aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/sirula/Makefile2
-rw-r--r--x11/sirula/files/patch-osstrtools11
2 files changed, 11 insertions, 2 deletions
diff --git a/x11/sirula/Makefile b/x11/sirula/Makefile
index 6760dbe031c0..405833ecafc0 100644
--- a/x11/sirula/Makefile
+++ b/x11/sirula/Makefile
@@ -11,8 +11,6 @@ WWW= https://github.com/DorianRudolph/sirula
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= could not compile osstrtools
-
LIB_DEPENDS= libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
USES= cargo gnome
diff --git a/x11/sirula/files/patch-osstrtools b/x11/sirula/files/patch-osstrtools
new file mode 100644
index 000000000000..3b367d97416b
--- /dev/null
+++ b/x11/sirula/files/patch-osstrtools
@@ -0,0 +1,11 @@
+--- cargo-crates/osstrtools-0.2.2/src/lib.rs.orig 2024-01-01 16:19:06 UTC
++++ cargo-crates/osstrtools-0.2.2/src/lib.rs
+@@ -751,7 +751,7 @@ impl WinOsStr for OsStr {
+
+ fn as_bytes<'s>(&'s self) -> &'s [u8] {
+ // This should be fine in any case, as OsStr is just a &[u8]
+- unsafe { (bytes as *const _).cast:() }
++ unsafe { (bytes as *const _).cast() }
+ }
+ }
+