aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/mailman/Makefile2
-rw-r--r--mail/mailman/files/pkg-install.in7
2 files changed, 5 insertions, 4 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index fcdcccd524ea..f1b32e203c1d 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
diff --git a/mail/mailman/files/pkg-install.in b/mail/mailman/files/pkg-install.in
index 589500e0823f..90d4f0584318 100644
--- a/mail/mailman/files/pkg-install.in
+++ b/mail/mailman/files/pkg-install.in
@@ -109,13 +109,14 @@ POST-INSTALL)
echo "---> Running assorted other checks"
if egrep -q "^[ \t]*MTA.*=.*Postfix" "%%MAILMANDIR%%/Mailman/mm_cfg.py" ; then
# run Postfix-specific checks
- if [ "x`${PKG_PREFIX}/sbin/postconf -h myhostname`" != "xlocalhost" ] \
- && ! egrep -q "^[ \t]*SMTPHOST.*=.*`${PKG_PREFIX}/sbin/postconf -h myhostname`" \
+ POSTCONF=$(PATH="${PKG_PREFIX}/sbin:/usr/sbin:/sbin:$PATH" which postconf)
+ if [ "x`${POSTCONF} -h myhostname`" != "xlocalhost" ] \
+ && ! egrep -q "^[ \t]*SMTPHOST.*=.*`${POSTCONF} -h myhostname`" \
"%%MAILMANDIR%%/Mailman/mm_cfg.py"
then
echo ""
echo "Your Postfix hostname is non-default."
- echo -n "You must add \"SMTPHOST = '`${PKG_PREFIX}/sbin/postconf -h myhostname`'"
+ echo -n "You must add \"SMTPHOST = '`${POSTCONF} -h myhostname`'"
echo "\" to the bottom of mm_cfg.py (without quotes)."
echo ""
fi