aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/py-z3-solver/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/math/py-z3-solver/Makefile b/math/py-z3-solver/Makefile
index 3426ee6af08a..f900b3ea09b4 100644
--- a/math/py-z3-solver/Makefile
+++ b/math/py-z3-solver/Makefile
@@ -10,12 +10,7 @@ COMMENT= Python binding for Z3 Theorem Prover
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
-CFLAGS_armv7= -fPIC
-CFLAGS_powerpc= -fPIC
-
-BROKEN_i386= can't create dynamic relocation R_386_32 against symbol: .L.str in readonly segment; see https://github.com/Z3Prover/z3/issues/2442
-
-# CAVEAT: There should have LIB_DEPENDS=libz3.so:math/z3, but currently it rebuilds all code, see https://github.com/Z3Prover/z3/issues/1767
+BROKEN_riscv64= fails to configure, see https://github.com/Z3Prover/z3/issues/6183
BUILD_DEPENDS= cmake:devel/cmake
@@ -26,8 +21,13 @@ USE_GITHUB= yes
GH_ACCOUNT= Z3Prover
GH_PROJECT= z3
+CFLAGS_armv7= -fPIC
+CFLAGS_powerpc= -fPIC
+
WRKSRC_SUBDIR= src/api/python
+# CAVEAT: There should have LIB_DEPENDS=libz3.so:math/z3, but currently it rebuilds all code, see https://github.com/Z3Prover/z3/issues/1767
+
post-patch: # https://github.com/Z3Prover/z3/issues/2131
@${REINPLACE_CMD} 's|…|...|' ${WRKSRC}/../../ast/recfun_decl_plugin.h