aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/gubby/Makefile2
-rw-r--r--mail/gubby/files/patch-include_die.h10
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/gubby/Makefile b/mail/gubby/Makefile
index 16869fefd01d..dcce909f22d5 100644
--- a/mail/gubby/Makefile
+++ b/mail/gubby/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= mich@FreeBSD.org
COMMENT= Program showing where new mail has been placed
+USES= ncurses
+
LDFLAGS+= -lncurses
CFLAGS+= -fno-exceptions -fno-rtti
diff --git a/mail/gubby/files/patch-include_die.h b/mail/gubby/files/patch-include_die.h
new file mode 100644
index 000000000000..746d2fe7864b
--- /dev/null
+++ b/mail/gubby/files/patch-include_die.h
@@ -0,0 +1,10 @@
+--- include/die.h.orig 2004-12-18 04:29:19 UTC
++++ include/die.h
+@@ -1,6 +1,7 @@
+ // Gubby
+ // csl@sublevel3.org
+
++#include <cstdlib>
+ #include <string>
+
+ void die(const std::string& s);