aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-RegExp/Makefile22
-rw-r--r--textproc/p5-XML-RegExp/distinfo1
-rw-r--r--textproc/p5-XML-RegExp/pkg-comment1
-rw-r--r--textproc/p5-XML-RegExp/pkg-descr15
-rw-r--r--textproc/p5-XML-RegExp/pkg-plist5
6 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6f8ac08681cd..31e968da397b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -160,6 +160,7 @@
SUBDIR += p5-XML-Node
SUBDIR += p5-XML-Parser
SUBDIR += p5-XML-RSS
+ SUBDIR += p5-XML-RegExp
SUBDIR += p5-XML-SAX
SUBDIR += p5-XML-SAX-Expat
SUBDIR += p5-XML-SAX-Writer
diff --git a/textproc/p5-XML-RegExp/Makefile b/textproc/p5-XML-RegExp/Makefile
new file mode 100644
index 000000000000..bb4944ab4e48
--- /dev/null
+++ b/textproc/p5-XML-RegExp/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: XML::RegExp
+# Date created: 7 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RegExp
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XML::RegExp.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-RegExp/distinfo b/textproc/p5-XML-RegExp/distinfo
new file mode 100644
index 000000000000..8aa066469726
--- /dev/null
+++ b/textproc/p5-XML-RegExp/distinfo
@@ -0,0 +1 @@
+MD5 (XML-RegExp-0.03.tar.gz) = 5826b24e0d05714e25c2bb04e1f1c09b
diff --git a/textproc/p5-XML-RegExp/pkg-comment b/textproc/p5-XML-RegExp/pkg-comment
new file mode 100644
index 000000000000..312860120ff4
--- /dev/null
+++ b/textproc/p5-XML-RegExp/pkg-comment
@@ -0,0 +1 @@
+Regular expressions for XML tokens
diff --git a/textproc/p5-XML-RegExp/pkg-descr b/textproc/p5-XML-RegExp/pkg-descr
new file mode 100644
index 000000000000..9cb3d730ee66
--- /dev/null
+++ b/textproc/p5-XML-RegExp/pkg-descr
@@ -0,0 +1,15 @@
+This package contains regular expressions for the following XML tokens:
+BaseChar, Ideographic, Letter, Digit, Extender, CombiningChar, NameChar,
+EntityRef, CharRef, Reference, Name, NmToken, and AttValue.
+
+The definitions of these tokens were taken from the XML spec
+(Extensible Markup Language 1.0) at http://www.w3.org/TR/REC-xml.
+
+Also contains the regular expressions for the following tokens from the
+XML Namespaces spec at http://www.w3.org/TR/REC-xml-names:
+NCNameChar, NCName, QName, Prefix and LocalPart.
+
+WWW: http://search.cpan.org/search?dist=XML-RegExp
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/textproc/p5-XML-RegExp/pkg-plist b/textproc/p5-XML-RegExp/pkg-plist
new file mode 100644
index 000000000000..670b15d0f15e
--- /dev/null
+++ b/textproc/p5-XML-RegExp/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/RegExp/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/RegExp.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/RegExp
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true