aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/portconf/Makefile2
-rw-r--r--ports-mgmt/portconf/files/portconf.sh.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/portconf/Makefile b/ports-mgmt/portconf/Makefile
index ae4f353849e6..73545bb40277 100644
--- a/ports-mgmt/portconf/Makefile
+++ b/ports-mgmt/portconf/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portconf
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portconf/files/portconf.sh.in b/ports-mgmt/portconf/files/portconf.sh.in
index 5a3ac83df3f9..bce47ff5c650 100644
--- a/ports-mgmt/portconf/files/portconf.sh.in
+++ b/ports-mgmt/portconf/files/portconf.sh.in
@@ -36,7 +36,7 @@ _pwd=`pwd`
sed '/^#/d;/^[[:space:]]*$/d' "${_conf}" | while read _line; do
for _port in ${_line%%:*}; do
if [ "${_pwd%%${_port}}" != "${_pwd}" ]; then
- echo ${_line#*:} | sed -E 's/([A-Za-z0-9_]+)(=([^|]+))?/\1=\3/g;s/!([A-Za-z0-9_]+)=([^|]+)?/.undef \1/g;s/ *\| */|/g;s/ /%/g'
+ echo ${_line#*:} | sed -E 's/([A-Za-z0-9_\-]+\+?)(=([^|]+))?/\1=\3/g;s/!([A-Za-z0-9_]+)=([^|]+)?/.undef \1/g;s/ *\| */|/g;s/ /%/g'
fi
done
done