aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-dnspython1/Makefile30
-rw-r--r--dns/py-dnspython1/distinfo3
-rw-r--r--dns/py-dnspython1/pkg-descr12
4 files changed, 46 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 58f59b673354..db2eeb488716 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -185,6 +185,7 @@
SUBDIR += py-dns-crawler
SUBDIR += py-dns-lexicon
SUBDIR += py-dnspython
+ SUBDIR += py-dnspython1
SUBDIR += py-dnspython2
SUBDIR += py-easyzone
SUBDIR += py-idna
diff --git a/dns/py-dnspython1/Makefile b/dns/py-dnspython1/Makefile
new file mode 100644
index 000000000000..c8b3b9c52c64
--- /dev/null
+++ b/dns/py-dnspython1/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= dnspython
+PORTVERSION= 1.16.0
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= DNS toolkit for Python - 1.x release
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:2.7 zip
+USE_PYTHON= autoplist concurrent cython distutils
+
+NO_ARCH= yes
+
+PORTEXAMPLES= ddns.py e164.py mx.py name.py reverse.py reverse_name.py xfr.py \
+ zonediff.py
+
+OPTIONS_DEFINE= EXAMPLES PYCRYPTODOME
+PYCRYPTODOME_DESC= Enable pycryptodome (part of dnssec needs it)
+PYCRYPTODOME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome>=0:security/py-pycryptodome@${PY_FLAVOR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/examples/,} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/dns/py-dnspython1/distinfo b/dns/py-dnspython1/distinfo
new file mode 100644
index 000000000000..88b7df39d17d
--- /dev/null
+++ b/dns/py-dnspython1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646069762
+SHA256 (dnspython-1.16.0.zip) = 36c5e8e38d4369a08b6780b7f27d790a292b2b08eea01607865bf0936c558e01
+SIZE (dnspython-1.16.0.zip) = 266364
diff --git a/dns/py-dnspython1/pkg-descr b/dns/py-dnspython1/pkg-descr
new file mode 100644
index 000000000000..7e8c1f540ae1
--- /dev/null
+++ b/dns/py-dnspython1/pkg-descr
@@ -0,0 +1,12 @@
+dnspython is a DNS toolkit for Python. It supports almost all record
+types. It can be used for queries, zone transfers, and dynamic
+updates. It supports TSIG authenticated messages and EDNS0.
+
+dnspython provides both high and low level access to DNS. The high
+level classes perform queries for data of a given name, type, and
+class, and return an answer set. The low level classes allow direct
+manipulation of DNS zones, messages, names, and records.
+
+This is 1.x version of the port which supports python 2.7
+
+WWW: http://www.dnspython.org/