aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-clipr/Makefile23
-rw-r--r--devel/R-cran-clipr/distinfo3
-rw-r--r--devel/R-cran-clipr/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a840ec32a99f..101673cd6776 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -28,6 +28,7 @@
SUBDIR += R-cran-chron
SUBDIR += R-cran-classInt
SUBDIR += R-cran-cli
+ SUBDIR += R-cran-clipr
SUBDIR += R-cran-covr
SUBDIR += R-cran-crayon
SUBDIR += R-cran-data.table
diff --git a/devel/R-cran-clipr/Makefile b/devel/R-cran-clipr/Makefile
new file mode 100644
index 000000000000..2a706ac93662
--- /dev/null
+++ b/devel/R-cran-clipr/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= clipr
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Read and Write from the System Clipboard
+
+LICENSE= GPLv3
+
+USES= cran:auto-plist
+
+OPTIONS_DEFINE= XCLIP XSEL
+OPTIONS_DEFAULT= XCLIP
+XCLIP_DESC= Use xclip for interacting with X11 clipboard
+XSEL_DESC= Use xsel for interacting with X11 clipboard
+
+XCLIP_RUN_DEPENDS= xclip:x11/xclip
+XSEL_RUN_DEPENDS= xsel:x11/xsel-conrad
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-clipr/distinfo b/devel/R-cran-clipr/distinfo
new file mode 100644
index 000000000000..8d7f66c16740
--- /dev/null
+++ b/devel/R-cran-clipr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1563070829
+SHA256 (clipr_0.6.0.tar.gz) = 55f4adaef46781c1c1e584a8840f2775efd026b138760d923833c95a678d334d
+SIZE (clipr_0.6.0.tar.gz) = 18855
diff --git a/devel/R-cran-clipr/pkg-descr b/devel/R-cran-clipr/pkg-descr
new file mode 100644
index 000000000000..bc76270eab38
--- /dev/null
+++ b/devel/R-cran-clipr/pkg-descr
@@ -0,0 +1,4 @@
+Simple utility functions to read from and write to the Windows, OS
+X, and X11 clipboards.
+
+WWW: https://cran.r-project.org/web/packages/clipr/