aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/chrpath/Makefile8
-rw-r--r--devel/chrpath/distinfo4
-rw-r--r--devel/chrpath/files/patch-Makefile.in43
-rw-r--r--devel/chrpath/files/patch-elf.c11
-rw-r--r--devel/chrpath/files/patch-protos.h30
-rw-r--r--devel/chrpath/files/patch-testsuite__Makefile.in6
6 files changed, 63 insertions, 39 deletions
diff --git a/devel/chrpath/Makefile b/devel/chrpath/Makefile
index 13dfcac513b6..8880692f87b6 100644
--- a/devel/chrpath/Makefile
+++ b/devel/chrpath/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= chrpath
-PORTVERSION= 0.13
-PORTREVISION= 2
+PORTVERSION= 0.16
CATEGORIES= devel sysutils
-MASTER_SITES= http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/
+MASTER_SITES= DEBIAN_POOL
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to modify DT_RPATH in existing ELF binaries
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/devel/chrpath/distinfo b/devel/chrpath/distinfo
index 326fb91e988f..87503d69e8e0 100644
--- a/devel/chrpath/distinfo
+++ b/devel/chrpath/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chrpath-0.13.tar.gz) = c1aa5342eac0daad81b8da05aa282ae1ccd6f68bc75ca94064304f541eed071b
-SIZE (chrpath-0.13.tar.gz) = 125129
+SHA256 (chrpath_0.16.orig.tar.gz) = bb0d4c54bac2990e1bdf8132f2c9477ae752859d523e141e72b3b11a12c26e7b
+SIZE (chrpath_0.16.orig.tar.gz) = 134506
diff --git a/devel/chrpath/files/patch-Makefile.in b/devel/chrpath/files/patch-Makefile.in
index f7d89f50c376..30f3dd2fc3ba 100644
--- a/devel/chrpath/files/patch-Makefile.in
+++ b/devel/chrpath/files/patch-Makefile.in
@@ -1,27 +1,30 @@
---- Makefile.in.orig 2004-09-19 12:42:53.000000000 +0400
-+++ Makefile.in 2010-06-20 12:55:59.000000000 +0400
-@@ -66,7 +66,7 @@
-
- SUBDIRS = testsuite deb
-
+--- Makefile.in.orig 2014-01-12 09:03:45.000000000 +0100
++++ Makefile.in 2016-02-03 19:32:36.764942000 +0100
+@@ -243,7 +243,7 @@
+ builddir = @builddir@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
+docdir = $(prefix)/share/doc/$(PACKAGE)
-
- doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
-
-@@ -263,16 +263,6 @@
-
+ dvidir = @dvidir@
+ exec_prefix = @exec_prefix@
+ host = @host@
+@@ -457,19 +457,6 @@
+ dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
install-docDATA: $(doc_DATA)
@$(NORMAL_INSTALL)
-- $(mkinstalldirs) $(DESTDIR)$(docdir)
-- @list='$(doc_DATA)'; for p in $$list; do \
-- if test -f $(srcdir)/$$p; then \
-- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(docdir)/$$p; \
-- else if test -f $$p; then \
-- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p"; \
-- $(INSTALL_DATA) $$p $(DESTDIR)$(docdir)/$$p; \
-- fi; fi; \
+- @list='$(doc_DATA)'; test -n "$(docdir)" || list=; \
+- if test -n "$$list"; then \
+- echo " $(MKDIR_P) '$(DESTDIR)$(docdir)'"; \
+- $(MKDIR_P) "$(DESTDIR)$(docdir)" || exit 1; \
+- fi; \
+- for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- echo "$$d$$p"; \
+- done | $(am__base_list) | \
+- while read files; do \
+- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(docdir)'"; \
+- $(INSTALL_DATA) $$files "$(DESTDIR)$(docdir)" || exit $$?; \
- done
uninstall-docDATA:
diff --git a/devel/chrpath/files/patch-elf.c b/devel/chrpath/files/patch-elf.c
deleted file mode 100644
index 340cae861a9e..000000000000
--- a/devel/chrpath/files/patch-elf.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- elf.c.orig 2003-12-19 21:07:00.000000000 +0000
-+++ elf.c 2009-12-01 20:39:21.000000000 +0000
-@@ -55,7 +55,7 @@
- if (ehdr->e_phentsize != sizeof(Elf_Phdr))
- {
- fprintf(stderr, "section size was read as %d, not %d!\n",
-- ehdr->e_phentsize, sizeof(Elf_Phdr));
-+ ehdr->e_phentsize, (int)sizeof(Elf_Phdr));
- close(fd);
- return -1;
- }
diff --git a/devel/chrpath/files/patch-protos.h b/devel/chrpath/files/patch-protos.h
new file mode 100644
index 000000000000..a5c0810e0ed9
--- /dev/null
+++ b/devel/chrpath/files/patch-protos.h
@@ -0,0 +1,30 @@
+--- protos.h.orig 2013-11-24 08:30:01.000000000 +0100
++++ protos.h 2016-02-03 19:47:21.946096000 +0100
+@@ -1,7 +1,14 @@
+ #ifndef PROTOS_H
+ #define PROTOS_H
+
++#ifdef __FreeBSD__
++#include <sys/endian.h>
++#define bswap_16 bswap16
++#define bswap_32 bswap32
++#define bswap_64 bswap64
++#else
+ #include <byteswap.h>
++#endif
+ #include <elf.h>
+ #include "config.h"
+
+@@ -14,6 +21,12 @@
+ #error "Unknown word size (SIZEOF_VOID_P)!"
+ #endif
+
++#ifdef __FreeBSD__
++#define Elf_Ehdr Elf__Ehdr
++#define Elf_Shdr Elf__Shdr
++#define Elf_Phdr Elf__Phdr
++#endif
++
+ typedef union {
+ unsigned char e_ident[EI_NIDENT];
+ Elf32_Ehdr e32;
diff --git a/devel/chrpath/files/patch-testsuite__Makefile.in b/devel/chrpath/files/patch-testsuite__Makefile.in
index ed84c486828f..302f5bf4feb3 100644
--- a/devel/chrpath/files/patch-testsuite__Makefile.in
+++ b/devel/chrpath/files/patch-testsuite__Makefile.in
@@ -1,6 +1,6 @@
---- ./testsuite/Makefile.in.orig 2004-09-19 10:42:53.000000000 +0200
-+++ ./testsuite/Makefile.in 2014-04-04 15:32:16.000000000 +0200
-@@ -259,7 +259,7 @@
+--- testsuite/Makefile.in.orig 2014-01-12 09:03:45.000000000 +0100
++++ testsuite/Makefile.in 2016-02-03 19:34:07.381487000 +0100
+@@ -457,7 +457,7 @@
prog: prog.c