aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql-devel-server/Makefile6
-rw-r--r--databases/postgresql7/Makefile6
-rw-r--r--databases/postgresql74-server/Makefile6
-rw-r--r--databases/postgresql80-server/Makefile6
-rw-r--r--databases/postgresql81-server/Makefile6
-rw-r--r--databases/postgresql82-server/Makefile6
-rw-r--r--databases/postgresql83-server/Makefile6
-rw-r--r--databases/postgresql84-server/Makefile6
-rw-r--r--databases/postgresql90-server/Makefile6
-rw-r--r--databases/postgresql91-server/Makefile6
-rw-r--r--databases/postgresql92-server/Makefile6
11 files changed, 33 insertions, 33 deletions
diff --git a/databases/postgresql-devel-server/Makefile b/databases/postgresql-devel-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql-devel-server/Makefile
+++ b/databases/postgresql-devel-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql7/Makefile b/databases/postgresql7/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql7/Makefile
+++ b/databases/postgresql7/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql80-server/Makefile
+++ b/databases/postgresql80-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 63c4b73098a2..14f37207f566 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/postgresql-${PORTVERSION}
DIST_SUBDIR= postgresql
USE_BZIP2= YES
-USE_GETTEXT= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
@@ -46,9 +45,10 @@ CONFIGURE_ARGS+= --with-pam
USE_GETOPT_LONG=yes
.endif
-.if !defined(WITHOUT_GETTEXT)
+.if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
+USE_GETTEXT= YES
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= GETTEXT="@comment "
@@ -149,7 +149,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_GNUGETOPT Don't install GNU getopt (will"
@${ECHO} " still be used if already installed)"
- @${ECHO} " WITHOUT_GETTEXT Skips building with support for"
+ @${ECHO} " WITHOUT_NLS Skips building with support for"
@${ECHO} " internationalized error messages"
@${ECHO} " WITHOUT_SERVER Don't install the server,"
@${ECHO} " only install binaries, headers and libs"