aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/distinfo6
-rw-r--r--www/firefox-esr/files/patch-bug174556026
3 files changed, 4 insertions, 30 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index e63ef50fff78..bab993896d68 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -1,7 +1,7 @@
# Created by: Alan Eldridge <alane@FreeBSD.org>
PORTNAME= firefox
-DISTVERSION= 91.5.1
+DISTVERSION= 91.6.0
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index d5b58e0401a4..49dfccdd78de 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643404085
-SHA256 (firefox-91.5.1esr.source.tar.xz) = 36049694505ff5edd1a086480e5a3d29fedd3f0b0d4a8a27a271a66e8fc6cd1f
-SIZE (firefox-91.5.1esr.source.tar.xz) = 388976720
+TIMESTAMP = 1643733463
+SHA256 (firefox-91.6.0esr.source.tar.xz) = 7e802832152c39588b9a5c8392e90c1b00036bf948fa4a97a7af0d1435ba09a1
+SIZE (firefox-91.6.0esr.source.tar.xz) = 386869628
diff --git a/www/firefox-esr/files/patch-bug1745560 b/www/firefox-esr/files/patch-bug1745560
deleted file mode 100644
index 15cfb73d5fae..000000000000
--- a/www/firefox-esr/files/patch-bug1745560
+++ /dev/null
@@ -1,26 +0,0 @@
-https://hg.mozilla.org/mozilla-central/rev/f7e2cf808d30
-
-ld: warning: undefined symbol: wl_proxy_marshal_flags
->>> referenced by Unified_cpp_gfx_gl0.cpp
->>> objdir/gfx/gl/Unified_cpp_gfx_gl0.o:(mozilla::gl::DeleteWaylandGLSurface(void*))
->>> referenced by Unified_cpp_gfx_gl0.cpp
->>> objdir/gfx/gl/Unified_cpp_gfx_gl0.o:(mozilla::gl::GLContextEGL::CreateWaylandBufferSurface(mozilla::gl::EglDisplay&, void*, mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits>&))
->>> referenced by Unified_cpp_gfx_layers1.cpp
->>> objdir/gfx/layers/Unified_cpp_gfx_layers1.o:(mozilla::layers::NativeLayerRootWayland::CommitToScreen(mozilla::detail::BaseAutoLock<mozilla::Mutex&> const&))
->>> referenced 84 more times
-
-diff --git widget/gtk/mozwayland/mozwayland.c widget/gtk/mozwayland/mozwayland.c
-index 7a448e6321e2..1a86468b4f3d 100644
---- widget/gtk/mozwayland/mozwayland.c
-+++ widget/gtk/mozwayland/mozwayland.c
-@@ -200,3 +200,10 @@ MOZ_EXPORT int wl_list_empty(const struct wl_list* list) { return -1; }
-
- MOZ_EXPORT void wl_list_insert_list(struct wl_list* list,
- struct wl_list* other) {}
-+
-+MOZ_EXPORT struct wl_proxy* wl_proxy_marshal_flags(
-+ struct wl_proxy* proxy, uint32_t opcode,
-+ const struct wl_interface* interface, uint32_t version, uint32_t flags,
-+ ...) {
-+ return NULL;
-+}