aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Algorithm-ChooseSubsets/Makefile9
-rw-r--r--devel/p5-Config-IniRegEx/Makefile9
-rw-r--r--devel/p5-Danga-Socket-Callback/Makefile3
-rw-r--r--devel/p5-Data-Dumper-Perltidy/Makefile9
-rw-r--r--devel/p5-Data-Rand/Makefile4
-rw-r--r--devel/p5-Devel-Autoflush/Makefile9
-rw-r--r--devel/p5-JIRA-Client/Makefile9
-rw-r--r--devel/p5-Mknod/Makefile9
-rw-r--r--devel/p5-Module-Install-AuthorRequires/Makefile8
-rw-r--r--devel/p5-Module-Install-AuthorTests/Makefile8
-rw-r--r--devel/p5-Number-Bytes-Human/Makefile9
-rw-r--r--devel/p5-Params-Coerce/Makefile9
-rw-r--r--devel/p5-PerlIO-via-symlink/Makefile9
-rw-r--r--devel/p5-SVN-Statistics/Makefile9
-rw-r--r--devel/p5-Sys-Sendfile-FreeBSD/Makefile9
-rw-r--r--devel/p5-Test-Compile/Makefile3
-rw-r--r--devel/p5-Text-Outdent/Makefile9
-rw-r--r--devel/p5-Tie-Restore/Makefile9
-rw-r--r--devel/p5-common-sense/Makefile9
19 files changed, 52 insertions, 100 deletions
diff --git a/devel/p5-Algorithm-ChooseSubsets/Makefile b/devel/p5-Algorithm-ChooseSubsets/Makefile
index 9cde2846c36e..86136d8e0c7a 100644
--- a/devel/p5-Algorithm-ChooseSubsets/Makefile
+++ b/devel/p5-Algorithm-ChooseSubsets/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Algorithm::ChooseSubsets
-# Date created: 04 Mar 2005
-# Whom: lars.eggert@gmx.net
-#
+# Created by: lars.eggert@gmx.net
# $FreeBSD$
-#
PORTNAME= Algorithm-ChooseSubsets
PORTVERSION= 0.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lars.eggert@gmx.net
COMMENT= Perl algorithm to iterate through subsets of a list
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Algorithm::ChooseSubsets.3
diff --git a/devel/p5-Config-IniRegEx/Makefile b/devel/p5-Config-IniRegEx/Makefile
index eefcca64b026..b93e93041be7 100644
--- a/devel/p5-Config-IniRegEx/Makefile
+++ b/devel/p5-Config-IniRegEx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Config-IniRegEx
-# Date created: 2009-01-30
-# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
-#
+# Created by: Murilo Opsfelder <mopsfelder@gmail.com>
# $FreeBSD$
-#
PORTNAME= Config-IniRegEx
PORTVERSION= 0.01
@@ -16,7 +12,8 @@ COMMENT= Ini workaround, regex search for parameters and sections
RUN_DEPENDS= p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::IniRegEx.3
diff --git a/devel/p5-Danga-Socket-Callback/Makefile b/devel/p5-Danga-Socket-Callback/Makefile
index 4e5160ede3f7..a922419f3a1d 100644
--- a/devel/p5-Danga-Socket-Callback/Makefile
+++ b/devel/p5-Danga-Socket-Callback/Makefile
@@ -18,7 +18,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Danga-Socket>=0:${PORTSDIR}/devel/p5-Danga-Socket
RUN_DEPENDS= p5-Danga-Socket>=0:${PORTSDIR}/devel/p5-Danga-Socket
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Danga::Socket::Callback.3
diff --git a/devel/p5-Data-Dumper-Perltidy/Makefile b/devel/p5-Data-Dumper-Perltidy/Makefile
index a0912643ba6d..8117f29dc22c 100644
--- a/devel/p5-Data-Dumper-Perltidy/Makefile
+++ b/devel/p5-Data-Dumper-Perltidy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Dumper-Perltidy
-# Date created: 2009-01-30
-# Whom: Murilo Opsfelder <mopsfelder@gmail.com>
-#
+# Created by: Murilo Opsfelder <mopsfelder@gmail.com>
# $FreeBSD$
-#
PORTNAME= Data-Dumper-Perltidy
PORTVERSION= 0.01
@@ -16,7 +12,8 @@ COMMENT= Stringify and pretty print Perl data structures
RUN_DEPENDS= perltidy>=0:${PORTSDIR}/devel/perltidy
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Dumper::Perltidy.3
diff --git a/devel/p5-Data-Rand/Makefile b/devel/p5-Data-Rand/Makefile
index 441e9209cc0c..ecb7eae2b2da 100644
--- a/devel/p5-Data-Rand/Makefile
+++ b/devel/p5-Data-Rand/Makefile
@@ -1,5 +1,4 @@
# $FreeBSD$
-#
PORTNAME= Data-Rand
PORTVERSION= 0.0.4
@@ -13,7 +12,8 @@ COMMENT= Perl module for generating random strings or arrays
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Data::Rand.3
diff --git a/devel/p5-Devel-Autoflush/Makefile b/devel/p5-Devel-Autoflush/Makefile
index 2459e85faa79..90a9d999bd06 100644
--- a/devel/p5-Devel-Autoflush/Makefile
+++ b/devel/p5-Devel-Autoflush/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Devel-Autoflush
-# Date created: 2011-02-04
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Devel-Autoflush
PORTVERSION= 0.05
@@ -20,6 +16,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Devel::Autoflush.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-JIRA-Client/Makefile b/devel/p5-JIRA-Client/Makefile
index cf67ec6ff253..88b0472126b8 100644
--- a/devel/p5-JIRA-Client/Makefile
+++ b/devel/p5-JIRA-Client/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: JIRA::Client
-# Date created: 2009-04-28
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= JIRA-Client
PORTVERSION= 0.25
@@ -18,7 +14,8 @@ COMMENT= An extended interface to JIRA's SOAP API
RUN_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PROJECTHOST= jira-client
MAN3= JIRA::Client.3
diff --git a/devel/p5-Mknod/Makefile b/devel/p5-Mknod/Makefile
index 3ffc0f576ea5..186aa971105c 100644
--- a/devel/p5-Mknod/Makefile
+++ b/devel/p5-Mknod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Mknod
-# Date created: 3 November 2004
-# Whom: Sean Farley <sean-freebsd@farley.org>
-#
+# Created by: Sean Farley <sean-freebsd@farley.org>
# $FreeBSD$
-#
PORTNAME= Mknod
PORTVERSION= 0.02
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sean-freebsd@farley.org
COMMENT= Perl module interface to the mknod(2) system call
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MANPREFIX= ${SITE_PERL}
MAN3= Mknod.3
diff --git a/devel/p5-Module-Install-AuthorRequires/Makefile b/devel/p5-Module-Install-AuthorRequires/Makefile
index 10e044e36c45..972aed2974b5 100644
--- a/devel/p5-Module-Install-AuthorRequires/Makefile
+++ b/devel/p5-Module-Install-AuthorRequires/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Module::Install::AuthorRequires
-# Date created: 09 Sep 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Module-Install-AuthorRequires
PORTVERSION= 0.02
@@ -18,7 +13,8 @@ RUN_DEPENDS= \
p5-Module-Install>0:${PORTSDIR}/devel/p5-Module-Install
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Module::Install::AuthorRequires.3
diff --git a/devel/p5-Module-Install-AuthorTests/Makefile b/devel/p5-Module-Install-AuthorTests/Makefile
index 2295cb966455..e8b0479927ae 100644
--- a/devel/p5-Module-Install-AuthorTests/Makefile
+++ b/devel/p5-Module-Install-AuthorTests/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Module::Install::AuthorTests
-# Date created: 22 Jan 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Module-Install-AuthorTests
PORTVERSION= 0.002
@@ -18,7 +13,8 @@ RUN_DEPENDS= \
p5-Module-Install>0:${PORTSDIR}/devel/p5-Module-Install
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Module::Install::AuthorTests.3
diff --git a/devel/p5-Number-Bytes-Human/Makefile b/devel/p5-Number-Bytes-Human/Makefile
index 3eebf84b9afc..3649d6031497 100644
--- a/devel/p5-Number-Bytes-Human/Makefile
+++ b/devel/p5-Number-Bytes-Human/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Number::Bytes::Human
-# Date created: 2006-10-19
-# Whom: Sulev-Madis Silber <madis555@hot.ee>
-#
+# Created by: Sulev-Madis Silber <madis555@hot.ee>
# $FreeBSD$
-#
PORTNAME= Number-Bytes-Human
PORTVERSION= 0.07
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= madis555@hot.ee
COMMENT= Convert byte count to human readable format
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Number::Bytes::Human.3
diff --git a/devel/p5-Params-Coerce/Makefile b/devel/p5-Params-Coerce/Makefile
index 50f07645d4f0..e3a31801be6d 100644
--- a/devel/p5-Params-Coerce/Makefile
+++ b/devel/p5-Params-Coerce/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Params-Coerce
-# Date created: 08 September 2007
-# Whom: Cory R. King <coryking@mozimedia.com>
-#
+# Created by: Cory R. King <coryking@mozimedia.com>
# $FreeBSD$
-#
PORTNAME= Params-Coerce
PORTVERSION= 0.14
@@ -18,7 +14,8 @@ COMMENT= Allows your classes to do coercion of parameters (Params::Coerce)
BUILD_DEPENDS= p5-Params-Util>=0.20:${PORTSDIR}/devel/p5-Params-Util
RUN_DEPENDS= p5-Params-Util>=0.20:${PORTSDIR}/devel/p5-Params-Util
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Params::Coerce.3
diff --git a/devel/p5-PerlIO-via-symlink/Makefile b/devel/p5-PerlIO-via-symlink/Makefile
index 7c965a9c4b5a..0c3413c281d2 100644
--- a/devel/p5-PerlIO-via-symlink/Makefile
+++ b/devel/p5-PerlIO-via-symlink/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-PerlIO-via-symlink
-# Date created: Aug 05 2004
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= PerlIO-via-symlink
PORTVERSION= 0.05
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Symbolic link PerlIO layers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PerlIO::via::symlink.3
diff --git a/devel/p5-SVN-Statistics/Makefile b/devel/p5-SVN-Statistics/Makefile
index e501b32b03b8..21bb5868a1b6 100644
--- a/devel/p5-SVN-Statistics/Makefile
+++ b/devel/p5-SVN-Statistics/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-SVN-Statistics
-# Date created: 2006-07-12
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
# $FreeBSD$
-#
PORTNAME= SVN-Statistics
PORTVERSION= 0.041
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-IO-Toolkit>=0:${PORTSDIR}/devel/p5-IO-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Statistics.3
diff --git a/devel/p5-Sys-Sendfile-FreeBSD/Makefile b/devel/p5-Sys-Sendfile-FreeBSD/Makefile
index 327c439cf685..9ea6941424df 100644
--- a/devel/p5-Sys-Sendfile-FreeBSD/Makefile
+++ b/devel/p5-Sys-Sendfile-FreeBSD/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Sys::Sendfile::FreeBSD
-# Date created: Jan 21, 2009
-# Whom: Mykola Marzhan <delgod@portaone.com>
-#
+# Created by: Mykola Marzhan <delgod@portaone.com>
# $FreeBSD$
-#
PORTNAME= Sys-Sendfile-FreeBSD
PORTVERSION= 0.01
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= delgod@portaone.com
COMMENT= Wrapper for the FreeBSD sendfile(2) function
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sys::Sendfile::FreeBSD.3
diff --git a/devel/p5-Test-Compile/Makefile b/devel/p5-Test-Compile/Makefile
index 87765930a175..6ebda2837f63 100644
--- a/devel/p5-Test-Compile/Makefile
+++ b/devel/p5-Test-Compile/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Devel-CheckOS>=0:${PORTSDIR}/devel/p5-Devel-CheckOS \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Compile.3 Test::Compile::Internal.3
diff --git a/devel/p5-Text-Outdent/Makefile b/devel/p5-Text-Outdent/Makefile
index 8cb4b8c24ec5..8eb20f5ee9b8 100644
--- a/devel/p5-Text-Outdent/Makefile
+++ b/devel/p5-Text-Outdent/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Text-Outdent
-# Date created: 2011-01-13
-# Whom: Kurt Lidl <kurt.lidl@cello.com>
-#
+# Created by: Kurt Lidl <kurt.lidl@cello.com>
# $FreeBSD$
-#
PORTNAME= Text-Outdent
PORTVERSION= 0.01
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kurt.lidl@cello.com
COMMENT= Strip leading whitespace from here-docs
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Outdent.3
diff --git a/devel/p5-Tie-Restore/Makefile b/devel/p5-Tie-Restore/Makefile
index 00e6917626ac..e473c5ba22c3 100644
--- a/devel/p5-Tie-Restore/Makefile
+++ b/devel/p5-Tie-Restore/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Tie-Restore
-# Date created: April 19th 2006
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Tie-Restore
PORTVERSION= 0.11
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Restores ties to an existing object
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tie::Restore.3
diff --git a/devel/p5-common-sense/Makefile b/devel/p5-common-sense/Makefile
index 767b27d2b586..03c39e4f0d0e 100644
--- a/devel/p5-common-sense/Makefile
+++ b/devel/p5-common-sense/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-common-sense
-# Date created: 2009-08-12
-# Whom: Mons Anderson <mons@cpan.org>
-#
+# Created by: Mons Anderson <mons@cpan.org>
# $FreeBSD$
-#
PORTNAME= common-sense
PORTVERSION= 3.6
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mons@cpan.org
COMMENT= Perl common defaults with lower memory usage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= common::sense.3