aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/pear-PHP_UML/Makefile8
-rw-r--r--devel/pear-PHP_UML/pkg-descr9
2 files changed, 11 insertions, 6 deletions
diff --git a/devel/pear-PHP_UML/Makefile b/devel/pear-PHP_UML/Makefile
index 76b392ebd04a..016e12ee94d8 100644
--- a/devel/pear-PHP_UML/Makefile
+++ b/devel/pear-PHP_UML/Makefile
@@ -9,11 +9,11 @@ COMMENT= PEAR Class to Create UML Representation of PHP Code
LICENSE= LGPL3
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear@${PHP_FLAVOR} \
- ${PEARDIR}/Console/CommandLine.php:devel/pear-Console_CommandLine@${PHP_FLAVOR}
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Console_CommandLine>=0:devel/pear-Console_CommandLine@${PHP_FLAVOR}
-USES= pear php
+USES= pear
USE_PHP= spl xsl
+NO_ARCH= yes
+
.include <bsd.port.mk>
diff --git a/devel/pear-PHP_UML/pkg-descr b/devel/pear-PHP_UML/pkg-descr
index 1fb139a9848b..614e706eb2bd 100644
--- a/devel/pear-PHP_UML/pkg-descr
+++ b/devel/pear-PHP_UML/pkg-descr
@@ -1,4 +1,9 @@
-PHP_UML is a reverse-engineering package that scans PHP files and directories,
-and delivers an UML/XMI representation of the classes and packages found.
+PHP_UML is a PHP parser, an XMI generator and a documentation tool.
+
+Practically, with PHP_UML, you will be able to feed a UML CASE tool, like
+Rational Rose or Argouml, with a UML representation of existing PHP source code.
+This way, you get an instant overview of a PHP application, with all the usual
+functions of a software design tool (such as class diagrams exportation,
+refactoring of object-oriented applications, or automatic code generation).
WWW: https://pear.php.net/package/PHP_UML