aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/Makefile1
-rw-r--r--irc/tircd/Makefile49
-rw-r--r--irc/tircd/distinfo3
-rw-r--r--irc/tircd/files/tircd.sh.in27
-rw-r--r--irc/tircd/pkg-descr12
-rw-r--r--irc/tircd/pkg-plist4
6 files changed, 96 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 6236361da7c0..270a09fbff65 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -130,6 +130,7 @@
SUBDIR += srvx
SUBDIR += talksoup
SUBDIR += thales
+ SUBDIR += tircd
SUBDIR += tircproxy
SUBDIR += tkirc
SUBDIR += tr-ircd
diff --git a/irc/tircd/Makefile b/irc/tircd/Makefile
new file mode 100644
index 000000000000..05414ddf6699
--- /dev/null
+++ b/irc/tircd/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: tircd
+# Date created: 6th March 2010
+# Whom: Gavin Atkinson <gavin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tircd
+PORTVERSION= 0.10
+CATEGORIES= irc
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gavin@FreeBSD.org
+COMMENT= IRC proxy to Twitter
+
+RUN_DEPENDS= p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Time-Local>=0:${PORTSDIR}/devel/p5-Time-Local \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
+ p5-Net-Twitter-Lite>=0:${PORTSDIR}/net/p5-Net-Twitter-Lite \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Filter-IRCD>=0:${PORTSDIR}/irc/p5-POE-Filter-IRCD
+
+WRKSRC= ${WRKDIR}/tircd
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= tircd.1
+USE_RC_SUBR= tircd.sh
+
+post-patch:
+ ${REINPLACE_CMD} -e '1s,^#!/usr/bin/perl,#!${PREFIX}/bin/perl,' \
+ -e 's,/etc/tircd.cfg,${PREFIX}/etc/tircd.cfg,g' \
+ ${WRKSRC}/tircd.pl ${WRKSRC}/tircd.pod
+ pod2man ${WRKSRC}/tircd.pod > ${WRKSRC}/tircd.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tircd.pl ${PREFIX}/bin/tircd.pl
+ ${INSTALL_MAN} ${WRKSRC}/tircd.1 ${MAN1PREFIX}/man/man1/tircd.1
+ ${INSTALL_DATA} ${WRKSRC}/tircd.cfg.example ${PREFIX}/etc/tircd.cfg.example
+ @if [ ! -f ${PREFIX}/etc/tircd.cfg ]; then \
+ ${CP} -p ${PREFIX}/etc/tircd.cfg.example ${PREFIX}/etc/tircd.cfg ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/irc/tircd/distinfo b/irc/tircd/distinfo
new file mode 100644
index 000000000000..48c8e8667bce
--- /dev/null
+++ b/irc/tircd/distinfo
@@ -0,0 +1,3 @@
+MD5 (tircd_v0.10.tgz) = b98d8dfac4aec44327f65e5643b5af34
+SHA256 (tircd_v0.10.tgz) = 81f5ea5441af71d242acc4c2e98757e26005f19235752e8053193bab2aecea54
+SIZE (tircd_v0.10.tgz) = 26766
diff --git a/irc/tircd/files/tircd.sh.in b/irc/tircd/files/tircd.sh.in
new file mode 100644
index 000000000000..437cbd9c5c99
--- /dev/null
+++ b/irc/tircd/files/tircd.sh.in
@@ -0,0 +1,27 @@
+#! /bin/sh
+# $FreeBSD$
+#
+# PROVIDE: tircd
+# REQUIRE: LOGIN syslogd
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# tircd_enable (bool): Set to NO by default.
+# Set it to YES to enable tircd.
+
+. %%RC_SUBR%%
+
+name="tircd"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/bin/$name.pl"
+command_args="> /dev/null &"
+required_files="%%PREFIX%%/etc/tircd.cfg"
+
+load_rc_config $name
+
+: ${tircd_enable="NO"}
+
+run_rc_command "$1"
diff --git a/irc/tircd/pkg-descr b/irc/tircd/pkg-descr
new file mode 100644
index 000000000000..56882a3dfae3
--- /dev/null
+++ b/irc/tircd/pkg-descr
@@ -0,0 +1,12 @@
+tircd presents Twitter as an irc channel. You can connect to tircd
+with any IRC client, and tweet as if you were on IRC. The daemon
+supports authentication via OAuth or standard http and https
+authentication, and supports direct messages, automatic URL shortening,
+and Twitter searching.
+
+Quickstart: in irssi, "/connect localhost 6667 twitpass twituser"
+and join #twitter
+
+ - @gavinatkinson
+
+WWW: http://code.google.com/p/tircd/
diff --git a/irc/tircd/pkg-plist b/irc/tircd/pkg-plist
new file mode 100644
index 000000000000..5accc5993496
--- /dev/null
+++ b/irc/tircd/pkg-plist
@@ -0,0 +1,4 @@
+bin/tircd.pl
+@unexec if cmp -s %D/etc/tircd.cfg.example %D/etc/tircd.cfg; then rm -f %D/etc/tircd.cfg; fi
+etc/tircd.cfg.example
+@exec if [ ! -f %D/etc/tircd.cfg ] ; then cp -p %D/%F %B/tircd.cfg; fi