aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pear-MDB2_Driver_mysql/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile1
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile2
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile2
-rw-r--r--databases/pecl-rrd/Makefile1
-rw-r--r--devel/aphpunit/Makefile2
-rw-r--r--devel/pear-PEAR_Info/Makefile2
-rw-r--r--devel/pecl-jsmin/Makefile1
-rw-r--r--devel/pecl-msgpack/Makefile2
-rw-r--r--devel/pecl-propro2/Makefile1
-rw-r--r--devel/pecl-raphf2/Makefile1
-rw-r--r--devel/pecl-request/Makefile2
-rw-r--r--devel/pecl-swoole/Makefile1
-rw-r--r--devel/pecl-uv/Makefile2
-rw-r--r--devel/pecl-vld/Makefile2
-rw-r--r--devel/pecl-xdebug-devel/Makefile2
-rw-r--r--devel/pecl-xdebug/Makefile2
-rw-r--r--devel/pecl-yac/Makefile2
-rw-r--r--devel/pecl-yaconf/Makefile2
-rw-r--r--lang/php71-extensions/Makefile2
-rw-r--r--lang/php71/Makefile.ext2
-rw-r--r--lang/php72-extensions/Makefile2
-rw-r--r--lang/php72/Makefile.ext2
-rw-r--r--lang/php73-extensions/Makefile2
-rw-r--r--lang/php73/Makefile.ext2
-rw-r--r--mail/pecl-mailparse/Makefile1
-rw-r--r--math/pecl-stats2/Makefile1
-rw-r--r--net-im/pecl-stomp2/Makefile1
-rw-r--r--net/pecl-oauth2/Makefile1
-rw-r--r--security/pecl-mcrypt/Makefile2
-rw-r--r--security/pecl-ssh2/Makefile1
-rw-r--r--security/snuffleupagus/Makefile2
-rw-r--r--textproc/pecl-xdiff2/Makefile1
-rw-r--r--textproc/pecl-yaml/Makefile1
-rw-r--r--www/mediawiki131/Makefile2
-rw-r--r--www/moodle34/Makefile2
-rw-r--r--www/moodle35/Makefile2
-rw-r--r--www/moodle36/Makefile2
-rw-r--r--www/pecl-http/Makefile1
-rw-r--r--www/typo3-8/Makefile2
-rw-r--r--www/typo3-9/Makefile2
42 files changed, 14 insertions, 56 deletions
diff --git a/databases/pear-MDB2_Driver_mysql/Makefile b/databases/pear-MDB2_Driver_mysql/Makefile
index 6d9f7473979f..c3fe4541c1db 100644
--- a/databases/pear-MDB2_Driver_mysql/Makefile
+++ b/databases/pear-MDB2_Driver_mysql/Makefile
@@ -10,8 +10,6 @@ COMMENT= PEAR MySQL MDB2 driver
LICENSE= BSD3CLAUSE
-IGNORE_WITH_PHP= 56
-
BUILD_DEPENDS= ${PEAR_PKGNAMEPREFIX}MDB2>=0:databases/pear-MDB2@${PHP_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
index e2a8d7bafd25..def33729b607 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
@@ -10,8 +10,6 @@ COMMENT= DataSource driver using PEAR::DB and an SQL query
LICENSE= BSD2CLAUSE
-IGNORE_WITH_PHP= 56
-
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
index c3e5975dbabe..71bbde637da4 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
@@ -17,7 +17,6 @@ RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@$
USES= pear
USE_PHP= mysqli
-IGNORE_WITH_PHP= 56
NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
index 545e3a01ac97..d62cc07ba7e3 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
@@ -10,8 +10,6 @@ COMMENT= DataSource driver using PEAR::DB_DataObject
LICENSE= BSD2CLAUSE
-IGNORE_WITH_PHP= 56
-
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/DB/DataObject.php:databases/pear-DB_DataObject@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
index f86047865f7e..4ee38e66837c 100644
--- a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
@@ -10,8 +10,6 @@ COMMENT= DataSource driver using PEAR::MDB2 and an SQL query
LICENSE= BSD2CLAUSE
-IGNORE_WITH_PHP= 56
-
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:devel/pear-Structures_DataGrid@${PHP_FLAVOR} \
diff --git a/databases/pecl-rrd/Makefile b/databases/pecl-rrd/Makefile
index d20de02cf563..4ffc491e9e80 100644
--- a/databases/pecl-rrd/Makefile
+++ b/databases/pecl-rrd/Makefile
@@ -10,7 +10,6 @@ COMMENT= PHP bindings to rrd tool system
LICENSE= PHP301
-IGNORE_WITH_PHP=56
LIB_DEPENDS= librrd.so:databases/rrdtool
USES= php:pecl localbase pkgconfig
diff --git a/devel/aphpunit/Makefile b/devel/aphpunit/Makefile
index f332cda8e39a..dc8136ef5bc6 100644
--- a/devel/aphpunit/Makefile
+++ b/devel/aphpunit/Makefile
@@ -12,8 +12,6 @@ COMMENT= Testing framework for unit tests
LICENSE= BSD2CLAUSE
-IGNORE_WITH_PHP= 56
-
USES= php:flavors
USE_PHP= mbstring pcntl phar posix sysvmsg
diff --git a/devel/pear-PEAR_Info/Makefile b/devel/pear-PEAR_Info/Makefile
index 40e2ea9dbd7d..01ad2dd729ad 100644
--- a/devel/pear-PEAR_Info/Makefile
+++ b/devel/pear-PEAR_Info/Makefile
@@ -9,8 +9,6 @@ CATEGORIES= devel www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= Show Information about your PEAR install and its packages
-IGNORE_WITH_PHP= 56
-
BUILD_DEPENDS= ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs@${PHP_FLAVOR}
RUN_DEPENDS= ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs@${PHP_FLAVOR}
diff --git a/devel/pecl-jsmin/Makefile b/devel/pecl-jsmin/Makefile
index f9fad4c3e54f..8e82cafa3425 100644
--- a/devel/pecl-jsmin/Makefile
+++ b/devel/pecl-jsmin/Makefile
@@ -11,6 +11,5 @@ COMMENT= PHP extension for minifying JavaScript
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP=56
.include <bsd.port.mk>
diff --git a/devel/pecl-msgpack/Makefile b/devel/pecl-msgpack/Makefile
index 6ddfb7eeb26b..5d1dfc73d777 100644
--- a/devel/pecl-msgpack/Makefile
+++ b/devel/pecl-msgpack/Makefile
@@ -10,8 +10,6 @@ COMMENT= Provides API for communicating with MessagePack serialization
LICENSE= BSD3CLAUSE
-IGNORE_WITH_PHP= 56
-
USES= php:pecl
.include <bsd.port.mk>
diff --git a/devel/pecl-propro2/Makefile b/devel/pecl-propro2/Makefile
index cf0976996bd8..48c78171f22e 100644
--- a/devel/pecl-propro2/Makefile
+++ b/devel/pecl-propro2/Makefile
@@ -11,7 +11,6 @@ COMMENT= Facility to manage extension object properties
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56
PORTSCOUT= limit:^2.*
USES= gmake php:pecl
diff --git a/devel/pecl-raphf2/Makefile b/devel/pecl-raphf2/Makefile
index 478d7950551d..1d77017e4871 100644
--- a/devel/pecl-raphf2/Makefile
+++ b/devel/pecl-raphf2/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PORTSCOUT= limit:^2.*
USES= gmake php:pecl
-IGNORE_WITH_PHP= 56
CONFLICTS= pecl-raphf-1*
.include <bsd.port.mk>
diff --git a/devel/pecl-request/Makefile b/devel/pecl-request/Makefile
index 5aa3972ebd01..985156a3e444 100644
--- a/devel/pecl-request/Makefile
+++ b/devel/pecl-request/Makefile
@@ -12,6 +12,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
USES= php:pecl
-IGNORE_WITH_PHP= 56 72 73
+IGNORE_WITH_PHP= 72 73
.include <bsd.port.mk>
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index 974cf8cffbd7..7c8282f3f39c 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -15,7 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c11 localbase:ldflags php:pecl ssl
USE_PHP= hash:build pcre
-IGNORE_WITH_PHP= 56
CONFIGURE_ARGS+= --enable-mysqlnd
OPTIONS_DEFINE= HTTP2 SOCKETS PGSQL
diff --git a/devel/pecl-uv/Makefile b/devel/pecl-uv/Makefile
index a0c4ae7f202d..635731cbb686 100644
--- a/devel/pecl-uv/Makefile
+++ b/devel/pecl-uv/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libuv.so:devel/libuv
-IGNORE_WITH_PHP= 56 73
+IGNORE_WITH_PHP= 73
USES= php:pecl
.include <bsd.port.mk>
diff --git a/devel/pecl-vld/Makefile b/devel/pecl-vld/Makefile
index c3e6b8bdbf20..03575f7ba0f1 100644
--- a/devel/pecl-vld/Makefile
+++ b/devel/pecl-vld/Makefile
@@ -11,8 +11,6 @@ COMMENT= Dump the internal representation of PHP scripts
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56
-
USES= php:pecl
CONFIGURE_ARGS= --enable-vld
diff --git a/devel/pecl-xdebug-devel/Makefile b/devel/pecl-xdebug-devel/Makefile
index 1e97c274096c..d5f2f1b3d556 100644
--- a/devel/pecl-xdebug-devel/Makefile
+++ b/devel/pecl-xdebug-devel/Makefile
@@ -12,7 +12,7 @@ COMMENT= Xdebug extension for PHP
LICENSE= PHP30
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56 71
+IGNORE_WITH_PHP= 71
USES= php:pecl,zend tar:tgz
diff --git a/devel/pecl-xdebug/Makefile b/devel/pecl-xdebug/Makefile
index cc776ded74f5..2f847fd9fd82 100644
--- a/devel/pecl-xdebug/Makefile
+++ b/devel/pecl-xdebug/Makefile
@@ -11,7 +11,7 @@ COMMENT= Xdebug extension for PHP
LICENSE= PHP30
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56 73
+IGNORE_WITH_PHP= 73
CONFIGURE_ARGS= --enable-xdebug
USES= php:pecl,zend tar:tgz
diff --git a/devel/pecl-yac/Makefile b/devel/pecl-yac/Makefile
index a30be2f5b24e..29844444186a 100644
--- a/devel/pecl-yac/Makefile
+++ b/devel/pecl-yac/Makefile
@@ -12,7 +12,7 @@ COMMENT= Yac is a shared memory user data cache for PHP
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 56 73
+IGNORE_WITH_PHP= 73
OPTIONS_DEFINE= MSGPACK
MSGPACK_DESC= Enable MSGPACK module
diff --git a/devel/pecl-yaconf/Makefile b/devel/pecl-yaconf/Makefile
index 4ba74c0e7925..a2d77046de15 100644
--- a/devel/pecl-yaconf/Makefile
+++ b/devel/pecl-yaconf/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP Persistent Configurations Container
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 56 73
+IGNORE_WITH_PHP= 73
USES= php:pecl
.include <bsd.port.mk>
diff --git a/lang/php71-extensions/Makefile b/lang/php71-extensions/Makefile
index 1bc356fd9df1..2d10b1b1f714 100644
--- a/lang/php71-extensions/Makefile
+++ b/lang/php71-extensions/Makefile
@@ -10,7 +10,7 @@ COMMENT= "meta-port" to install PHP extensions
USES= metaport php
PHP_VER= 71
-IGNORE_WITH_PHP= 56 72 73
+IGNORE_WITH_PHP= 72 73
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/lang/php71/Makefile.ext b/lang/php71/Makefile.ext
index 21cb01167d9a..a1e7f18a4449 100644
--- a/lang/php71/Makefile.ext
+++ b/lang/php71/Makefile.ext
@@ -5,7 +5,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 71
-IGNORE_WITH_PHP= 56 72 73
+IGNORE_WITH_PHP= 72 73
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/lang/php72-extensions/Makefile b/lang/php72-extensions/Makefile
index 646f38dbb003..9f1d9d84625b 100644
--- a/lang/php72-extensions/Makefile
+++ b/lang/php72-extensions/Makefile
@@ -10,7 +10,7 @@ COMMENT= "meta-port" to install PHP extensions
USES= metaport php
PHP_VER= 72
-IGNORE_WITH_PHP= 56 71 73
+IGNORE_WITH_PHP= 71 73
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/lang/php72/Makefile.ext b/lang/php72/Makefile.ext
index 44953724a7ef..ce47bd670ab7 100644
--- a/lang/php72/Makefile.ext
+++ b/lang/php72/Makefile.ext
@@ -5,7 +5,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 72
-IGNORE_WITH_PHP= 56 71 73
+IGNORE_WITH_PHP= 71 73
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/lang/php73-extensions/Makefile b/lang/php73-extensions/Makefile
index 280034c5d2c2..d87ba40b9357 100644
--- a/lang/php73-extensions/Makefile
+++ b/lang/php73-extensions/Makefile
@@ -10,7 +10,7 @@ COMMENT= "meta-port" to install PHP extensions
USES= metaport php
PHP_VER= 73
-IGNORE_WITH_PHP= 56 71 72
+IGNORE_WITH_PHP= 71 72
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/lang/php73/Makefile.ext b/lang/php73/Makefile.ext
index 79ff1d80af67..5161a90ec1aa 100644
--- a/lang/php73/Makefile.ext
+++ b/lang/php73/Makefile.ext
@@ -5,7 +5,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 73
-IGNORE_WITH_PHP= 56 71 72
+IGNORE_WITH_PHP= 71 72
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/mail/pecl-mailparse/Makefile b/mail/pecl-mailparse/Makefile
index ba1d54e43b11..1e98bc9221ad 100644
--- a/mail/pecl-mailparse/Makefile
+++ b/mail/pecl-mailparse/Makefile
@@ -13,6 +13,5 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
USE_PHP= mbstring:build
-IGNORE_WITH_PHP= 56
.include <bsd.port.mk>
diff --git a/math/pecl-stats2/Makefile b/math/pecl-stats2/Makefile
index 57974348b2f3..baa74cb634ed 100644
--- a/math/pecl-stats2/Makefile
+++ b/math/pecl-stats2/Makefile
@@ -11,7 +11,6 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 56
CONFLICTS= pecl-stats-1*
PORTSCOUT= limit:^2.*
diff --git a/net-im/pecl-stomp2/Makefile b/net-im/pecl-stomp2/Makefile
index 495eabdaac6c..00d246655ca0 100644
--- a/net-im/pecl-stomp2/Makefile
+++ b/net-im/pecl-stomp2/Makefile
@@ -11,7 +11,6 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 56
CONFLICTS= pecl-stomp-1*
PORTSCOUT= limit:^2.*
diff --git a/net/pecl-oauth2/Makefile b/net/pecl-oauth2/Makefile
index 235c082b433f..5d2dd264d01b 100644
--- a/net/pecl-oauth2/Makefile
+++ b/net/pecl-oauth2/Makefile
@@ -14,7 +14,6 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpcre.so:devel/pcre
USES= php:pecl
-IGNORE_WITH_PHP= 56
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/security/pecl-mcrypt/Makefile b/security/pecl-mcrypt/Makefile
index 3ca55f2b6935..3072908691b7 100644
--- a/security/pecl-mcrypt/Makefile
+++ b/security/pecl-mcrypt/Makefile
@@ -9,7 +9,7 @@ COMMENT= PHP extension for mcrypt, removed in PHP 7.2
LICENSE= PHP301
-IGNORE_WITH_PHP= 56 71
+IGNORE_WITH_PHP= 71
LIB_DEPENDS= libltdl.so:devel/libltdl \
libmcrypt.so:security/libmcrypt
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index ef1503256549..c465e30597d8 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libssh2.so:security/libssh2
USES= php:pecl
-IGNORE_WITH_PHP= 56
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
diff --git a/security/snuffleupagus/Makefile b/security/snuffleupagus/Makefile
index d0231eae467d..6567f562ea2a 100644
--- a/security/snuffleupagus/Makefile
+++ b/security/snuffleupagus/Makefile
@@ -12,8 +12,6 @@ COMMENT= Security module for PHP 7+
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/../LICENSE
-IGNORE_WITH_PHP= 56
-
LIB_DEPENDS= libpcre.so:devel/pcre
TEST_TARGET= test
diff --git a/textproc/pecl-xdiff2/Makefile b/textproc/pecl-xdiff2/Makefile
index f361b8f978b7..c836a13cbff2 100644
--- a/textproc/pecl-xdiff2/Makefile
+++ b/textproc/pecl-xdiff2/Makefile
@@ -13,7 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libxdiff.so:textproc/libxdiff
USES= php:pecl
-IGNORE_WITH_PHP= 56
CONFLICTS= pecl-xdiff-1*
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/pecl-yaml/Makefile b/textproc/pecl-yaml/Makefile
index 68ab2d8040a7..350e23f85bf0 100644
--- a/textproc/pecl-yaml/Makefile
+++ b/textproc/pecl-yaml/Makefile
@@ -14,6 +14,5 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libyaml.so:textproc/libyaml
USES= php:pecl
-IGNORE_WITH_PHP= 56
.include <bsd.port.mk>
diff --git a/www/mediawiki131/Makefile b/www/mediawiki131/Makefile
index 783e7c99a9e1..8611f7ad57f7 100644
--- a/www/mediawiki131/Makefile
+++ b/www/mediawiki131/Makefile
@@ -15,8 +15,6 @@ LICENSE= GPLv2
CONFLICTS= mediawiki12[79]-[0-9]* mediawiki130-[0-9]*
-IGNORE_WITH_PHP=56
-
USES= php:flavors shebangfix
SHEBANG_FILES= maintenance/dev/*.sh \
maintenance/postgres/*.pl \
diff --git a/www/moodle34/Makefile b/www/moodle34/Makefile
index ffe1ee3c81f4..ab1ce3b0780f 100644
--- a/www/moodle34/Makefile
+++ b/www/moodle34/Makefile
@@ -18,8 +18,6 @@ EXPIRATION_DATE=2019-03-03
CONFLICTS= moodle31-3.1.[0-9]* moodle33-3.3.[0-9]* moodle35-3.5.[0-9]* \
moodle36-3.6.[0-9]*
-IGNORE_WITH_PHP= 56
-
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
diff --git a/www/moodle35/Makefile b/www/moodle35/Makefile
index 7992a53be4ee..5057459d2bd2 100644
--- a/www/moodle35/Makefile
+++ b/www/moodle35/Makefile
@@ -15,8 +15,6 @@ LICENSE= GPLv3
CONFLICTS= moodle31-3.1.[0-9]* moodle33-3.3.[0-9]* moodle34-3.4.[0-9]* \
moodle36-3.6.[0-9]*
-IGNORE_WITH_PHP= 56
-
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
diff --git a/www/moodle36/Makefile b/www/moodle36/Makefile
index 740d76f315d0..62b18edba5d7 100644
--- a/www/moodle36/Makefile
+++ b/www/moodle36/Makefile
@@ -15,8 +15,6 @@ LICENSE= GPLv3
CONFLICTS= moodle31-3.1.[0-9]* moodle33-3.3.[0-9]* moodle34-3.4.[0-9]* \
moodle35-3.5.[0-9]*
-IGNORE_WITH_PHP= 56
-
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index 0b5f267f9cd1..4642ac594d06 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_mips= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
BROKEN_mips64= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
-IGNORE_WITH_PHP= 56
BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PHP_FLAVOR} \
${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro2@${PHP_FLAVOR} \
diff --git a/www/typo3-8/Makefile b/www/typo3-8/Makefile
index 424e52274209..4d2aeb894c4c 100644
--- a/www/typo3-8/Makefile
+++ b/www/typo3-8/Makefile
@@ -13,8 +13,6 @@ COMMENT= Typo3 content management system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-IGNORE_WITH_PHP= 56
-
PORTSCOUT= limit:^${PORT_V_MAJOR}\.${PORT_V_MINOR}\.
USES= cpe php:web,flavors shebangfix
diff --git a/www/typo3-9/Makefile b/www/typo3-9/Makefile
index 43d92dfcccbc..75e0e099033a 100644
--- a/www/typo3-9/Makefile
+++ b/www/typo3-9/Makefile
@@ -13,7 +13,7 @@ COMMENT= Typo3 content management system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-IGNORE_WITH_PHP=56 71
+IGNORE_WITH_PHP=71
USES= cpe php:web,flavors shebangfix
USE_PHP= ctype dom fileinfo filter hash intl json openssl pcre session simplexml \