aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/efl/Makefile1
-rw-r--r--graphics/entangle/Makefile1
-rw-r--r--graphics/gegl3/Makefile2
-rw-r--r--graphics/gthumb/Makefile2
-rw-r--r--graphics/libkdcraw-kde4/Makefile2
-rw-r--r--graphics/libraw/Makefile64
-rw-r--r--graphics/libraw/distinfo14
-rw-r--r--graphics/libraw/files/patch-Makefile.in12
-rw-r--r--graphics/libraw/files/patch-configure10
-rw-r--r--graphics/libraw/pkg-plist8
-rw-r--r--graphics/luminance-qt5/Makefile2
-rw-r--r--graphics/luminance/Makefile2
-rw-r--r--graphics/nomacs/Makefile2
-rw-r--r--graphics/openimageio/Makefile2
-rw-r--r--graphics/oyranos/Makefile2
-rw-r--r--graphics/shotwell/Makefile2
16 files changed, 61 insertions, 67 deletions
diff --git a/devel/efl/Makefile b/devel/efl/Makefile
index 30aece9a067a..13926b696dbf 100644
--- a/devel/efl/Makefile
+++ b/devel/efl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= efl
PORTVERSION= 1.18.4
+PORTREVISION= 1
CATEGORIES= devel enlightenment
MASTER_SITES= http://download.enlightenment.org/rel/libs/${PORTNAME}/
diff --git a/graphics/entangle/Makefile b/graphics/entangle/Makefile
index 242309e9317a..0bcfa2f34c0c 100644
--- a/graphics/entangle/Makefile
+++ b/graphics/entangle/Makefile
@@ -3,6 +3,7 @@
PORTNAME= entangle
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://entangle-photo.org/download/sources/
diff --git a/graphics/gegl3/Makefile b/graphics/gegl3/Makefile
index 372b4e63d462..f9649754a0bb 100644
--- a/graphics/gegl3/Makefile
+++ b/graphics/gegl3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= GIMP
PKGNAMESUFFIX= 3
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index cf44c9bbde09..74e20a95b758 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gthumb
PORTVERSION= 3.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/graphics/libkdcraw-kde4/Makefile b/graphics/libkdcraw-kde4/Makefile
index ea102441dc08..5f22ed6b195a 100644
--- a/graphics/libkdcraw-kde4/Makefile
+++ b/graphics/libkdcraw-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libkdcraw
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics kde kde-kde4
MAINTAINER= kde@FreeBSD.org
diff --git a/graphics/libraw/Makefile b/graphics/libraw/Makefile
index 7ba8f651ab6f..3bcaba6a6087 100644
--- a/graphics/libraw/Makefile
+++ b/graphics/libraw/Makefile
@@ -2,76 +2,70 @@
# $FreeBSD$
PORTNAME= libraw
-PORTVERSION= 0.17.2
+PORTVERSION= 0.18.0
CATEGORIES= graphics
MASTER_SITES= http://www.libraw.org/data/
DISTNAME= LibRaw-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT= Library for manipulating raw images
LICENSE= LGPL21 CDDL
LICENSE_COMB= dual
USE_LDCONFIG= yes
-USES= cpe libtool jpeg pathfix pkgconfig
+USES= cpe libtool localbase pathfix pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-examples --disable-jasper
-CFLAGS+= -fPIC
+CONFIGURE_ARGS= --disable-examples
INSTALL_TARGET= install-strip
PORTDOCS= *
PORTEXAMPLES= *
-OPTIONS_DEFINE= DEMOSAIC_PACK_GPL2 DEMOSAIC_PACK_GPL3 DOCS EXAMPLES LCMS2 \
- OPTIMIZED_CFLAGS OPENMP
-OPTIONS_DEFAULT= LCMS2
-
-DEMOSAIC_PACK_GPL2_DESC= Enable GPLv2 demosaic pack
-DEMOSAIC_PACK_GPL3_DESC= Enable GPLv3 demosaic pack
-OPTIMIZED_CFLAGS_DESC= Enable optimizations (on x86)
-OPENMP_DESC= Enable OpenMP (implies GCC 4.6+)
+OPTIONS_DEFINE= DEMOSAIC_PACK_GPL2 DEMOSAIC_PACK_GPL3 \
+ DOCS EXAMPLES JASPER JPEG LCMS2 OPENMP
+OPTIONS_DEFINE_i386= OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= JPEG LCMS2
+DEMOSAIC_PACK_GPL2_DESC= GPLv2 demosaic pack
DEMOSAIC_PACK_GPL2_CONFIGURE_OFF= --disable-demosaic-pack-gpl2
DEMOSAIC_PACK_GPL2_CONFIGURE_ON= --enable-demosaic-pack-gpl2=../LibRaw-demosaic-pack-GPL2-${PORTVERSION}
DEMOSAIC_PACK_GPL2_DISTFILES= LibRaw-demosaic-pack-GPL2-${PORTVERSION}.tar.gz
+DEMOSAIC_PACK_GPL2_VARS= LICENSE=GPLv2+ \
+ LICENSE_COMB=single
+
+DEMOSAIC_PACK_GPL3_DESC= GPLv3 demosaic pack
DEMOSAIC_PACK_GPL3_CONFIGURE_OFF= --disable-demosaic-pack-gpl3
DEMOSAIC_PACK_GPL3_CONFIGURE_ON= --enable-demosaic-pack-gpl3=../LibRaw-demosaic-pack-GPL3-${PORTVERSION}
DEMOSAIC_PACK_GPL3_DISTFILES= LibRaw-demosaic-pack-GPL3-${PORTVERSION}.tar.gz
-LCMS2_CONFIGURE_ENABLE= lcms
-LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
-OPENMP_CONFIGURE_ENABLE= openmp
-OPENMP_USE= GCC=yes
+DEMOSAIC_PACK_GPL3_VARS= LICENSE=GPLv3+ \
+ LICENSE_COMB=single
-.include <bsd.port.options.mk>
+JASPER_CONFIGURE_ENABLE= jasper
+JASPER_LIB_DEPENDS= libjasper.so:graphics/jasper
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-.if ${ARCH} == "i386"
-CFLAGS+= -O3
-.endif
-.endif
+JPEG_CONFIGURE_ENABLE= jpeg
+JPEG_USES= jpeg
-.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL2}
-LICENSE= GPLv2
-LICENSE_COMB= single
-.endif
+LCMS2_CONFIGURE_ENABLE= lcms
+LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
-.if ${PORT_OPTIONS:MDEMOSAIC_PACK_GPL3}
-LICENSE= GPLv3
-LICENSE_COMB= single
-.endif
+OPENMP_DESC= OpenMP support (implies GCC)
+OPENMP_CONFIGURE_ENABLE= openmp
+OPENMP_USES= compiler:openmp
-post-patch:
- @${REINPLACE_CMD} -e "s/-lstdc++//g" ${WRKSRC}/configure
+OPTIMIZED_CFLAGS_CFLAGS= -O3
+# Use "\*" instead of "." in COPYTREE_SHARE commands as "." has
+# the undesired effect of copying ".deps" directory
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && \
${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/samples && \
${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/libraw/distinfo b/graphics/libraw/distinfo
index c6ea16569ef0..e05184ca052d 100644
--- a/graphics/libraw/distinfo
+++ b/graphics/libraw/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1465820275
-SHA256 (LibRaw-0.17.2.tar.gz) = 92b0c42c7666eca9307e5e1f97d6fefc196cf0b7ee089e22880259a76fafd15c
-SIZE (LibRaw-0.17.2.tar.gz) = 1472714
-SHA256 (LibRaw-demosaic-pack-GPL2-0.17.2.tar.gz) = a2e5e9cc04fa8f3e94070110dce8a06aa3b0b2f573ed99c5fc3e327d15f014b7
-SIZE (LibRaw-demosaic-pack-GPL2-0.17.2.tar.gz) = 31190
-SHA256 (LibRaw-demosaic-pack-GPL3-0.17.2.tar.gz) = b00cd0f54851bd3c8a66be4cacbf049e4508f1bac8ff85cb4528d8979739ed36
-SIZE (LibRaw-demosaic-pack-GPL3-0.17.2.tar.gz) = 38908
+TIMESTAMP = 1484692033
+SHA256 (LibRaw-0.18.0.tar.gz) = d56a0c9a0e6d1b8c8c5585346acf2cfb0554eee0f0948da66f580cd65c8c5c9b
+SIZE (LibRaw-0.18.0.tar.gz) = 1278737
+SHA256 (LibRaw-demosaic-pack-GPL2-0.18.0.tar.gz) = 905eff0be2ce43c99527000c81e3b4f4a563ef9bc26581166742459f6358df90
+SIZE (LibRaw-demosaic-pack-GPL2-0.18.0.tar.gz) = 31149
+SHA256 (LibRaw-demosaic-pack-GPL3-0.18.0.tar.gz) = c79cbb4a7fa452a860ad0fa92e4feb4c250af4b5db297ea077b9472aa5be3905
+SIZE (LibRaw-demosaic-pack-GPL3-0.18.0.tar.gz) = 39585
diff --git a/graphics/libraw/files/patch-Makefile.in b/graphics/libraw/files/patch-Makefile.in
index 9c10d81c15f8..364c8cefa66d 100644
--- a/graphics/libraw/files/patch-Makefile.in
+++ b/graphics/libraw/files/patch-Makefile.in
@@ -1,16 +1,14 @@
---- Makefile.in.orig 2013-12-23 02:36:04.000000000 +0200
-+++ Makefile.in 2013-12-23 02:36:23.000000000 +0200
-@@ -462,12 +462,7 @@
+--- Makefile.in.orig 2016-12-27 15:20:16 UTC
++++ Makefile.in
+@@ -474,10 +474,7 @@ nobase_include_HEADERS = libraw/libraw.h
# Docs
-doc_DATA = COPYRIGHT \
- LICENSE.CDDL \
- LICENSE.LGPL \
-- LICENSE.LibRaw.pdf \
- Changelog.txt
--
-+doc_DATA =
++doc_DATA =
+
# pkg-config .pc files
- pkgconfigdir = $(libdir)/pkgconfig
diff --git a/graphics/libraw/files/patch-configure b/graphics/libraw/files/patch-configure
index 5781f77f33c8..0f02a396f5b5 100644
--- a/graphics/libraw/files/patch-configure
+++ b/graphics/libraw/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig 2010-12-29 18:51:59.000000000 +0300
-+++ configure 2010-12-29 18:52:22.000000000 +0300
-@@ -2256,7 +2256,7 @@
- */*) mkdir_p="\$(top_builddir)/$mkdir_p" ;;
- esac
+--- configure.orig 2016-12-27 15:20:15 UTC
++++ configure
+@@ -2763,7 +2763,7 @@ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $MKDIR_P" >&5
+ $as_echo "$MKDIR_P" >&6; }
-for ac_prog in gawk mawk nawk awk
+for ac_prog in awk
diff --git a/graphics/libraw/pkg-plist b/graphics/libraw/pkg-plist
index 8483b7f230c5..976e62955fa1 100644
--- a/graphics/libraw/pkg-plist
+++ b/graphics/libraw/pkg-plist
@@ -7,11 +7,11 @@ include/libraw/libraw_types.h
include/libraw/libraw_version.h
lib/libraw.a
lib/libraw.so
-lib/libraw.so.15
-lib/libraw.so.15.0.0
+lib/libraw.so.16
+lib/libraw.so.16.0.0
lib/libraw_r.a
lib/libraw_r.so
-lib/libraw_r.so.15
-lib/libraw_r.so.15.0.0
+lib/libraw_r.so.16
+lib/libraw_r.so.16.0.0
libdata/pkgconfig/libraw.pc
libdata/pkgconfig/libraw_r.pc
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index cc43c09f47c3..caa48ff25b16 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.4.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
PKGNAMESUFFIX= -qt5
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 643b05248d48..450b482f9f70 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -3,7 +3,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.3.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index bbed72b960d1..e51d552da55e 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nomacs
PORTVERSION= 2.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= SF/nomacs/nomacs-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 7ae38210132b..9cf60ba137e3 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openimageio
PORTVERSION= 1.6.12
DISTVERSIONPREFIX= Release-
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 4107e5fd52e9..3f01518533c8 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -2,7 +2,7 @@
PORTNAME= oyranos
PORTVERSION= 0.9.5
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Oyranos/Oyranos%20${PORTVERSION:C|(.*)\.[0-9]*$|\1|}
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index 82713f90ce31..3f7762d2eddd 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shotwell
PORTVERSION= 0.24.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME/sources/shotwell/${PORTVERSION:R}