aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/wyrmgus/Makefile4
-rw-r--r--games/wyrmgus/distinfo4
-rw-r--r--games/wyrmgus/files/patch-src_unit_script__unittype.cpp11
3 files changed, 15 insertions, 4 deletions
diff --git a/games/wyrmgus/Makefile b/games/wyrmgus/Makefile
index f032747e31d4..cb2bb31e5498 100644
--- a/games/wyrmgus/Makefile
+++ b/games/wyrmgus/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wyrmgus
-PORTVERSION= git20150514
+PORTVERSION= git20150601
CATEGORIES= games devel
MAINTAINER= amdmi3@FreeBSD.org
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= Andrettin
GH_PROJECT= Wyrmgus
-GH_TAGNAME= bc2d9703d3
+GH_TAGNAME= 80c76abcc6
USE_GL= gl glu
USE_SDL= sdl
diff --git a/games/wyrmgus/distinfo b/games/wyrmgus/distinfo
index 40fd630f27f2..3164a78976aa 100644
--- a/games/wyrmgus/distinfo
+++ b/games/wyrmgus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Andrettin-Wyrmgus-git20150514-bc2d9703d3_GH0.tar.gz) = caef6b02db19747e5f1f37a13f36812a5bc665343501d673bde4e719981a9b57
-SIZE (Andrettin-Wyrmgus-git20150514-bc2d9703d3_GH0.tar.gz) = 1080110
+SHA256 (Andrettin-Wyrmgus-git20150601-80c76abcc6_GH0.tar.gz) = 1032a1b372061c36c9a1615ace17db5307923bbc209fa15c34a4d55cfbacd720
+SIZE (Andrettin-Wyrmgus-git20150601-80c76abcc6_GH0.tar.gz) = 1076866
diff --git a/games/wyrmgus/files/patch-src_unit_script__unittype.cpp b/games/wyrmgus/files/patch-src_unit_script__unittype.cpp
new file mode 100644
index 000000000000..0a8291211055
--- /dev/null
+++ b/games/wyrmgus/files/patch-src_unit_script__unittype.cpp
@@ -0,0 +1,11 @@
+--- src/unit/script_unittype.cpp.orig 2015-06-01 15:35:14 UTC
++++ src/unit/script_unittype.cpp
+@@ -1342,7 +1342,7 @@ static int CclDefineUnitType(lua_State *
+ type->Parent = LuaToString(l, -1);
+ CUnitType *parent_type = UnitTypeByIdent(type->Parent);
+ if (!parent_type) {
+- LuaError(l, "Unit type %s not defined" _C_ type->Parent);
++ LuaError(l, "Unit type %s not defined" _C_ type->Parent.c_str());
+ }
+ type->Class = parent_type->Class;
+ type->DrawLevel = parent_type->DrawLevel;