aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/varnish/Makefile2
-rw-r--r--www/varnish/files/patch-svn-r191318
-rw-r--r--www/varnish2/Makefile2
-rw-r--r--www/varnish2/files/patch-svn-r191318
4 files changed, 38 insertions, 2 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 4d6b40d6aa2a..d4e869406d6a 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -7,7 +7,7 @@
PORTNAME= varnish
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/varnish/files/patch-svn-r1913 b/www/varnish/files/patch-svn-r1913
new file mode 100644
index 000000000000..318666826f0e
--- /dev/null
+++ b/www/varnish/files/patch-svn-r1913
@@ -0,0 +1,18 @@
+Index: bin/varnishd/cache_center.c
+===================================================================
+--- bin/varnishd/cache_center.c (revision 1912)
++++ bin/varnishd/cache_center.c (revision 1913)
+@@ -524,7 +524,12 @@
+ */
+ WSL(sp->wrk, SLT_Debug, sp->fd,
+ "on waiting list on obj %u", sp->obj->xid);
+- assert(!isnan(sp->wrk->used));
++ /*
++ * There is a non-zero risk that we come here more than once
++ * before we get through, in that case cnt_recv must be set
++ */
++ if (isnan(sp->wrk->used))
++ sp->wrk->used = TIM_real();
+ SES_Charge(sp);
+ return (1);
+ }
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
index 4d6b40d6aa2a..d4e869406d6a 100644
--- a/www/varnish2/Makefile
+++ b/www/varnish2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= varnish
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/varnish2/files/patch-svn-r1913 b/www/varnish2/files/patch-svn-r1913
new file mode 100644
index 000000000000..318666826f0e
--- /dev/null
+++ b/www/varnish2/files/patch-svn-r1913
@@ -0,0 +1,18 @@
+Index: bin/varnishd/cache_center.c
+===================================================================
+--- bin/varnishd/cache_center.c (revision 1912)
++++ bin/varnishd/cache_center.c (revision 1913)
+@@ -524,7 +524,12 @@
+ */
+ WSL(sp->wrk, SLT_Debug, sp->fd,
+ "on waiting list on obj %u", sp->obj->xid);
+- assert(!isnan(sp->wrk->used));
++ /*
++ * There is a non-zero risk that we come here more than once
++ * before we get through, in that case cnt_recv must be set
++ */
++ if (isnan(sp->wrk->used))
++ sp->wrk->used = TIM_real();
+ SES_Charge(sp);
+ return (1);
+ }