aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gstreamer.mk5
-rw-r--r--devel/gstreamer-plugins-gconf/Makefile14
-rw-r--r--devel/gstreamer-plugins-gconf80/Makefile14
-rw-r--r--multimedia/gstreamer-plugins/Makefile11
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common32
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist8
-rw-r--r--multimedia/gstreamer-plugins80/Makefile11
-rw-r--r--multimedia/gstreamer-plugins80/Makefile.common32
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist8
9 files changed, 102 insertions, 33 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 57ca4e84c5e0..a4fe66d81d2f 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -54,7 +54,7 @@ GST_SHLIB_VERSION= 1
#
_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdparanoia \
dirac dts dv dvd esound faac faad ffmpeg flac \
- gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
+ gconf gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
jpeg-mmx ladspa lame libcaca libfame libmms libmng \
libpng libvisual mad mikmod mpeg2dec mpeg2enc mplex \
musepack musicbrainz nas sdl shout shout2 sidplay \
@@ -72,6 +72,9 @@ core_GST_EXT= .keep
yes_DEPENDS= multimedia/gstreamer-plugins
yes_PLIST= libgstac3parse
+gconf_DEPENDS= devel/gstreamer-plugins-gconf
+gconf_PLIST= libgstgconfelements
+
# Audio Plugins Section
a52dec_DEPENDS= audio/gstreamer-plugins-a52dec
diff --git a/devel/gstreamer-plugins-gconf/Makefile b/devel/gstreamer-plugins-gconf/Makefile
new file mode 100644
index 000000000000..d3490058e4fb
--- /dev/null
+++ b/devel/gstreamer-plugins-gconf/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: gstreamer-plugins-gconf
+# Date created: 10 Mar 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+GST_PLUGIN= gconf
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/gstreamer-plugins-gconf80/Makefile b/devel/gstreamer-plugins-gconf80/Makefile
new file mode 100644
index 000000000000..d3490058e4fb
--- /dev/null
+++ b/devel/gstreamer-plugins-gconf80/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: gstreamer-plugins-gconf
+# Date created: 10 Mar 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+GST_PLUGIN= gconf
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 5262f64c4e7f..d787fdeb9176 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gstreamer
PORTVERSION= 0.8.8
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -31,8 +31,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME+= gnomehack \
gnomeprefix \
- pkgconfig \
- gconf2
+ gnometarget \
+ pkgconfig
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
GST_PLUGIN?= base
@@ -45,12 +45,11 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
.include <bsd.port.pre.mk>
.include "${MASTERDIR}/Makefile.common"
-#.if !defined(WITH_CPUFLAGS)
+.if !defined(WITH_CPUFLAGS)
WITHOUT_CPU_CFLAGS= yes
-#.endif
+.endif
.if ${GST_PLUGIN} == "base"
-GCONF_SCHEMAS= gstreamer-0.8.schemas
INSTALLS_SHLIB= yes
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index a620d83b7ea0..3d2bdbd68376 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -23,6 +23,7 @@ GST_ALL_PLUGINS= \
faac \
faad \
flac \
+ gconf \
gdk_pixbuf \
gnome_vfs \
gsm \
@@ -88,8 +89,9 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-alsa \
--disable-http \
--enable-cdrom \
- --enable-gconf \
- --enable-gconftool \
+ --disable-gconf \
+ --disable-gconftool \
+ --disable-schemas-install \
--enable-oss \
--disable-osx_audio \
--disable-osx_video \
@@ -178,6 +180,22 @@ LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
.endif
+# gconf
+.if ${GST_PLUGIN}=="gconf"
+USE_GNOME+= gconf2
+GST_PLUGIN_DIR= gst-libs/gst/gconf \
+ ext/gconf \
+ gconf
+GCONF_SCHEMAS= gstreamer-0.8.schemas
+
+PLIST_FILES= include/gstreamer-0.8/gst/gconf/gconf.h \
+ lib/gstreamer-0.8/libgstgconfelements.so \
+ lib/libgstgconf-0.8.a \
+ lib/libgstgconf-0.8.so \
+ lib/libgstgconf-0.8.so.1 \
+ libdata/pkgconfig/gstreamer-gconf-0.8.pc
+.endif
+
# gdkpixbuf
.if ${GST_PLUGIN}=="gdkpixbuf"
USE_GNOME+= gtk20
@@ -433,12 +451,15 @@ LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
.endif
-LIB_DEPENDS+= gstgconf-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+LIB_DEPENDS+= gstplay-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
PLIST_FILES+= '@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
PLIST_FILES+= '@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
do-build:
+.if ${GST_PLUGIN} == "gconf"
+ @cd ${WRKSRC}/pkgconfig && ../config.status &
+.endif
.for dir in ${GST_PREBUILD_DIR} ${GST_PLUGIN_DIR} ${GST_POSTBUILD_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
@@ -449,5 +470,10 @@ do-install:
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
.endfor
+.if ${GST_PLUGIN} == "gconf"
+ @cd ${WRKSRC}/pkgconfig && ${GMAKE} gstreamer-gconf-0.8.pc
+ @${INSTALL_SCRIPT} ${WRKSRC}/pkgconfig/gstreamer-gconf-0.8.pc \
+ ${PREFIX}/libdata/pkgconfig/gstreamer-gconf-0.8.pc
+.endif
.endif
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 5e7a8a43fbfa..87b1ee4d42de 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -9,7 +9,6 @@ include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance-enumtypes.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalancechannel.h
include/gstreamer-%%VERSION%%/gst/floatcast/floatcast.h
-include/gstreamer-%%VERSION%%/gst/gconf/gconf.h
include/gstreamer-%%VERSION%%/gst/idct/idct.h
include/gstreamer-%%VERSION%%/gst/media-info/media-info.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer-enumtypes.h
@@ -65,7 +64,6 @@ lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
lib/gstreamer-%%VERSION%%/libgstfilter.so
lib/gstreamer-%%VERSION%%/libgstflxdec.so
lib/gstreamer-%%VERSION%%/libgstgamma.so
-lib/gstreamer-%%VERSION%%/libgstgconfelements.so
lib/gstreamer-%%VERSION%%/libgstgoom.so
lib/gstreamer-%%VERSION%%/libgstidct.so
lib/gstreamer-%%VERSION%%/libgstinterleave.so
@@ -134,9 +132,6 @@ lib/gstreamer-%%VERSION%%/libgstximagesink.so
lib/gstreamer-%%VERSION%%/libgstxvimagesink.so
lib/gstreamer-%%VERSION%%/libgstxwindowlistener.so
lib/gstreamer-%%VERSION%%/libgsty4menc.so
-lib/libgstgconf-%%VERSION%%.a
-lib/libgstgconf-%%VERSION%%.so
-lib/libgstgconf-%%VERSION%%.so.%%SHLIB_VERSION%%
lib/libgstinterfaces-%%VERSION%%.a
lib/libgstinterfaces-%%VERSION%%.so
lib/libgstinterfaces-%%VERSION%%.so.%%SHLIB_VERSION%%
@@ -146,7 +141,6 @@ lib/libgstmedia-info-%%VERSION%%.so.%%SHLIB_VERSION%%
lib/libgstplay-%%VERSION%%.a
lib/libgstplay-%%VERSION%%.so
lib/libgstplay-%%VERSION%%.so.%%SHLIB_VERSION%%
-libdata/pkgconfig/gstreamer-gconf-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-interfaces-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-libs-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-media-info-%%VERSION%%.pc
@@ -180,7 +174,7 @@ share/locale/vi/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/mixer
@dirrm include/gstreamer-%%VERSION%%/gst/media-info
@dirrm include/gstreamer-%%VERSION%%/gst/idct
-@dirrm include/gstreamer-%%VERSION%%/gst/gconf
+@dirrm include/gstreamer-%%VERSION%%/gst/gconf 2>/dev/null || true
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
@dirrm include/gstreamer-%%VERSION%%/gst/colorbalance
@dirrm include/gstreamer-%%VERSION%%/gst/audio
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index 5262f64c4e7f..d787fdeb9176 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gstreamer
PORTVERSION= 0.8.8
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -31,8 +31,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME+= gnomehack \
gnomeprefix \
- pkgconfig \
- gconf2
+ gnometarget \
+ pkgconfig
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
GST_PLUGIN?= base
@@ -45,12 +45,11 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
.include <bsd.port.pre.mk>
.include "${MASTERDIR}/Makefile.common"
-#.if !defined(WITH_CPUFLAGS)
+.if !defined(WITH_CPUFLAGS)
WITHOUT_CPU_CFLAGS= yes
-#.endif
+.endif
.if ${GST_PLUGIN} == "base"
-GCONF_SCHEMAS= gstreamer-0.8.schemas
INSTALLS_SHLIB= yes
diff --git a/multimedia/gstreamer-plugins80/Makefile.common b/multimedia/gstreamer-plugins80/Makefile.common
index a620d83b7ea0..3d2bdbd68376 100644
--- a/multimedia/gstreamer-plugins80/Makefile.common
+++ b/multimedia/gstreamer-plugins80/Makefile.common
@@ -23,6 +23,7 @@ GST_ALL_PLUGINS= \
faac \
faad \
flac \
+ gconf \
gdk_pixbuf \
gnome_vfs \
gsm \
@@ -88,8 +89,9 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-alsa \
--disable-http \
--enable-cdrom \
- --enable-gconf \
- --enable-gconftool \
+ --disable-gconf \
+ --disable-gconftool \
+ --disable-schemas-install \
--enable-oss \
--disable-osx_audio \
--disable-osx_video \
@@ -178,6 +180,22 @@ LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
.endif
+# gconf
+.if ${GST_PLUGIN}=="gconf"
+USE_GNOME+= gconf2
+GST_PLUGIN_DIR= gst-libs/gst/gconf \
+ ext/gconf \
+ gconf
+GCONF_SCHEMAS= gstreamer-0.8.schemas
+
+PLIST_FILES= include/gstreamer-0.8/gst/gconf/gconf.h \
+ lib/gstreamer-0.8/libgstgconfelements.so \
+ lib/libgstgconf-0.8.a \
+ lib/libgstgconf-0.8.so \
+ lib/libgstgconf-0.8.so.1 \
+ libdata/pkgconfig/gstreamer-gconf-0.8.pc
+.endif
+
# gdkpixbuf
.if ${GST_PLUGIN}=="gdkpixbuf"
USE_GNOME+= gtk20
@@ -433,12 +451,15 @@ LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
.endif
-LIB_DEPENDS+= gstgconf-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+LIB_DEPENDS+= gstplay-${VERSION}.${SHLIB_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
PLIST_FILES+= '@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
PLIST_FILES+= '@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null || true'
do-build:
+.if ${GST_PLUGIN} == "gconf"
+ @cd ${WRKSRC}/pkgconfig && ../config.status &
+.endif
.for dir in ${GST_PREBUILD_DIR} ${GST_PLUGIN_DIR} ${GST_POSTBUILD_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
@@ -449,5 +470,10 @@ do-install:
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
.endfor
+.if ${GST_PLUGIN} == "gconf"
+ @cd ${WRKSRC}/pkgconfig && ${GMAKE} gstreamer-gconf-0.8.pc
+ @${INSTALL_SCRIPT} ${WRKSRC}/pkgconfig/gstreamer-gconf-0.8.pc \
+ ${PREFIX}/libdata/pkgconfig/gstreamer-gconf-0.8.pc
+.endif
.endif
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index 5e7a8a43fbfa..87b1ee4d42de 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -9,7 +9,6 @@ include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance-enumtypes.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalance.h
include/gstreamer-%%VERSION%%/gst/colorbalance/colorbalancechannel.h
include/gstreamer-%%VERSION%%/gst/floatcast/floatcast.h
-include/gstreamer-%%VERSION%%/gst/gconf/gconf.h
include/gstreamer-%%VERSION%%/gst/idct/idct.h
include/gstreamer-%%VERSION%%/gst/media-info/media-info.h
include/gstreamer-%%VERSION%%/gst/mixer/mixer-enumtypes.h
@@ -65,7 +64,6 @@ lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
lib/gstreamer-%%VERSION%%/libgstfilter.so
lib/gstreamer-%%VERSION%%/libgstflxdec.so
lib/gstreamer-%%VERSION%%/libgstgamma.so
-lib/gstreamer-%%VERSION%%/libgstgconfelements.so
lib/gstreamer-%%VERSION%%/libgstgoom.so
lib/gstreamer-%%VERSION%%/libgstidct.so
lib/gstreamer-%%VERSION%%/libgstinterleave.so
@@ -134,9 +132,6 @@ lib/gstreamer-%%VERSION%%/libgstximagesink.so
lib/gstreamer-%%VERSION%%/libgstxvimagesink.so
lib/gstreamer-%%VERSION%%/libgstxwindowlistener.so
lib/gstreamer-%%VERSION%%/libgsty4menc.so
-lib/libgstgconf-%%VERSION%%.a
-lib/libgstgconf-%%VERSION%%.so
-lib/libgstgconf-%%VERSION%%.so.%%SHLIB_VERSION%%
lib/libgstinterfaces-%%VERSION%%.a
lib/libgstinterfaces-%%VERSION%%.so
lib/libgstinterfaces-%%VERSION%%.so.%%SHLIB_VERSION%%
@@ -146,7 +141,6 @@ lib/libgstmedia-info-%%VERSION%%.so.%%SHLIB_VERSION%%
lib/libgstplay-%%VERSION%%.a
lib/libgstplay-%%VERSION%%.so
lib/libgstplay-%%VERSION%%.so.%%SHLIB_VERSION%%
-libdata/pkgconfig/gstreamer-gconf-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-interfaces-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-libs-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-media-info-%%VERSION%%.pc
@@ -180,7 +174,7 @@ share/locale/vi/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/mixer
@dirrm include/gstreamer-%%VERSION%%/gst/media-info
@dirrm include/gstreamer-%%VERSION%%/gst/idct
-@dirrm include/gstreamer-%%VERSION%%/gst/gconf
+@dirrm include/gstreamer-%%VERSION%%/gst/gconf 2>/dev/null || true
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
@dirrm include/gstreamer-%%VERSION%%/gst/colorbalance
@dirrm include/gstreamer-%%VERSION%%/gst/audio