aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.qt.mk20
-rw-r--r--accessibility/qt4-accessible/Makefile1
-rw-r--r--devel/qmake4/Makefile15
-rw-r--r--devel/qmake4/files/patch-qt4-before-ports-in-mkspecs.diff4
-rw-r--r--devel/qmake4/pkg-plist12
-rw-r--r--devel/qt4-assistant-adp/Makefile1
-rw-r--r--devel/qt4-assistant/Makefile1
-rw-r--r--devel/qt4-declarative/Makefile1
-rw-r--r--devel/qt4-designer/Makefile1
-rw-r--r--devel/qt4-help-tools/Makefile1
-rw-r--r--devel/qt4-help/Makefile1
-rw-r--r--devel/qt4-libqtassistantclient/Makefile1
-rw-r--r--devel/qt4-linguist/Makefile1
-rw-r--r--devel/qt4-makeqpf/Makefile5
-rw-r--r--devel/qt4-makeqpf/files/extra-patch__tools__makeqpf__qpf2.cpp (renamed from devel/qt4-makeqpf/files/patch-tools-makeqpf-qpf2.cpp)0
-rw-r--r--devel/qt4-qdbusviewer/Makefile1
-rw-r--r--devel/qt4-qdoc3/Makefile1
-rw-r--r--devel/qt4-qt3support/Makefile1
-rw-r--r--devel/qt4-qvfb/Makefile1
-rw-r--r--devel/qt4-qvfb/files/patch-tools__qvfb__qvfb.pro11
-rw-r--r--devel/qt4-scripttools/Makefile1
-rw-r--r--devel/qt4-uic3/Makefile1
-rw-r--r--devel/qt4/distinfo4
-rw-r--r--graphics/qt4-iconengines/Makefile1
-rw-r--r--graphics/qt4-imageformats/Makefile1
-rw-r--r--graphics/qt4-pixeltool/Makefile1
-rw-r--r--graphics/qt4-svg/Makefile1
-rw-r--r--misc/qt4-doc/pkg-plist2
-rw-r--r--misc/qt4-l10n/Makefile1
-rw-r--r--misc/qt4-qtconfig/Makefile1
-rw-r--r--misc/qt4-qtdemo/Makefile1
-rw-r--r--multimedia/qt4-multimedia/Makefile1
-rw-r--r--multimedia/qt4-phonon-gst/Makefile1
-rw-r--r--multimedia/qt4-phonon/Makefile1
-rw-r--r--net/qt4-network/pkg-plist2
-rw-r--r--www/qt4-webkit/Makefile1
-rw-r--r--www/qt4-webkit/pkg-plist2
-rw-r--r--x11-toolkits/qt4-gui/Makefile1
-rw-r--r--x11-toolkits/qt4-gui/files/patch-src__gui__text__qtextlayout.cpp13
-rw-r--r--x11/qt4-graphicssystems-opengl/Makefile1
-rw-r--r--x11/qt4-inputmethods/Makefile1
-rw-r--r--x11/qt4-opengl/Makefile1
42 files changed, 39 insertions, 81 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 01821122cc28..63566e8344cd 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -146,9 +146,9 @@ QTCGFLIBS?=
#
# QT4 version
#
-QT4_VERSION?= 4.8.1
+QT4_VERSION?= 4.8.2
-_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
+_USE_QT4_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
dbus declarative demo designer doc \
graphicssystems-opengl gui help help-tools \
@@ -342,26 +342,26 @@ xmlpatterns-tool_DEPENDS= ${QT_PREFIX}/bin/xmlpatterns
.if defined(_POSTMKINCLUDED) && !defined(Qt_Post_Include)
Qt_Post_Include= bsd.qt.mk
-.for component in ${_QT_COMPONENTS_ALL}
+.for component in ${_USE_QT4_ALL}
${component}_BUILD_DEPENDS?= ${${component}_DEPENDS}:${PORTSDIR}/${${component}_PORT}
${component}_RUN_DEPENDS?= ${${component}_DEPENDS}:${PORTSDIR}/${${component}_PORT}
${component}_build_BUILD_DEPENDS?= ${${component}_BUILD_DEPENDS}
${component}_run_RUN_DEPENDS?= ${${component}_RUN_DEPENDS}
-_QT_COMPONENTS_ALL_SUFFIXED+= ${component} ${component}_build ${component}_run
+_USE_QT4_ALL_SUFFIXED+= ${component} ${component}_build ${component}_run
.endfor
-.if defined(USE_QT4)
-QT_COMPONENTS= ${USE_QT4}
-.endif
.if defined(QT_COMPONENTS)
-. for component in ${QT_COMPONENTS:O:u}
-. if ${_QT_COMPONENTS_ALL_SUFFIXED:M${component}}!= ""
+USE_QT4= ${QT_COMPONENTS}
+.endif
+.if defined(USE_QT4)
+. for component in ${USE_QT4:O:u}
+. if ${_USE_QT4_ALL_SUFFIXED:M${component}}!= ""
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
. else
-IGNORE= can't be installed: unknown Qt 4 component '${component}'
+IGNORE= can't be installed: unknown USE_QT4 component '${component}'
. endif
. endfor
.endif
diff --git a/accessibility/qt4-accessible/Makefile b/accessibility/qt4-accessible/Makefile
index a3aa2a486a51..8557e75661c0 100644
--- a/accessibility/qt4-accessible/Makefile
+++ b/accessibility/qt4-accessible/Makefile
@@ -8,7 +8,6 @@
PORTNAME= accessible
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= accessibility
PKGNAMEPREFIX= qt4-
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
index 8b482f26bd95..af6179986847 100644
--- a/devel/qmake4/Makefile
+++ b/devel/qmake4/Makefile
@@ -52,21 +52,22 @@ post-patch:
${WRKSRC}/../mkspecs/freebsd-*/qmake.conf
@${REINPLACE_CMD} -e 's|@QMAKE_QTOBJS@||g' ${WRKSRC}/Makefile.unix
- # FIXME: This is ugly
+# FIXME: This is ugly
@${RM} ${WRKSRC}/../mkspecs/freebsd-g++/*.orig
- @${RM} ${WRKSRC}/../mkspecs/freebsd-g++40/*.orig
+ @${RM} ${WRKSRC}/../mkspecs/freebsd-g++46/*.orig
# Add mkspec for clang
- @${CP} -PpR ${WRKSRC}/../mkspecs/freebsd-g++ ${WRKSRC}/../mkspecs/freebsd-clang
+ @${CP} -PpR ${WRKSRC}/../mkspecs/freebsd-g++46 ${WRKSRC}/../mkspecs/freebsd-clang
@${REINPLACE_CMD} -e 's|g++-unix.conf|clang.conf|g' \
+ -e 's|freebsd-g++|freebsd-clang|g' \
${WRKSRC}/../mkspecs/freebsd-clang/qmake.conf
+
# Add mkspecs for the different GCC versions in the ports tree
-.for v in 42 44 46 47 48
- @${CP} -PpR ${WRKSRC}/../mkspecs/freebsd-g++40 ${WRKSRC}/../mkspecs/freebsd-g++${v}
- @${REINPLACE_CMD} -e 's|40|${v}|g' \
+.for v in 42 44 47 48
+ @${CP} -PpR ${WRKSRC}/../mkspecs/freebsd-g++46 ${WRKSRC}/../mkspecs/freebsd-g++${v}
+ @${REINPLACE_CMD} -e 's|46|${v}|g' \
${WRKSRC}/../mkspecs/freebsd-g++${v}/qmake.conf
.endfor
- @${RM} -r ${WRKSRC}/../mkspecs/freebsd-g++40
do-configure:
${SED} -e 's|/usr/local|${PREFIX}|g' \
diff --git a/devel/qmake4/files/patch-qt4-before-ports-in-mkspecs.diff b/devel/qmake4/files/patch-qt4-before-ports-in-mkspecs.diff
index 9ae0c7fff3fd..f1778eb13706 100644
--- a/devel/qmake4/files/patch-qt4-before-ports-in-mkspecs.diff
+++ b/devel/qmake4/files/patch-qt4-before-ports-in-mkspecs.diff
@@ -11,8 +11,8 @@
QMAKE_INCDIR_X11 = /usr/X11R6/include
QMAKE_LIBDIR_X11 = /usr/X11R6/lib
QMAKE_INCDIR_QT = $$[QT_INSTALL_HEADERS]
---- ../mkspecs/freebsd-g++40/qmake.conf.old 2011-09-17 01:03:00.000000000 -0300
-+++ ../mkspecs/freebsd-g++40/qmake.conf 2011-09-17 00:23:41.000000000 -0300
+--- ../mkspecs/freebsd-g++46/qmake.conf.old 2011-09-17 01:03:00.000000000 -0300
++++ ../mkspecs/freebsd-g++46/qmake.conf 2011-09-17 00:23:41.000000000 -0300
@@ -37,8 +37,8 @@
QMAKE_CXXFLAGS_THREAD = $$QMAKE_CFLAGS_THREAD
diff --git a/devel/qmake4/pkg-plist b/devel/qmake4/pkg-plist
index 1d069bab04f4..5d855583e660 100644
--- a/devel/qmake4/pkg-plist
+++ b/devel/qmake4/pkg-plist
@@ -187,8 +187,6 @@ share/qt4/mkspecs/freebsd-clang/qmake.conf
share/qt4/mkspecs/freebsd-clang/qplatformdefs.h
share/qt4/mkspecs/freebsd-g++/qmake.conf
share/qt4/mkspecs/freebsd-g++/qplatformdefs.h
-share/qt4/mkspecs/freebsd-g++34/qmake.conf
-share/qt4/mkspecs/freebsd-g++34/qplatformdefs.h
share/qt4/mkspecs/freebsd-g++42/qmake.conf
share/qt4/mkspecs/freebsd-g++42/qplatformdefs.h
share/qt4/mkspecs/freebsd-g++44/qmake.conf
@@ -227,6 +225,8 @@ share/qt4/mkspecs/irix-g++-64/qmake.conf
share/qt4/mkspecs/irix-g++-64/qplatformdefs.h
share/qt4/mkspecs/irix-g++/qmake.conf
share/qt4/mkspecs/irix-g++/qplatformdefs.h
+share/qt4/mkspecs/linux-arm-gnueabi-g++/qmake.conf
+share/qt4/mkspecs/linux-arm-gnueabi-g++/qplatformdefs.h
share/qt4/mkspecs/linux-cxx/qmake.conf
share/qt4/mkspecs/linux-cxx/qplatformdefs.h
share/qt4/mkspecs/linux-ecc-64/qmake.conf
@@ -401,6 +401,10 @@ share/qt4/mkspecs/unixware-cc/qmake.conf
share/qt4/mkspecs/unixware-cc/qplatformdefs.h
share/qt4/mkspecs/unixware-g++/qmake.conf
share/qt4/mkspecs/unixware-g++/qplatformdefs.h
+share/qt4/mkspecs/unsupported/blackberry-armv7le-qcc/qmake.conf
+share/qt4/mkspecs/unsupported/blackberry-armv7le-qcc/qplatformdefs.h
+share/qt4/mkspecs/unsupported/blackberry-x86-qcc/qmake.conf
+share/qt4/mkspecs/unsupported/blackberry-x86-qcc/qplatformdefs.h
share/qt4/mkspecs/unsupported/linux-armcc/qmake.conf
share/qt4/mkspecs/unsupported/linux-armcc/qplatformdefs.h
share/qt4/mkspecs/unsupported/linux-clang/qmake.conf
@@ -569,6 +573,8 @@ share/qt4/mkspecs/wincewm65professional-msvc2008/qplatformdefs.h
@dirrm share/qt4/mkspecs/unsupported/linux-host-g++
@dirrm share/qt4/mkspecs/unsupported/linux-clang
@dirrm share/qt4/mkspecs/unsupported/linux-armcc
+@dirrm share/qt4/mkspecs/unsupported/blackberry-x86-qcc
+@dirrm share/qt4/mkspecs/unsupported/blackberry-armv7le-qcc
@dirrm share/qt4/mkspecs/unsupported
@dirrm share/qt4/mkspecs/unixware-g++
@dirrm share/qt4/mkspecs/unixware-cc
@@ -654,6 +660,7 @@ share/qt4/mkspecs/wincewm65professional-msvc2008/qplatformdefs.h
@dirrm share/qt4/mkspecs/linux-g++
@dirrm share/qt4/mkspecs/linux-ecc-64
@dirrm share/qt4/mkspecs/linux-cxx
+@dirrm share/qt4/mkspecs/linux-arm-gnueabi-g++
@dirrm share/qt4/mkspecs/irix-g++-64
@dirrm share/qt4/mkspecs/irix-g++
@dirrm share/qt4/mkspecs/irix-cc-64
@@ -673,7 +680,6 @@ share/qt4/mkspecs/wincewm65professional-msvc2008/qplatformdefs.h
@dirrm share/qt4/mkspecs/freebsd-g++46
@dirrm share/qt4/mkspecs/freebsd-g++44
@dirrm share/qt4/mkspecs/freebsd-g++42
-@dirrm share/qt4/mkspecs/freebsd-g++34
@dirrm share/qt4/mkspecs/freebsd-g++
@dirrm share/qt4/mkspecs/freebsd-clang
@dirrm share/qt4/mkspecs/features/win32
diff --git a/devel/qt4-assistant-adp/Makefile b/devel/qt4-assistant-adp/Makefile
index e9d62351998b..78602bfc6338 100644
--- a/devel/qt4-assistant-adp/Makefile
+++ b/devel/qt4-assistant-adp/Makefile
@@ -7,7 +7,6 @@
PORTNAME= assistant
PORTVERSION= 4.6.3
-PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-assistant/Makefile b/devel/qt4-assistant/Makefile
index a216e850fa76..fc56b40af9bb 100644
--- a/devel/qt4-assistant/Makefile
+++ b/devel/qt4-assistant/Makefile
@@ -8,7 +8,6 @@
PORTNAME= assistant
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-declarative/Makefile b/devel/qt4-declarative/Makefile
index eb388063325b..2b5f2205468a 100644
--- a/devel/qt4-declarative/Makefile
+++ b/devel/qt4-declarative/Makefile
@@ -7,7 +7,6 @@
PORTNAME= declarative
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index 8ba7ff24c7d2..1144032e10ee 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -8,7 +8,6 @@
PORTNAME= designer
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-help-tools/Makefile b/devel/qt4-help-tools/Makefile
index fe700249fc94..ad29da63574e 100644
--- a/devel/qt4-help-tools/Makefile
+++ b/devel/qt4-help-tools/Makefile
@@ -7,7 +7,6 @@
PORTNAME= help
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-help/Makefile b/devel/qt4-help/Makefile
index 8490ebb6f1eb..65d6825c532d 100644
--- a/devel/qt4-help/Makefile
+++ b/devel/qt4-help/Makefile
@@ -7,7 +7,6 @@
PORTNAME= help
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-libqtassistantclient/Makefile b/devel/qt4-libqtassistantclient/Makefile
index e14df9fd3267..851ca9ba2e13 100644
--- a/devel/qt4-libqtassistantclient/Makefile
+++ b/devel/qt4-libqtassistantclient/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libQtAssistantClient
PORTVERSION= 4.6.3
-PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-linguist/Makefile b/devel/qt4-linguist/Makefile
index 74d3086b21ec..b0a37da1ad5d 100644
--- a/devel/qt4-linguist/Makefile
+++ b/devel/qt4-linguist/Makefile
@@ -8,7 +8,6 @@
PORTNAME= linguist
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-makeqpf/Makefile b/devel/qt4-makeqpf/Makefile
index aa79fcd1a814..e6a183404b73 100644
--- a/devel/qt4-makeqpf/Makefile
+++ b/devel/qt4-makeqpf/Makefile
@@ -8,7 +8,6 @@
PORTNAME= makeqpf
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
@@ -46,6 +45,10 @@ INSTALL_WRKSRC= ${BUILD_WRKSRC}
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+.if ${OSVERSION} < 802502
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-tools__makeqpf__qpf2.cpp
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's|^TARGET[[:blank:]]*=[[:blank:]]*|TARGET=${PORTNAME}-qt4|g' \
${BUILD_WRKSRC}/${PORTNAME}.pro
diff --git a/devel/qt4-makeqpf/files/patch-tools-makeqpf-qpf2.cpp b/devel/qt4-makeqpf/files/extra-patch__tools__makeqpf__qpf2.cpp
index ab46d51ae6c7..ab46d51ae6c7 100644
--- a/devel/qt4-makeqpf/files/patch-tools-makeqpf-qpf2.cpp
+++ b/devel/qt4-makeqpf/files/extra-patch__tools__makeqpf__qpf2.cpp
diff --git a/devel/qt4-qdbusviewer/Makefile b/devel/qt4-qdbusviewer/Makefile
index cab8d623ca68..d62636ea063a 100644
--- a/devel/qt4-qdbusviewer/Makefile
+++ b/devel/qt4-qdbusviewer/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qdbusviewer
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-qdoc3/Makefile b/devel/qt4-qdoc3/Makefile
index 306ea197bf94..0ebbdde8792b 100644
--- a/devel/qt4-qdoc3/Makefile
+++ b/devel/qt4-qdoc3/Makefile
@@ -7,7 +7,6 @@
PORTNAME= qdoc3
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES= devel textproc
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-qt3support/Makefile b/devel/qt4-qt3support/Makefile
index 823f3ce917d3..0eabf96da490 100644
--- a/devel/qt4-qt3support/Makefile
+++ b/devel/qt4-qt3support/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qt3support
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel x11-toolkits
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-qvfb/Makefile b/devel/qt4-qvfb/Makefile
index 50718cd1a6f2..b8fc3bd5e262 100644
--- a/devel/qt4-qvfb/Makefile
+++ b/devel/qt4-qvfb/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qvfb
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-qvfb/files/patch-tools__qvfb__qvfb.pro b/devel/qt4-qvfb/files/patch-tools__qvfb__qvfb.pro
deleted file mode 100644
index db5b6d8a8623..000000000000
--- a/devel/qt4-qvfb/files/patch-tools__qvfb__qvfb.pro
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tools/qvfb/qvfb.pro.orig 2012-01-08 16:32:17.921428981 +0100
-+++ ./tools/qvfb/qvfb.pro 2012-01-08 16:33:01.611355995 +0100
-@@ -38,8 +38,6 @@
-
- !embedded {
- DEFINES += QT_NO_QWS_SIGNALHANDLER
-- HEADERS += ../../src/gui/embedded/qlock_p.h
-- SOURCES += ../../src/gui/embedded/qlock.cpp
- }
-
- include(../shared/deviceskin/deviceskin.pri)
diff --git a/devel/qt4-scripttools/Makefile b/devel/qt4-scripttools/Makefile
index 6b351aaa3cbe..4b76c5b2967a 100644
--- a/devel/qt4-scripttools/Makefile
+++ b/devel/qt4-scripttools/Makefile
@@ -7,7 +7,6 @@
PORTNAME= scripttools
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-uic3/Makefile b/devel/qt4-uic3/Makefile
index 9397aede8767..de05ab3c6a3f 100644
--- a/devel/qt4-uic3/Makefile
+++ b/devel/qt4-uic3/Makefile
@@ -8,7 +8,6 @@
PORTNAME= uic3
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4/distinfo b/devel/qt4/distinfo
index cb5f8a92998b..fbf29ccab5a5 100644
--- a/devel/qt4/distinfo
+++ b/devel/qt4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/qt-everywhere-opensource-src-4.8.1.tar.gz) = ef851a36aa41b4ad7a3e4c96ca27eaed2a629a6d2fa06c20f072118caed87ae8
-SIZE (KDE/qt-everywhere-opensource-src-4.8.1.tar.gz) = 239606696
+SHA256 (KDE/qt-everywhere-opensource-src-4.8.2.tar.gz) = 921b2a2d060934ceda65ae4615edec474cea13d3c893e7df19ad1262e7dc2379
+SIZE (KDE/qt-everywhere-opensource-src-4.8.2.tar.gz) = 239108331
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index 2f4ae9d4b69b..a672a857a744 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -8,7 +8,6 @@
PORTNAME= iconengines
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 4cf5f7d808e9..bf8c5c5b5af6 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -8,7 +8,6 @@
PORTNAME= imageformats
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index b42356577d5d..76818fe56b22 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -8,7 +8,6 @@
PORTNAME= pixeltool
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 43402033d8eb..af73d7b8b3fe 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -8,7 +8,6 @@
PORTNAME= svg
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= graphics
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-doc/pkg-plist b/misc/qt4-doc/pkg-plist
index 4931fa9a9c0a..17ce1bc873bb 100644
--- a/misc/qt4-doc/pkg-plist
+++ b/misc/qt4-doc/pkg-plist
@@ -1894,7 +1894,7 @@
%%DOCSDIR%%/html/images/appicon_screenshot.png
%%DOCSDIR%%/html/images/application-menus.png
%%DOCSDIR%%/html/images/application.png
-%%DOCSDIR%%/html/images/arrow.png
+%%DOCSDIR%%/html/images/arrow_bc.png
%%DOCSDIR%%/html/images/arrow_down.png
%%DOCSDIR%%/html/images/arthurplugin-demo.png
%%DOCSDIR%%/html/images/assistant-address-toolbar.png
diff --git a/misc/qt4-l10n/Makefile b/misc/qt4-l10n/Makefile
index 92a7b628b742..7add3a5b4af9 100644
--- a/misc/qt4-l10n/Makefile
+++ b/misc/qt4-l10n/Makefile
@@ -7,7 +7,6 @@
PORTNAME= l10n
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-qtconfig/Makefile b/misc/qt4-qtconfig/Makefile
index 5fe0393106cf..ef9d1ab2bff5 100644
--- a/misc/qt4-qtconfig/Makefile
+++ b/misc/qt4-qtconfig/Makefile
@@ -7,7 +7,6 @@
PORTNAME= qtconfig
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index c9a2c13119de..e2f724045a86 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -8,7 +8,6 @@
PORTNAME= qtdemo
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
diff --git a/multimedia/qt4-multimedia/Makefile b/multimedia/qt4-multimedia/Makefile
index c1da479f7e12..5d77b8b4051f 100644
--- a/multimedia/qt4-multimedia/Makefile
+++ b/multimedia/qt4-multimedia/Makefile
@@ -7,7 +7,6 @@
PORTNAME= multimedia
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
diff --git a/multimedia/qt4-phonon-gst/Makefile b/multimedia/qt4-phonon-gst/Makefile
index f3221e18b353..a484a98e27dc 100644
--- a/multimedia/qt4-phonon-gst/Makefile
+++ b/multimedia/qt4-phonon-gst/Makefile
@@ -7,7 +7,6 @@
PORTNAME= phonon
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
PKGNAMESUFFIX= -gst
diff --git a/multimedia/qt4-phonon/Makefile b/multimedia/qt4-phonon/Makefile
index c598de46b44f..32870c3de6de 100644
--- a/multimedia/qt4-phonon/Makefile
+++ b/multimedia/qt4-phonon/Makefile
@@ -7,7 +7,6 @@
PORTNAME= phonon
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= multimedia
PKGNAMEPREFIX= qt4-
diff --git a/net/qt4-network/pkg-plist b/net/qt4-network/pkg-plist
index 98487934715b..f86f9d38d4b8 100644
--- a/net/qt4-network/pkg-plist
+++ b/net/qt4-network/pkg-plist
@@ -15,6 +15,7 @@ include/qt4/Qt/qnetworkconfiguration.h
include/qt4/Qt/qnetworkcookie.h
include/qt4/Qt/qnetworkcookiejar.h
include/qt4/Qt/qnetworkdiskcache.h
+include/qt4/Qt/qnetworkfunctions_wince.h
include/qt4/Qt/qnetworkinterface.h
include/qt4/Qt/qnetworkproxy.h
include/qt4/Qt/qnetworkreply.h
@@ -90,6 +91,7 @@ include/qt4/QtNetwork/qnetworkconfiguration.h
include/qt4/QtNetwork/qnetworkcookie.h
include/qt4/QtNetwork/qnetworkcookiejar.h
include/qt4/QtNetwork/qnetworkdiskcache.h
+include/qt4/QtNetwork/qnetworkfunctions_wince.h
include/qt4/QtNetwork/qnetworkinterface.h
include/qt4/QtNetwork/qnetworkproxy.h
include/qt4/QtNetwork/qnetworkreply.h
diff --git a/www/qt4-webkit/Makefile b/www/qt4-webkit/Makefile
index 2d06e8783704..4c6cbe4d0ae4 100644
--- a/www/qt4-webkit/Makefile
+++ b/www/qt4-webkit/Makefile
@@ -7,7 +7,6 @@
PORTNAME= webkit
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= www
PKGNAMEPREFIX= qt4-
diff --git a/www/qt4-webkit/pkg-plist b/www/qt4-webkit/pkg-plist
index 101b5da42ea8..3923148494bf 100644
--- a/www/qt4-webkit/pkg-plist
+++ b/www/qt4-webkit/pkg-plist
@@ -64,7 +64,7 @@ lib/qt4/libQtWebKit.prl
lib/qt4/libQtWebKit.so
lib/qt4/libQtWebKit.so.4
lib/qt4/libQtWebKit.so.4.9
-lib/qt4/libQtWebKit.so.4.9.0
+lib/qt4/libQtWebKit.so.4.9.2
libdata/pkgconfig/QtWebKit.pc
share/qt4/mkspecs/modules/qt_webkit_version.pri
@dirrmtry share/qt4/mkspecs/modules
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 2ce5f8e689d2..7cf71375e83e 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -8,7 +8,6 @@
PORTNAME= gui
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11-toolkits
PKGNAMEPREFIX= qt4-
diff --git a/x11-toolkits/qt4-gui/files/patch-src__gui__text__qtextlayout.cpp b/x11-toolkits/qt4-gui/files/patch-src__gui__text__qtextlayout.cpp
deleted file mode 100644
index 7043bfc32308..000000000000
--- a/x11-toolkits/qt4-gui/files/patch-src__gui__text__qtextlayout.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/gui/text/qtextlayout.cpp.orig 2012-03-14 15:01:14.000000000 +0100
-+++ ./src/gui/text/qtextlayout.cpp 2012-04-03 09:40:53.779974016 +0200
-@@ -2508,6 +2508,10 @@
- int pos = *cursorPos;
- int itm;
- const HB_CharAttributes *attributes = eng->attributes();
-+ if (!attributes) {
-+ *cursorPos = 0;
-+ return x.toReal();
-+ }
- while (pos < line.from + line.length && !attributes[pos].charStop)
- pos++;
- if (pos == line.from + (int)line.length) {
diff --git a/x11/qt4-graphicssystems-opengl/Makefile b/x11/qt4-graphicssystems-opengl/Makefile
index 4f06486ad20d..025f56393b59 100644
--- a/x11/qt4-graphicssystems-opengl/Makefile
+++ b/x11/qt4-graphicssystems-opengl/Makefile
@@ -7,7 +7,6 @@
PORTNAME= graphicssystems
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
PKGNAMESUFFIX= -opengl
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index 211dafb87341..ef8f2ff8274e 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -8,7 +8,6 @@
PORTNAME= inputmethods
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index b049e02f321f..8c733042cc92 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,7 +8,6 @@
PORTNAME= opengl
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-