aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/xkeywrap/Makefile29
-rw-r--r--x11/xkeywrap/distinfo1
-rw-r--r--x11/xkeywrap/files/patch-aa21
-rw-r--r--x11/xkeywrap/pkg-comment1
-rw-r--r--x11/xkeywrap/pkg-descr28
-rw-r--r--x11/xkeywrap/pkg-plist5
6 files changed, 85 insertions, 0 deletions
diff --git a/x11/xkeywrap/Makefile b/x11/xkeywrap/Makefile
new file mode 100644
index 000000000000..731986a1f212
--- /dev/null
+++ b/x11/xkeywrap/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: XKeyWrap
+# Version required: 1.0
+# Date created: 7 January 2000
+# Whom: Sakai Hiroaki <sakai@seki.ee.kagu.sut.ac.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= xkeywrap-1.0
+CATEGORIES= x11
+MASTER_SITES= http://www.seki.ee.kagu.sut.ac.jp/~sakai/
+
+MAINTAINER= sakai@seki.ee.kagu.sut.ac.jp
+
+USE_X_PREFIX= yes
+MAN1= xkeywrap.1
+PORTSDOCDIR= ${PREFIX}/share/doc/xkeywrap
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xkeywrap ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xkeywrap.man ${PREFIX}/man/man1/xkeywrap.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PORTSDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${PORTSDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo.dat ${PORTSDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xkeywrap_demo.c ${PORTSDOCDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/xkeywrap/distinfo b/x11/xkeywrap/distinfo
new file mode 100644
index 000000000000..6c5535261141
--- /dev/null
+++ b/x11/xkeywrap/distinfo
@@ -0,0 +1 @@
+MD5 (xkeywrap-1.0.tar.gz) = 14166cfa1a18e07bfc6939472d1fc2f3
diff --git a/x11/xkeywrap/files/patch-aa b/x11/xkeywrap/files/patch-aa
new file mode 100644
index 000000000000..45aa881f8c85
--- /dev/null
+++ b/x11/xkeywrap/files/patch-aa
@@ -0,0 +1,21 @@
+*** Makefile~ Sun Jan 2 10:01:41 2000
+--- Makefile Sun Jan 2 10:02:17 2000
+***************
+*** 6,13 ****
+ ###############################################################################
+
+ #PREFIX = /usr/local
+! PREFIX = /usr/X11R6
+! X11BASE = /usr/X11R6
+ BINDIR = ${PREFIX}/bin
+ MANDIR = ${PREFIX}/man/man1
+ PKGNAME = xkeywrap-1.0
+--- 6,13 ----
+ ###############################################################################
+
+ #PREFIX = /usr/local
+! #PREFIX = /usr/X11R6
+! #X11BASE = /usr/X11R6
+ BINDIR = ${PREFIX}/bin
+ MANDIR = ${PREFIX}/man/man1
+ PKGNAME = xkeywrap-1.0
diff --git a/x11/xkeywrap/pkg-comment b/x11/xkeywrap/pkg-comment
new file mode 100644
index 000000000000..04192e18157c
--- /dev/null
+++ b/x11/xkeywrap/pkg-comment
@@ -0,0 +1 @@
+Record, repeat, and play key sequence from keyboard
diff --git a/x11/xkeywrap/pkg-descr b/x11/xkeywrap/pkg-descr
new file mode 100644
index 000000000000..5f5f5efe3aa3
--- /dev/null
+++ b/x11/xkeywrap/pkg-descr
@@ -0,0 +1,28 @@
+XKeyWrap is a wrapper of key sequence between keyboard and an application
+(ex.emacs).
+XKeyWrap can record, repeat, and play key sequence in real time.
+And XKeyWrap can send key sequence to an application on other X server
+over the network.
+
+If you want to read more details, type
+ % xkeywrap -readme
+and
+ % man xkeywrap
+
+If you want to see a demonstration of XKeyWrap, type
+ % cp /usr/X11R6/share/doc/xkeywrap/demo.dat .
+ % cp /usr/X11R6/share/doc/xkeywrap/xkeywrap_demo.c .
+ % xkeywrap -p -s 2 -f demo.dat -x emacs -geometry 80x25 xkeywrap_demo.c
+
+If you want to get the full or newest original destribution package
+of XKeyWrap, see
+
+WWW: http://www.seki.ee.kagu.sut.ac.jp/~sakai/myfreesoft.html
+
+This software is distributed under the GNU General Public License.
+If you want to get a copy of the GNU General Public License, see above
+web site and get the full original destribution package of XKeyWrap.
+
+- Sakai Hiroaki
+sakai@seki.ee.kagu.sut.ac.jp
+hsakai@pfu.co.jp
diff --git a/x11/xkeywrap/pkg-plist b/x11/xkeywrap/pkg-plist
new file mode 100644
index 000000000000..e04619e66327
--- /dev/null
+++ b/x11/xkeywrap/pkg-plist
@@ -0,0 +1,5 @@
+bin/xkeywrap
+share/doc/xkeywrap/README
+share/doc/xkeywrap/demo.dat
+share/doc/xkeywrap/xkeywrap_demo.c
+@dirrm share/doc/xkeywrap