aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/mame-devel/Makefile7
-rw-r--r--emulators/mame-devel/pkg-plist5
-rw-r--r--emulators/mame/Makefile7
-rw-r--r--emulators/mame/pkg-plist5
-rw-r--r--emulators/sdlmame-devel/Makefile7
-rw-r--r--emulators/sdlmame-devel/pkg-plist5
-rw-r--r--emulators/sdlmame/Makefile7
-rw-r--r--emulators/sdlmame/pkg-plist5
8 files changed, 48 insertions, 0 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index 78bdc0bf2f61..ac3befc2d47e 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdlmame
PORTVERSION= 0.130
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.arcadebsd.org/pub/FreeBSD/ports/distfiles/ \
http://rbelmont.mameworld.info/
@@ -47,6 +48,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/emulators/mame-devel/pkg-plist b/emulators/mame-devel/pkg-plist
index 3793f2175e57..fae88491a0c6 100644
--- a/emulators/mame-devel/pkg-plist
+++ b/emulators/mame-devel/pkg-plist
@@ -1,4 +1,8 @@
bin/sdlmame
+libexec/sdlmame/chdman
+libexec/sdlmame/ldverify
+libexec/sdlmame/ldresample
+libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
@@ -16,6 +20,7 @@ bin/sdlmame
%%EXAMPLESDIR%%/mame.ini
@dirrm %%DATADIR%%/keymaps/
@dirrm %%DATADIR%%/
+@dirrm libexec/sdlmame
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 78bdc0bf2f61..ac3befc2d47e 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdlmame
PORTVERSION= 0.130
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.arcadebsd.org/pub/FreeBSD/ports/distfiles/ \
http://rbelmont.mameworld.info/
@@ -47,6 +48,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/emulators/mame/pkg-plist b/emulators/mame/pkg-plist
index 3793f2175e57..fae88491a0c6 100644
--- a/emulators/mame/pkg-plist
+++ b/emulators/mame/pkg-plist
@@ -1,4 +1,8 @@
bin/sdlmame
+libexec/sdlmame/chdman
+libexec/sdlmame/ldverify
+libexec/sdlmame/ldresample
+libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
@@ -16,6 +20,7 @@ bin/sdlmame
%%EXAMPLESDIR%%/mame.ini
@dirrm %%DATADIR%%/keymaps/
@dirrm %%DATADIR%%/
+@dirrm libexec/sdlmame
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
index 78bdc0bf2f61..ac3befc2d47e 100644
--- a/emulators/sdlmame-devel/Makefile
+++ b/emulators/sdlmame-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdlmame
PORTVERSION= 0.130
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.arcadebsd.org/pub/FreeBSD/ports/distfiles/ \
http://rbelmont.mameworld.info/
@@ -47,6 +48,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/emulators/sdlmame-devel/pkg-plist b/emulators/sdlmame-devel/pkg-plist
index 3793f2175e57..fae88491a0c6 100644
--- a/emulators/sdlmame-devel/pkg-plist
+++ b/emulators/sdlmame-devel/pkg-plist
@@ -1,4 +1,8 @@
bin/sdlmame
+libexec/sdlmame/chdman
+libexec/sdlmame/ldverify
+libexec/sdlmame/ldresample
+libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
@@ -16,6 +20,7 @@ bin/sdlmame
%%EXAMPLESDIR%%/mame.ini
@dirrm %%DATADIR%%/keymaps/
@dirrm %%DATADIR%%/
+@dirrm libexec/sdlmame
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
index 78bdc0bf2f61..ac3befc2d47e 100644
--- a/emulators/sdlmame/Makefile
+++ b/emulators/sdlmame/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdlmame
PORTVERSION= 0.130
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.arcadebsd.org/pub/FreeBSD/ports/distfiles/ \
http://rbelmont.mameworld.info/
@@ -47,6 +48,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${MKDIR} ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/chdman ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldresample ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/ldverify ${PREFIX}/libexec/sdlmame
+ ${INSTALL_PROGRAM} ${WRKSRC}/testkeys ${PREFIX}/libexec/sdlmame
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
diff --git a/emulators/sdlmame/pkg-plist b/emulators/sdlmame/pkg-plist
index 3793f2175e57..fae88491a0c6 100644
--- a/emulators/sdlmame/pkg-plist
+++ b/emulators/sdlmame/pkg-plist
@@ -1,4 +1,8 @@
bin/sdlmame
+libexec/sdlmame/chdman
+libexec/sdlmame/ldverify
+libexec/sdlmame/ldresample
+libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
@@ -16,6 +20,7 @@ bin/sdlmame
%%EXAMPLESDIR%%/mame.ini
@dirrm %%DATADIR%%/keymaps/
@dirrm %%DATADIR%%/
+@dirrm libexec/sdlmame
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%EXAMPLESDIR%%