aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mnogosearch/Makefile5
-rw-r--r--www/mnogosearch/files/spelld.sh-dist3
-rw-r--r--www/mnogosearch/pkg-install2
-rw-r--r--www/mnogosearch31/Makefile5
-rw-r--r--www/mnogosearch31/files/spelld.sh-dist3
-rw-r--r--www/mnogosearch31/pkg-install2
6 files changed, 14 insertions, 6 deletions
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 3403397c2037..de02e42d6d01 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.1.19
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/
@@ -24,6 +25,8 @@ CONFIGURE_ARGS= --enable-phrase \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+RUN_DEPENDS+= ${LOCALBASE}/etc/apache/httpd.conf:${PORTSDIR}/www/apache13
+
.ifndef NO_OPENSSL
USE_OPENSSL= yes
.endif
@@ -69,7 +72,7 @@ pre-install:
post-install:
cd ${WRKSRC} && ${TAR} --create --file - --exclude CVS create | (cd ${PREFIX}/share/mnogosearch && ${TAR} xf -)
${CHMOD} 700 /var/mnogosearch/cache
- ${CHOWN} -R nobody:nogroup /var/mnogosearch/
+ ${CHOWN} -R www:www /var/mnogosearch/
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/mnogosearch
${INSTALL_DATA} ${FILESDIR}/spelld.sh-dist ${PREFIX}/etc/rc.d/
@${ECHO}
diff --git a/www/mnogosearch/files/spelld.sh-dist b/www/mnogosearch/files/spelld.sh-dist
index 195b48d410db..1f10515ace47 100644
--- a/www/mnogosearch/files/spelld.sh-dist
+++ b/www/mnogosearch/files/spelld.sh-dist
@@ -1,4 +1,5 @@
#!/bin/sh
+# $FreeBSD$
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
@@ -10,7 +11,7 @@ start)
if [ -x ${PREFIX}/sbin/spelld ]; then
# Uncomment to disallow access from outside
# /sbin/ipfw -q add 7001 deny tcp from any to any 7001
- su -f -m nobody -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
+ su -f -m www -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
fi
;;
stop)
diff --git a/www/mnogosearch/pkg-install b/www/mnogosearch/pkg-install
index 9b16414b95ae..a191b8346c2c 100644
--- a/www/mnogosearch/pkg-install
+++ b/www/mnogosearch/pkg-install
@@ -9,7 +9,7 @@ case $2 in
mkdir -m 755 /var/mnogosearch/raw
mkdir -m 755 /var/mnogosearch/splitter
mkdir -m 755 /var/mnogosearch/tree
- chown -R nobody:nogroup /var/mnogosearch
+ chown -R www:www /var/mnogosearch
;;
*)
echo "Unexpected Argument $2!!!"
diff --git a/www/mnogosearch31/Makefile b/www/mnogosearch31/Makefile
index 3403397c2037..de02e42d6d01 100644
--- a/www/mnogosearch31/Makefile
+++ b/www/mnogosearch31/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.1.19
+PORTREVISION= 1
CATEGORIES= www databases
MASTER_SITES= http://search.mnogo.ru/Download/
@@ -24,6 +25,8 @@ CONFIGURE_ARGS= --enable-phrase \
--sysconfdir=${PREFIX}/etc/mnogosearch \
--localstatedir=/var/mnogosearch
+RUN_DEPENDS+= ${LOCALBASE}/etc/apache/httpd.conf:${PORTSDIR}/www/apache13
+
.ifndef NO_OPENSSL
USE_OPENSSL= yes
.endif
@@ -69,7 +72,7 @@ pre-install:
post-install:
cd ${WRKSRC} && ${TAR} --create --file - --exclude CVS create | (cd ${PREFIX}/share/mnogosearch && ${TAR} xf -)
${CHMOD} 700 /var/mnogosearch/cache
- ${CHOWN} -R nobody:nogroup /var/mnogosearch/
+ ${CHOWN} -R www:www /var/mnogosearch/
${INSTALL_DATA} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/mnogosearch
${INSTALL_DATA} ${FILESDIR}/spelld.sh-dist ${PREFIX}/etc/rc.d/
@${ECHO}
diff --git a/www/mnogosearch31/files/spelld.sh-dist b/www/mnogosearch31/files/spelld.sh-dist
index 195b48d410db..1f10515ace47 100644
--- a/www/mnogosearch31/files/spelld.sh-dist
+++ b/www/mnogosearch31/files/spelld.sh-dist
@@ -1,4 +1,5 @@
#!/bin/sh
+# $FreeBSD$
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
@@ -10,7 +11,7 @@ start)
if [ -x ${PREFIX}/sbin/spelld ]; then
# Uncomment to disallow access from outside
# /sbin/ipfw -q add 7001 deny tcp from any to any 7001
- su -f -m nobody -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
+ su -f -m www -c "exec ${PREFIX}/sbin/spelld &" > /dev/null 2>&1 && echo -n ' spelld'
fi
;;
stop)
diff --git a/www/mnogosearch31/pkg-install b/www/mnogosearch31/pkg-install
index 9b16414b95ae..a191b8346c2c 100644
--- a/www/mnogosearch31/pkg-install
+++ b/www/mnogosearch31/pkg-install
@@ -9,7 +9,7 @@ case $2 in
mkdir -m 755 /var/mnogosearch/raw
mkdir -m 755 /var/mnogosearch/splitter
mkdir -m 755 /var/mnogosearch/tree
- chown -R nobody:nogroup /var/mnogosearch
+ chown -R www:www /var/mnogosearch
;;
*)
echo "Unexpected Argument $2!!!"