aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/xsc/Makefile19
-rw-r--r--games/xsc/distinfo1
-rw-r--r--games/xsc/pkg-comment1
-rw-r--r--games/xsc/pkg-descr15
-rw-r--r--games/xsc/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0e0e1c888b82..8144be3b2af7 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -310,6 +310,7 @@
SUBDIR += xrobots
SUBDIR += xrot
SUBDIR += xrubik
+ SUBDIR += xsc
SUBDIR += xscavenger
SUBDIR += xscorch
SUBDIR += xscrabble
diff --git a/games/xsc/Makefile b/games/xsc/Makefile
new file mode 100644
index 000000000000..689a39ae174a
--- /dev/null
+++ b/games/xsc/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: xsc
+# Date created: Apr 16, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xsc
+PORTVERSION= 1.3
+CATEGORIES= games
+MASTER_SITES= http://www.panix.com/~mbh/xsc/
+
+MAINTAINER= mark@kyne.com.au
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include" LDFLAGS="${LDFLAGS} -L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/games/xsc/distinfo b/games/xsc/distinfo
new file mode 100644
index 000000000000..01331e8a2055
--- /dev/null
+++ b/games/xsc/distinfo
@@ -0,0 +1 @@
+MD5 (xsc-1.3.tar.gz) = 4b9c605dc94369f5ab93cfd921c70e85
diff --git a/games/xsc/pkg-comment b/games/xsc/pkg-comment
new file mode 100644
index 000000000000..87ec44d236df
--- /dev/null
+++ b/games/xsc/pkg-comment
@@ -0,0 +1 @@
+A vector graphics space shoot'em up game
diff --git a/games/xsc/pkg-descr b/games/xsc/pkg-descr
new file mode 100644
index 000000000000..4ae8c0679c66
--- /dev/null
+++ b/games/xsc/pkg-descr
@@ -0,0 +1,15 @@
+Xsc is a clone of the old vector graphics video game Star Castle by
+Cinematronics. The object is to destroy the enemy ship, destroying its
+protective rings first while dodging various buzzers and fireballs
+sent to destroy you.
+
+Keys:
+D turn counter-clockwise
+F turn clockwise
+J thrust
+K fire laser
+P pause
+Q quit
+space new game
+
+WWW: http://www.panix.com/~mbh/projects.html
diff --git a/games/xsc/pkg-plist b/games/xsc/pkg-plist
new file mode 100644
index 000000000000..eb9a0b815ac0
--- /dev/null
+++ b/games/xsc/pkg-plist
@@ -0,0 +1 @@
+bin/xsc