aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/Makefile1
-rw-r--r--print/pdfmixtool/Makefile40
-rw-r--r--print/pdfmixtool/distinfo3
-rw-r--r--print/pdfmixtool/pkg-descr12
-rw-r--r--print/pdfmixtool/pkg-plist8
5 files changed, 64 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index b2165ccc23f6..6885e6bb6463 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -147,6 +147,7 @@
SUBDIR += pdfchain
SUBDIR += pdflib
SUBDIR += pdflib-perl
+ SUBDIR += pdfmixtool
SUBDIR += pdfstitch
SUBDIR += pdftk
SUBDIR += pear-File_PDF
diff --git a/print/pdfmixtool/Makefile b/print/pdfmixtool/Makefile
new file mode 100644
index 000000000000..9173e536f3b9
--- /dev/null
+++ b/print/pdfmixtool/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= pdfmixtool
+DISTVERSION= 1.1.1
+CATEGORIES= print graphics editors
+PKGNAMESUFFIX= -${FLAVOR}
+
+MAINTAINER= dev@submerge.ch
+COMMENT= Application to split, merge, rotate and mix PDF files
+WWW= https://www.scarpetta.eu/pdfmixtool/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libqpdf.so:print/qpdf
+qt6_BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+
+FLAVORS= qt5 qt6
+FLAVOR?= ${FLAVORS:[1]}
+
+USES= cmake compiler:c++11-lang desktop-file-utils magick pkgconfig
+
+.if ${FLAVOR} == qt5
+USES+= qt:5
+USE_QT= buildtools:build core gui linguisttools:build qmake:build \
+ svg widgets xml
+.elif ${FLAVOR} == qt6
+USES+= gl qt:6
+USE_GL= gl opengl
+USE_QT= base tools:build svg
+CMAKE_ARGS+= -DQT_VERSION=6
+.endif
+
+USE_GITLAB= yes
+GL_ACCOUNT= scarpetta
+GL_COMMIT= 35d482029881d9904c6e7487fe7572a3a5795406
+
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFLICTS_INSTALL= pdfmixtool-qt5 pdfmixtool-qt6
+
+.include <bsd.port.mk>
diff --git a/print/pdfmixtool/distinfo b/print/pdfmixtool/distinfo
new file mode 100644
index 000000000000..46e6f29df871
--- /dev/null
+++ b/print/pdfmixtool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1668987650
+SHA256 (scarpetta-pdfmixtool-35d482029881d9904c6e7487fe7572a3a5795406_GL0.tar.gz) = ec767369f8d9fb02f320ec9f6044b0fc5bd962dbc45cc7b1be9c69cfa620c2b0
+SIZE (scarpetta-pdfmixtool-35d482029881d9904c6e7487fe7572a3a5795406_GL0.tar.gz) = 174137
diff --git a/print/pdfmixtool/pkg-descr b/print/pdfmixtool/pkg-descr
new file mode 100644
index 000000000000..94529e5517b4
--- /dev/null
+++ b/print/pdfmixtool/pkg-descr
@@ -0,0 +1,12 @@
+PDF Mix Tool is a simple and lightweight application that allows you to perform
+common editing operations on PDF files.
+
+Base operations it can perform are the following:
+* Merge two or more files specifying a page set for each of them
+* Rotate pages
+* Composite more pages onto a single one (N-up)
+* Combinations of all of the above
+
+Besides, it can also mix files alternating their pages, generate booklets,
+add white pages to a PDF file, delete pages from a PDF file, extract pages from
+a PDF file, edit the PDF document information, extract images from a PDF file.
diff --git a/print/pdfmixtool/pkg-plist b/print/pdfmixtool/pkg-plist
new file mode 100644
index 000000000000..0a6384174fd4
--- /dev/null
+++ b/print/pdfmixtool/pkg-plist
@@ -0,0 +1,8 @@
+bin/pdfmixtool
+share/applications/eu.scarpetta.PDFMixTool.desktop
+share/icons/hicolor/128x128/apps/eu.scarpetta.PDFMixTool.png
+share/icons/hicolor/256x256/apps/eu.scarpetta.PDFMixTool.png
+share/icons/hicolor/48x48/apps/eu.scarpetta.PDFMixTool.png
+share/icons/hicolor/64x64/apps/eu.scarpetta.PDFMixTool.png
+share/icons/hicolor/scalable/apps/eu.scarpetta.PDFMixTool.svg
+share/metainfo/eu.scarpetta.PDFMixTool.appdata.xml