aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/spiralloops/Makefile2
-rw-r--r--audio/spiralsynth/Makefile2
-rw-r--r--audio/spiralsynthmodular/Makefile2
-rw-r--r--biology/seaview/Makefile2
-rw-r--r--comms/fldigi/Makefile2
-rw-r--r--comms/flwrap/Makefile2
-rw-r--r--finance/xtrader/Makefile2
-rw-r--r--games/toycars/Makefile2
-rw-r--r--graphics/cinepaint/Makefile2
-rw-r--r--graphics/quat-gui/Makefile2
-rw-r--r--multimedia/openmovieeditor/Makefile2
-rw-r--r--science/flounder/Makefile2
-rw-r--r--x11-toolkits/flu/Makefile2
-rw-r--r--x11-toolkits/py-fltk/Makefile2
-rw-r--r--x11-wm/flwm/Makefile2
15 files changed, 30 insertions, 0 deletions
diff --git a/audio/spiralloops/Makefile b/audio/spiralloops/Makefile
index 4b2af5962927..5ef0e96e33ec 100644
--- a/audio/spiralloops/Makefile
+++ b/audio/spiralloops/Makefile
@@ -17,6 +17,8 @@ COMMENT= Loop-based sampler
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
DOCDIR= share/doc/${PORTNAME}
DOC_FILES= CHANGES COPYING README
GNU_CONFIGURE= yes
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 24acb8166722..445786de7525 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -17,6 +17,8 @@ COMMENT= MIDI-capable synthesizer for X
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
GNU_CONFIGURE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
diff --git a/audio/spiralsynthmodular/Makefile b/audio/spiralsynthmodular/Makefile
index 55f6898f8ac1..f4b0f6ec7406 100644
--- a/audio/spiralsynthmodular/Makefile
+++ b/audio/spiralsynthmodular/Makefile
@@ -20,6 +20,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
sndfile.1:${PORTSDIR}/audio/libsndfile
+BROKEN= does not compile
+
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/biology/seaview/Makefile b/biology/seaview/Makefile
index 335f3e9aca8e..b5f68db04374 100644
--- a/biology/seaview/Makefile
+++ b/biology/seaview/Makefile
@@ -20,6 +20,8 @@ COMMENT= Multiple DNA/protein sequence alignment editor
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
pdf.8:${PORTSDIR}/print/pdflib
+BROKEN= does not compile
+
NO_WRKSUBDIR= yes
EXTRACT_CMD= ${CAT}
EXTRACT_BEFORE_ARGS= #
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 59cead32d40b..842259f100a5 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -23,6 +23,8 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
xsltproc:${PORTSDIR}/textproc/libxslt
+BROKEN= does not compile
+
GNU_CONFIGURE= yes
USE_DOS2UNIX= yes
USE_GMAKE= yes
diff --git a/comms/flwrap/Makefile b/comms/flwrap/Makefile
index 5ca04229bd14..34ac30b4c2e0 100644
--- a/comms/flwrap/Makefile
+++ b/comms/flwrap/Makefile
@@ -17,6 +17,8 @@ COMMENT= Flwrap is a companion utility for fldigi
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/finance/xtrader/Makefile b/finance/xtrader/Makefile
index 1355ca260154..de96e273a9d6 100644
--- a/finance/xtrader/Makefile
+++ b/finance/xtrader/Makefile
@@ -17,6 +17,8 @@ COMMENT= Technical analysis program for financial instruments
LIB_DEPENDS= ptypes.21:${PORTSDIR}/devel/ptypes \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= Makefile.linux
USE_XORG= x11 xpm
diff --git a/games/toycars/Makefile b/games/toycars/Makefile
index e25a66a69713..85733bf01296 100644
--- a/games/toycars/Makefile
+++ b/games/toycars/Makefile
@@ -16,6 +16,8 @@ COMMENT= Physics-based 2D racing game
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
USE_SDL= image sdl
USE_GL= gl glu
USE_GMAKE= yes
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 72fc944122b6..912c36e61967 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -29,6 +29,8 @@ USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_XORG= xpm
+BROKEN= does not compile
+
MAN1= cinepaint.1 cinepainttool.1
PLIST_SUB= VER=${PORTVERSION}-1
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 6b5249228148..dbdb00840308 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -18,6 +18,8 @@ COMMENT= A Three-dimensional fractal creator (X11 GUI)
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
USE_XORG= xext
USE_GL= gl glut
GNU_CONFIGURE= yes
diff --git a/multimedia/openmovieeditor/Makefile b/multimedia/openmovieeditor/Makefile
index c6045dcd39d6..08edc56b3537 100644
--- a/multimedia/openmovieeditor/Makefile
+++ b/multimedia/openmovieeditor/Makefile
@@ -28,6 +28,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libmpeg3.a:${PORTSDIR}/multimedia/libmpeg3 \
${LOCALBASE}/lib/libquicktime/lqt_lame.so:${PORTSDIR}/multimedia/libquicktime-lame
RUN_DEPENDS= ${LOCALBASE}/lib/libquicktime/lqt_lame.so:${PORTSDIR}/multimedia/libquicktime-lame
+BROKEN= does not compile
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= yes
diff --git a/science/flounder/Makefile b/science/flounder/Makefile
index 6b71f83ef247..b108a6a57368 100644
--- a/science/flounder/Makefile
+++ b/science/flounder/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
ungif:${PORTSDIR}/graphics/libungif \
png:${PORTSDIR}/graphics/png
+BROKEN= does not compile
+
USE_GL= glut
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/flu/Makefile b/x11-toolkits/flu/Makefile
index fd690fdfab41..acf841a5e4b9 100644
--- a/x11-toolkits/flu/Makefile
+++ b/x11-toolkits/flu/Makefile
@@ -17,6 +17,8 @@ COMMENT= A library containing extra widgets for FLTK
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
USE_GL= gl
USE_LDCONFIG= yes
HAS_CONFIGURE= yes
diff --git a/x11-toolkits/py-fltk/Makefile b/x11-toolkits/py-fltk/Makefile
index 29e5e40b2c87..52c388249e5d 100644
--- a/x11-toolkits/py-fltk/Makefile
+++ b/x11-toolkits/py-fltk/Makefile
@@ -18,6 +18,8 @@ COMMENT= Python interface to FLTK window toolkit
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN== does not compile
+
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
USE_XORG= x11
diff --git a/x11-wm/flwm/Makefile b/x11-wm/flwm/Makefile
index 6eb5c1cfdc9e..0de2e0b31cd3 100644
--- a/x11-wm/flwm/Makefile
+++ b/x11-wm/flwm/Makefile
@@ -17,6 +17,8 @@ COMMENT= The Fast Light Window Manager
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+BROKEN= does not compile
+
USE_XORG= x11 xt
GNU_CONFIGURE= yes