aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl7
2 files changed, 7 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 6cdf645fc588..c83969c45e9a 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,5 +1,5 @@
PORTNAME= portlint
-PORTVERSION= 2.21.0
+PORTVERSION= 2.22.0
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index f8d7185e8827..5fa4267e6065 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -51,7 +51,7 @@ $portdir = '.';
# version variables
my $major = 2;
-my $minor = 21;
+my $minor = 22;
my $micro = 0;
# default setting - for FreeBSD
@@ -1406,6 +1406,11 @@ sub checkmakefile {
}
}
$rawwhole .= $_;
+ if (/\\$/) {
+ # Concat continued lines.
+ chomp $rawwhole;
+ chop $rawwhole;
+ }
}
close(IN);