aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/py-orange3-single-cell/Makefile3
-rw-r--r--finance/electrum/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/biology/py-orange3-single-cell/Makefile b/biology/py-orange3-single-cell/Makefile
index 2290c9126a11..35249d39deb6 100644
--- a/biology/py-orange3-single-cell/Makefile
+++ b/biology/py-orange3-single-cell/Makefile
@@ -22,7 +22,8 @@ RUN_DEPENDS= orange3>0:misc/orange3 \
${PYTHON_PKGNAMEPREFIX}scikit-learn>0:science/py-scikit-learn@${PY_FLAVOR} \
${PYNUMPY}
-USES= python:3.4+
+# Supports 3.4+ but loompy 3.6+ only.
+USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= biolab
USE_PYTHON= distutils autoplist
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index 6d3acbcb5177..b267fe4ca298 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -30,7 +30,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp-socks>=0.2:net/py-aiohttp-socks@${PY
CONFLICTS_INSTALL= electrum2-*
-USES= desktop-file-utils pyqt:5 python:3.4+
+# Supports 3.4+ but aiorpcX is 3.6+
+USES= desktop-file-utils pyqt:5 python:3.6+
USE_PYQT= gui_run sip widgets
USE_PYTHON= autoplist distutils optsuffix
PYDISTUTILS_PKGNAME= Electrum