aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/gnomint/Makefile38
-rw-r--r--security/gnomint/distinfo2
-rw-r--r--security/gnomint/files/patch-configure15
-rw-r--r--security/gnomint/files/patch-src__Makefile.in11
-rw-r--r--security/gnomint/pkg-descr5
-rw-r--r--security/gnomint/pkg-plist75
7 files changed, 147 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 789e195d0663..7775cd8936b1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -159,6 +159,7 @@
SUBDIR += gnome-keyring-sharp
SUBDIR += gnome-password-generator
SUBDIR += gnome-ssh-askpass
+ SUBDIR += gnomint
SUBDIR += gnupg
SUBDIR += gnupg-idea
SUBDIR += gnupg1
diff --git a/security/gnomint/Makefile b/security/gnomint/Makefile
new file mode 100644
index 000000000000..d779a9528118
--- /dev/null
+++ b/security/gnomint/Makefile
@@ -0,0 +1,38 @@
+# Created by: Kevin Zheng <kevinz5000@gmail.com>
+# $FreeBSD$
+
+PORTNAME= gnomint
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= X.509 Certification Authority management tool
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ gnutls:${PORTSDIR}/security/gnutls \
+ sqlite3:${PORTSDIR}/databases/sqlite3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gconf2 gdkpixbuf2 glib20 gtk20
+USE_PERL5= yes
+CFLAGS:= ${CFLAGS:C/-Werror//}
+
+MAKE_JOBS_SAFE= yes
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/gnomint/distinfo b/security/gnomint/distinfo
new file mode 100644
index 000000000000..d5f832b87155
--- /dev/null
+++ b/security/gnomint/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnomint-1.2.1.tar.gz) = 6186ca6073e912bad5e0b026bc704430098a54392f3741d62929cc6fca3c38b0
+SIZE (gnomint-1.2.1.tar.gz) = 703316
diff --git a/security/gnomint/files/patch-configure b/security/gnomint/files/patch-configure
new file mode 100644
index 000000000000..0a4c8ea90a86
--- /dev/null
+++ b/security/gnomint/files/patch-configure
@@ -0,0 +1,15 @@
+--- ./configure.orig 2010-08-11 04:12:26.000000000 -0500
++++ ./configure 2013-02-18 10:26:44.000000000 -0600
+@@ -14337,12 +14337,6 @@
+
+
+
+-if test "x$GCC" = "xyes"; then
+- CFLAGS="-Wall -Werror"
+- if test "x$use_debug" = "xYes"; then
+- CFLAGS="$CFLAGS -g -O0"
+- fi
+-fi
+
+
+
diff --git a/security/gnomint/files/patch-src__Makefile.in b/security/gnomint/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..244cbb86ea10
--- /dev/null
+++ b/security/gnomint/files/patch-src__Makefile.in
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig 2010-08-11 04:12:26.000000000 -0500
++++ ./src/Makefile.in 2013-02-18 10:28:58.000000000 -0600
+@@ -98,7 +98,7 @@
+ $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) -lgcrypt -o $@
+ SOURCES = $(gnomint_SOURCES) $(gnomint_cli_SOURCES)
+ DIST_SOURCES = $(gnomint_SOURCES) $(gnomint_cli_SOURCES)
+ ETAGS = etags
diff --git a/security/gnomint/pkg-descr b/security/gnomint/pkg-descr
new file mode 100644
index 000000000000..26128d920c38
--- /dev/null
+++ b/security/gnomint/pkg-descr
@@ -0,0 +1,5 @@
+gnoMint is an X.509 Certificate Authority (CA) management tool with both a GTK
+and command-line interface. It allows anyone to create and manage a CA without
+having to write configuration files or remember long command-line arguments.
+
+WWW: http://gnomint.sourceforge.net/
diff --git a/security/gnomint/pkg-plist b/security/gnomint/pkg-plist
new file mode 100644
index 000000000000..7c7a5e936bed
--- /dev/null
+++ b/security/gnomint/pkg-plist
@@ -0,0 +1,75 @@
+bin/gnomint
+bin/gnomint-cli
+bin/gnomint-upgrade-db
+share/pixmaps/gnomint.png
+share/applications/gnomint.desktop
+@dirrmtry share/applications
+%%DATADIR%%/addca.png
+%%DATADIR%%/addcsr.png
+%%DATADIR%%/ca-stamp-16.png
+%%DATADIR%%/certificate_popup_menu.ui
+%%DATADIR%%/certificate_properties_dialog.ui
+%%DATADIR%%/change_password_dialog.ui
+%%DATADIR%%/creation_process_window.ui
+%%DATADIR%%/csr_popup_menu.ui
+%%DATADIR%%/csr_properties_dialog.ui
+%%DATADIR%%/dh_parameters_dialog.ui
+%%DATADIR%%/export_certificate_dialog.ui
+%%DATADIR%%/extractpkey.png
+%%DATADIR%%/get_db_password_dialog.ui
+%%DATADIR%%/get_password_dialog.ui
+%%DATADIR%%/get_pkey_dialog.ui
+%%DATADIR%%/gnomint.png
+%%DATADIR%%/import_file_or_directory_dialog.ui
+%%DATADIR%%/import_password_dialog.ui
+%%DATADIR%%/key-16.png
+%%DATADIR%%/main_window.ui
+%%DATADIR%%/new_ca_window.ui
+%%DATADIR%%/new_cert_window.ui
+%%DATADIR%%/new_crl_dialog.ui
+%%DATADIR%%/new_req_window.ui
+%%DATADIR%%/preferences_dialog.ui
+%%DATADIR%%/sign.png
+@dirrmtry %%DATADIR%%
+share/mime/packages/gnomint.xml
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+etc/gconf/schemas/gnomint.schemas
+@dirrmtry lib/pkgconfig
+%%NLS%%lib/locale/ca/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/ca/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/ca
+%%NLS%%lib/locale/cs/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/cs/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/cs
+%%NLS%%lib/locale/de/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/de
+%%NLS%%lib/locale/es/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/es/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/es
+%%NLS%%lib/locale/fi/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/fi/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/fi
+%%NLS%%lib/locale/fr/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/fr/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/fr
+%%NLS%%lib/locale/it/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/it
+%%NLS%%lib/locale/pt_BR/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/pt_BR
+%%NLS%%lib/locale/oc/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/oc/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/oc
+%%NLS%%lib/locale/ru/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/ru/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/ru
+%%NLS%%lib/locale/sk/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/sk/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/sk
+%%NLS%%lib/locale/sv/LC_MESSAGES/gnomint.mo
+%%NLS%%@dirrmtry lib/locale/sv/LC_MESSAGES
+%%NLS%%@dirrmtry lib/locale/sv
+%%NLS%%@dirrmtry lib/locale