aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/mongodb70/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/mongodb70/Makefile b/databases/mongodb70/Makefile
index 1c6014f85129..68707fd1a4dc 100644
--- a/databases/mongodb70/Makefile
+++ b/databases/mongodb70/Makefile
@@ -104,6 +104,12 @@ NOAVX_MAKE_ARGS= --experimental-optimization="-sandybridge"
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_MAKE_ARGS= --use-sasl-client
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1500026 # llvm 19.1.2 import
+USES+= llvm:max=18,build
+.endif
+
.include <bsd.port.pre.mk>
ALL_TARGET= install-core