aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/geckodriver/Makefile36
-rw-r--r--www/geckodriver/distinfo5
-rw-r--r--www/geckodriver/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b272840d63ad..07b41388cedb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -193,6 +193,7 @@
SUBDIR += gallery3
SUBDIR += gatling
SUBDIR += gecko-mediaplayer
+ SUBDIR += geckodriver
SUBDIR += geeklog
SUBDIR += geeknote
SUBDIR += geneweb
diff --git a/www/geckodriver/Makefile b/www/geckodriver/Makefile
new file mode 100644
index 000000000000..e2088e1b37bc
--- /dev/null
+++ b/www/geckodriver/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= geckodriver
+PORTVERSION= 0.14.0
+CATEGORIES= www
+MASTER_SITES= http://freebsd-ports.mytaste.org/www/geckodriver/:crates
+DISTFILES= registry-${PORTVERSION}.tar.gz:crates
+
+MAINTAINER= daniel@blodan.se
+COMMENT= Proxy for using WebDriver clients with Gecko-based browsers
+
+LICENSE= MPL
+
+BUILD_DEPENDS= cargo:devel/cargo
+
+USE_GITHUB= yes
+GH_ACCOUNT= mozilla
+GH_TAGNAME= a49be92
+
+MAKE_ENV= CARGO_HOME=${BUILD_WRKSRC}
+
+PLIST_FILES= bin/geckodriver
+
+post-extract:
+ cd ${WRKDIR} && ${COPYTREE_SHARE} registry ${WRKSRC}
+ ${MKDIR} ${BUILD_WRKSRC}/.cargo
+ ${ECHO} "[source.crates-io]" > ${BUILD_WRKSRC}/.cargo/config
+ ${ECHO} "local-registry = 'registry'" >> ${BUILD_WRKSRC}/.cargo/config
+
+do-build:
+ cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} cargo build --release --verbose
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/target/release/geckodriver ${STAGEDIR}${PREFIX}/bin/geckodriver
+
+.include <bsd.port.mk>
diff --git a/www/geckodriver/distinfo b/www/geckodriver/distinfo
new file mode 100644
index 000000000000..062da9fba8c5
--- /dev/null
+++ b/www/geckodriver/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1485946886
+SHA256 (registry-0.14.0.tar.gz) = 836249d4f748de6ad46605d848f2070bb70a0ab26ae9527854a29a0ef0e367cf
+SIZE (registry-0.14.0.tar.gz) = 8320537
+SHA256 (mozilla-geckodriver-0.14.0-a49be92_GH0.tar.gz) = 4b97ab904101d243e17e5851389bec7d3989dd22c1750fcbd0e4aab392f68348
+SIZE (mozilla-geckodriver-0.14.0-a49be92_GH0.tar.gz) = 41558
diff --git a/www/geckodriver/pkg-descr b/www/geckodriver/pkg-descr
new file mode 100644
index 000000000000..d476f0dc1171
--- /dev/null
+++ b/www/geckodriver/pkg-descr
@@ -0,0 +1,6 @@
+This program provides the HTTP API described by the
+WebDriver protocol to communicate with Gecko browsers, such as Firefox.
+It translates calls into the Marionette automation protocol by acting
+as a proxy between the local- and remote ends.
+
+WWW: https://github.com/mozilla/geckodriver