aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/Makefile1
-rw-r--r--editors/codelite/Makefile70
-rw-r--r--editors/codelite/distinfo3
-rw-r--r--editors/codelite/files/patch-configure34
-rw-r--r--editors/codelite/pkg-descr6
-rw-r--r--editors/codelite/pkg-plist92
6 files changed, 206 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index ee687f4311d9..be9b66712ec5 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -29,6 +29,7 @@
SUBDIR += cle
SUBDIR += code-browser
SUBDIR += codeeditor
+ SUBDIR += codelite
SUBDIR += color-mate
SUBDIR += conglomerate
SUBDIR += cooledit
diff --git a/editors/codelite/Makefile b/editors/codelite/Makefile
new file mode 100644
index 000000000000..a89e1b5f028f
--- /dev/null
+++ b/editors/codelite/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: codelite
+# Date created: 7 May 2008
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= codelite
+DISTVERSION= r1528
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= gahr
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= An Open Source IDE for C/C++
+
+OPTIONS= CSCOPE "Enable CScope integration" OFF
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
+USE_WX= 2.8
+WX_UNICODE= yes
+USE_GNOME= gtk20
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386
+
+.if defined(WITH_CSCOPE)
+RUN_DEPENDS+= cscope:${PORTSDIR}/devel/cscope
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/makefile.base
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR}/config
+ ${MKDIR} ${DATADIR}/rc
+ ${MKDIR} ${DATADIR}/templates
+ ${MKDIR} ${DATADIR}/lexers
+ ${MKDIR} ${DATADIR}/debuggers
+ ${MKDIR} ${DATADIR}/plugins
+ ${MKDIR} ${DATADIR}/images
+ ${INSTALL_PROGRAM} ${WRKSRC}/Runtime/CodeLiteUR ${PREFIX}/bin/CodeLite
+ ${INSTALL_SCRIPT} ${WRKSRC}/Runtime/le_dos2unix.sh ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/Runtime/le_exec.sh ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/Runtime/le_killproc.sh ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/sdk/ctags/ctags-le ${PREFIX}/bin
+ (cd ${WRKSRC}/Runtime/config/ && ${COPYTREE_SHARE} \* ${DATADIR}/config)
+ (cd ${WRKSRC}/Runtime/rc/ && ${COPYTREE_SHARE} \*.xrc ${DATADIR}/rc)
+ (cd ${WRKSRC}/Runtime/templates && ${COPYTREE_SHARE} \* ${DATADIR}/templates)
+ (cd ${WRKSRC}/Runtime/lexers && ${COPYTREE_SHARE} \* ${DATADIR}/lexers)
+ ${INSTALL_DATA} ${WRKSRC}/lib/Debugger.so ${DATADIR}/debuggers
+.for lib in CodeFormatter Subversion ReferenceAnalyser cscope Gizmos
+ ${INSTALL_DATA} ${WRKSRC}/lib/${lib}.so ${DATADIR}/plugins
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/Runtime/index.html ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Runtime/astyle.sample ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Runtime/svnreport.html ${DATADIR}
+ (cd ${WRKSRC}/Runtime/images && ${COPYTREE_SHARE} \*.png ${DATADIR}/images)
+ ${INSTALL} -d ${PREFIX}/share/applications
+ ${INSTALL} ${WRKSRC}/Runtime/codelite.desktop ${PREFIX}/share/applications/
+
+.include <bsd.port.post.mk>
diff --git a/editors/codelite/distinfo b/editors/codelite/distinfo
new file mode 100644
index 000000000000..62ccfbc77457
--- /dev/null
+++ b/editors/codelite/distinfo
@@ -0,0 +1,3 @@
+MD5 (codelite-r1528.tar.bz2) = 45b28df0a2b8e66a9a8329207edff8bd
+SHA256 (codelite-r1528.tar.bz2) = 7aefb3f18945fcd1f3ac80ca2fa0c01f1dbac2f7b21d8b9b86bfc33cde7ff568
+SIZE (codelite-r1528.tar.bz2) = 5238658
diff --git a/editors/codelite/files/patch-configure b/editors/codelite/files/patch-configure
new file mode 100644
index 000000000000..d0349b3aa7cc
--- /dev/null
+++ b/editors/codelite/files/patch-configure
@@ -0,0 +1,34 @@
+--- configure.orig 2008-05-14 19:24:35.000000000 +0200
++++ configure 2008-05-15 21:48:27.000000000 +0200
+@@ -83,11 +83,9 @@
+ echo "INCLUDES := \$(INCLUDES) -ILiteEditor " >> Makefile
+ fi
+ echo "" >> Makefile
+- if [ "$os_name" = "Linux" ]; then
+- echo "INCLUDES := \$(INCLUDES) \$(shell pkg-config --cflags gtk+-2.0)" >> Makefile
+- echo "LINK_FLAGS := \$(LINK_FLAGS) \$(shell pkg-config --libs gtk+-2.0)" >> Makefile
+- fi
+- echo "INCLUDES := \$(INCLUDES) -I. -I${base_dir}/sdk/wxsqlite3/include -I${base_dir}/sdk/wxsqlite3/sqlite3/include -I${base_dir}/sdk/wxscintilla/include -I${base_dir}/sdk/wxscintilla/src/scintilla/include -I${base_dir}/sdk/wxscintilla/src/scintilla/src -I${base_dir}/Interfaces -I${base_dir}/Debugger -I${base_dir}/Plugin -I${base_dir}/CodeLite -I${base_dir}/sdk/wxflatnotebook/include" >> Makefile
++ echo "INCLUDES := \$(INCLUDES) \$(shell pkg-config --cflags gtk+-2.0)" >> Makefile
++ echo "LINK_FLAGS := \$(LINK_FLAGS) \$(shell pkg-config --libs gtk+-2.0)" >> Makefile
++ echo "INCLUDES := -I. -I${base_dir}/sdk/wxsqlite3/include -I${base_dir}/sdk/wxsqlite3/sqlite3/include -I${base_dir}/sdk/wxscintilla/include -I${base_dir}/sdk/wxscintilla/src/scintilla/include -I${base_dir}/sdk/wxscintilla/src/scintilla/src -I${base_dir}/Interfaces -I${base_dir}/Debugger -I${base_dir}/Plugin -I${base_dir}/CodeLite -I${base_dir}/sdk/wxflatnotebook/include \$(INCLUDES)" >> Makefile
+ echo "" >> Makefile
+ echo "" >> Makefile
+ }
+@@ -381,12 +383,10 @@
+
+ createEndMessage()
+ {
+- if [ "$os_name" = "Linux" ]; then
+- echo "post_build_msg:" >> Makefile
+- echo " @echo ==========================================================" >> Makefile
+- echo " @echo Done, please run \"sudo make install\"." >> Makefile
+- echo " @echo ==========================================================" >> Makefile
+- fi
++ echo "post_build_msg:" >> Makefile
++ echo " @echo ==========================================================" >> Makefile
++ echo " @echo Done, please run \"sudo make install\"." >> Makefile
++ echo " @echo ==========================================================" >> Makefile
+ }
+
+ ## main
diff --git a/editors/codelite/pkg-descr b/editors/codelite/pkg-descr
new file mode 100644
index 000000000000..f8ad4269a432
--- /dev/null
+++ b/editors/codelite/pkg-descr
@@ -0,0 +1,6 @@
+CodeLite is a powerful open-source, cross platform code editor for the
+C/C++ programming languages.
+CodeLite uses a sophisticated, yet intuitive interface which allows
+user to easy create and build complex projects.
+
+WWW: http://codelite.org/
diff --git a/editors/codelite/pkg-plist b/editors/codelite/pkg-plist
new file mode 100644
index 000000000000..1887866cd382
--- /dev/null
+++ b/editors/codelite/pkg-plist
@@ -0,0 +1,92 @@
+bin/CodeLite
+bin/le_dos2unix.sh
+bin/le_exec.sh
+bin/le_killproc.sh
+bin/ctags-le
+%%DATADIR%%/config/debuggers.xml
+%%DATADIR%%/config/debuggers.xml.gtk
+%%DATADIR%%/config/build_settings.xml
+%%DATADIR%%/config/codelite.xml.default
+%%DATADIR%%/config/codelite.layout.default
+%%DATADIR%%/config/liteeditor.xml.mac
+%%DATADIR%%/config/accelerators.conf.default
+%%DATADIR%%/debuggers/Debugger.so
+%%DATADIR%%/templates/projects/vc-executable/vc-executable.project
+%%DATADIR%%/templates/projects/executable/main.cpp
+%%DATADIR%%/templates/projects/executable/executable.project
+%%DATADIR%%/templates/projects/vc-static-lib/vc-static-lib.project
+%%DATADIR%%/templates/projects/dynamic-library/dynamic-library.project
+%%DATADIR%%/templates/projects/static-library/static-library.project
+%%DATADIR%%/templates/projects/dynamic-library-wx-enabled/dynamic-library-wx-enabled.project
+%%DATADIR%%/templates/projects/vc-dynamic-library/vc-dynamic-library.project
+%%DATADIR%%/templates/projects/static-library-wx-enabled/static-library-wx-enabled.project
+%%DATADIR%%/templates/gizmos/wxmain.project.wizard
+%%DATADIR%%/templates/gizmos/mainframe.cpp.wizard
+%%DATADIR%%/templates/gizmos/app.cpp.wizard
+%%DATADIR%%/templates/gizmos/plugin.h.wizard
+%%DATADIR%%/templates/gizmos/main.cpp.wizard
+%%DATADIR%%/templates/gizmos/app.h.wizard
+%%DATADIR%%/templates/gizmos/liteeditor-plugin.project.wizard
+%%DATADIR%%/templates/gizmos/mainframe.h.wizard
+%%DATADIR%%/templates/gizmos/wxproject.project.wizard
+%%DATADIR%%/templates/gizmos/plugin.cpp.wizard
+%%DATADIR%%/plugins/CodeFormatter.so
+%%DATADIR%%/plugins/Subversion.so
+%%DATADIR%%/plugins/ReferenceAnalyser.so
+%%DATADIR%%/plugins/cscope.so
+%%DATADIR%%/plugins/Gizmos.so
+%%DATADIR%%/rc/menu.xrc
+%%DATADIR%%/lexers/Default/lexer_cpp.xml
+%%DATADIR%%/lexers/Default/lexer_script.xml
+%%DATADIR%%/lexers/Default/lexer_properties.xml
+%%DATADIR%%/lexers/Default/lexer_perl.xml
+%%DATADIR%%/lexers/Default/lexer_makefile.xml
+%%DATADIR%%/lexers/Default/lexer_lua.xml
+%%DATADIR%%/lexers/Default/lexer_java.xml
+%%DATADIR%%/lexers/Default/lexer_inno.xml
+%%DATADIR%%/lexers/Default/lexer_html.xml
+%%DATADIR%%/lexers/Default/lexer_diff.xml
+%%DATADIR%%/lexers/Default/lexer_default.xml
+%%DATADIR%%/lexers/Default/lexer_xml.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_cpp.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_script.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_properties.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_perl.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_makefile.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_lua.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_java.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_inno.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_html.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_diff.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_default.xml
+%%DATADIR%%/lexers/BlackTheme/lexer_xml.xml
+%%DATADIR%%/images/cubes.png
+%%DATADIR%%/images/help_earth.png
+%%DATADIR%%/images/plugin_not_ok.png
+%%DATADIR%%/images/plugin_ok.png
+%%DATADIR%%/images/splashscreen.png
+%%DATADIR%%/index.html
+%%DATADIR%%/astyle.sample
+%%DATADIR%%/svnreport.html
+share/applications/codelite.desktop
+@dirrm %%DATADIR%%/templates/projects/vc-static-lib
+@dirrm %%DATADIR%%/templates/projects/vc-executable
+@dirrm %%DATADIR%%/templates/projects/vc-dynamic-library
+@dirrm %%DATADIR%%/templates/projects/static-library-wx-enabled
+@dirrm %%DATADIR%%/templates/projects/static-library
+@dirrm %%DATADIR%%/templates/projects/executable
+@dirrm %%DATADIR%%/templates/projects/dynamic-library-wx-enabled
+@dirrm %%DATADIR%%/templates/projects/dynamic-library
+@dirrm %%DATADIR%%/templates/projects
+@dirrm %%DATADIR%%/templates/gizmos
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/rc
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/lexers/Default
+@dirrm %%DATADIR%%/lexers/BlackTheme
+@dirrm %%DATADIR%%/lexers
+@dirrm %%DATADIR%%/debuggers
+@dirrm %%DATADIR%%/config
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%
+@dirrmtry share/applications