aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-Domain/Makefile24
-rw-r--r--devel/p5-Data-Domain/distinfo2
-rw-r--r--devel/p5-Data-Domain/pkg-descr16
-rw-r--r--devel/p5-Data-Domain/pkg-plist2
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6cd2e7d3a300..011f3f62eef9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1424,6 +1424,7 @@
SUBDIR += p5-Data-Bind
SUBDIR += p5-Data-ClearSilver-HDF
SUBDIR += p5-Data-Compare
+ SUBDIR += p5-Data-Domain
SUBDIR += p5-Data-Dump
SUBDIR += p5-Data-Dump-Streamer
SUBDIR += p5-Data-DumpXML
diff --git a/devel/p5-Data-Domain/Makefile b/devel/p5-Data-Domain/Makefile
new file mode 100644
index 000000000000..672a38224e03
--- /dev/null
+++ b/devel/p5-Data-Domain/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Data-Domain
+# Date created: 2011-09-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Domain
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Data description and validation
+
+BUILD_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
+RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
+
+PERL_MODBUILD= yes
+
+MAN3= Data::Domain.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-Domain/distinfo b/devel/p5-Data-Domain/distinfo
new file mode 100644
index 000000000000..2b7b3531c130
--- /dev/null
+++ b/devel/p5-Data-Domain/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Data-Domain-0.14.tar.gz) = b62dd834deebe8bd8bf8eabb0def0c4663cfe5f99596948681eb1c847102eb38
+SIZE (Data-Domain-0.14.tar.gz) = 19662
diff --git a/devel/p5-Data-Domain/pkg-descr b/devel/p5-Data-Domain/pkg-descr
new file mode 100644
index 000000000000..02ca57ef89fb
--- /dev/null
+++ b/devel/p5-Data-Domain/pkg-descr
@@ -0,0 +1,16 @@
+A data domain is a description of a set of values, either scalar or structured
+(arrays or hashes). The description can include many constraints, like minimal
+or maximal values, regular expressions, required fields, forbidden fields, and
+also contextual dependencies. From that description, one can then invoke the
+domain's inspect method to check if a given value belongs to it or not. In case
+of mismatch, a structured set of error messages is returned.
+
+The motivation for writing this package was to be able to express in a compact
+way some possibly complex constraints about structured data. Typically the data
+is a Perl tree (nested hashrefs or arrayrefs) that may come from XML, JSON, from
+a database through DBIx::DataModel, or from postprocessing an HTML form through
+CGI::Expand. Data::Domain is a kind of tree parser on that structure, with some
+facilities for dealing with dependencies within the structure, and with several
+options to finely tune the error messages returned to the user.
+
+WWW: http://search.cpan.org/dist/Data-Domain/
diff --git a/devel/p5-Data-Domain/pkg-plist b/devel/p5-Data-Domain/pkg-plist
new file mode 100644
index 000000000000..c02bddefd60d
--- /dev/null
+++ b/devel/p5-Data-Domain/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Data/Domain.pm
+@dirrmtry %%SITE_PERL%%/Data