aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/py-idnkit2/Makefile28
-rw-r--r--dns/py-idnkit2/distinfo2
-rw-r--r--dns/py-idnkit2/files/patch-setup.py15
-rw-r--r--dns/py-idnkit2/pkg-descr13
5 files changed, 59 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 4462dcdd7721..1bef9d9d5f06 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -127,6 +127,7 @@
SUBDIR += py-adns
SUBDIR += py-dns
SUBDIR += py-dnspython
+ SUBDIR += py-idnkit2
SUBDIR += py-namebench
SUBDIR += py-twistedNames
SUBDIR += radns
diff --git a/dns/py-idnkit2/Makefile b/dns/py-idnkit2/Makefile
new file mode 100644
index 000000000000..4a6d901a9371
--- /dev/null
+++ b/dns/py-idnkit2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: idnkit
+# Date created: 13 November 2011
+# Whom: Rafal Lesniak <fbsd@grid.einherjar.de>
+#
+# $FreeBSD$
+
+PORTNAME= idnkit-python
+PORTVERSION= 2.1
+CATEGORIES= dns
+MASTER_SITES= http://jprs.co.jp/idn/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= fbsd@grid.einherjar.de
+COMMENT= Python bindings for Internationalized Domain Name toolkit 2.
+
+LIB_DEPENDS= idnkitlite.2:${PORTSDIR}/dns/idnkit2
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/idnkit.so
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/dns/py-idnkit2/distinfo b/dns/py-idnkit2/distinfo
new file mode 100644
index 000000000000..84f31fc47b9b
--- /dev/null
+++ b/dns/py-idnkit2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (idnkit-python-2.1.tar.bz2) = c53bbf220baaeb7e7a94a249a04b65f9a850858651f91b2515c8cfb2b72a5aed
+SIZE (idnkit-python-2.1.tar.bz2) = 31129
diff --git a/dns/py-idnkit2/files/patch-setup.py b/dns/py-idnkit2/files/patch-setup.py
new file mode 100644
index 000000000000..0e3885c12283
--- /dev/null
+++ b/dns/py-idnkit2/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- setup.py.orgi 2011-11-24 22:05:06.191148712 +0000
++++ setup.py 2011-11-24 22:05:37.913149693 +0000
+@@ -4,10 +4,10 @@
+ import glob
+
+ # Directory where idnkit header files are installed.
+-idnkit_include_dir = '/usr/local/include'
++idnkit_include_dir = '%%LOCALBASE%%/include'
+
+ # Directory where libidnkitlite resides.
+-idnkit_library_dir = '/usr/local/lib'
++idnkit_library_dir = '%%LOCALBASE%%/lib'
+
+ setup(name='idnkit-python',
+ version='2.1',
diff --git a/dns/py-idnkit2/pkg-descr b/dns/py-idnkit2/pkg-descr
new file mode 100644
index 000000000000..8e56b01f9f89
--- /dev/null
+++ b/dns/py-idnkit2/pkg-descr
@@ -0,0 +1,13 @@
+
+Internationalized Domain Name toolkit 2 (idnkit-2) provides useful
+APIs (libraries) for application developers to make softwares
+IDNA2008-compliant, and also provides tools for system administrators
+to process IDNs appropriately according to IDNA2008 specification.
+The idnkit-2 is a toolkit revised by JPRS from the idnkit-1.0
+developed by JPNIC, and it is released as an open source
+free software modified to comply with IDNA2008.
+
+idnkit-2 consists from its main part written in C and additional
+API packages for other languages (Java, Python, and Perl).
+
+WWW: http://jprs.co.jp/idn/index-e.html