aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING7
-rw-r--r--games/Makefile2
-rw-r--r--games/warzone/distinfo3
-rw-r--r--games/warzone/files/patch-src__game.c11
-rw-r--r--games/warzone2100/Makefile (renamed from games/warzone/Makefile)18
-rw-r--r--games/warzone2100/distinfo3
-rw-r--r--games/warzone2100/files/patch-src__loop.c13
-rw-r--r--games/warzone2100/files/patch-src__seqdisp.c22
-rw-r--r--games/warzone2100/pkg-descr (renamed from games/warzone/pkg-descr)0
-rw-r--r--games/warzone2100/pkg-message22
-rw-r--r--games/warzone2100/pkg-plist (renamed from games/warzone/pkg-plist)2
11 files changed, 80 insertions, 23 deletions
diff --git a/UPDATING b/UPDATING
index eb98dc8448c1..c362ec08e4b6 100644
--- a/UPDATING
+++ b/UPDATING
@@ -8,6 +8,13 @@ upgrades.
+20060831:
+ AFFECTS: users of games/warzone
+ AUTHOR: alepulver@FreeBSD.org
+
+ games/warzone port directory was renamed back to games/warzone2100 because
+ the last version (2.0.4) uses the original name.
+
20060830:
AFFECTS: users of textproc/p5-Senna
AUTHOR: kuriyama@FreeBSD.org
diff --git a/games/Makefile b/games/Makefile
index 8233a3dc21bd..55197794d515 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -726,7 +726,7 @@
SUBDIR += wargus
SUBDIR += warsow
SUBDIR += warsow-data
- SUBDIR += warzone
+ SUBDIR += warzone2100
SUBDIR += wesnoth
SUBDIR += wmeyes
SUBDIR += wmfortune
diff --git a/games/warzone/distinfo b/games/warzone/distinfo
deleted file mode 100644
index 8768b95f71b2..000000000000
--- a/games/warzone/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (warzone-2.0.3.tar.bz2) = 2396e0def69e5e48902448d04944927a
-SHA256 (warzone-2.0.3.tar.bz2) = 7668f6b794faad8d7ae66dbd0c7317df2521b33593f29174ab3fecb647326749
-SIZE (warzone-2.0.3.tar.bz2) = 19902273
diff --git a/games/warzone/files/patch-src__game.c b/games/warzone/files/patch-src__game.c
deleted file mode 100644
index 36a9d5503fa5..000000000000
--- a/games/warzone/files/patch-src__game.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/game.c.bak Thu Aug 17 18:52:11 2006
-+++ src/game.c Thu Aug 17 18:52:44 2006
-@@ -2832,7 +2832,7 @@
- aFileName[strlen(aFileName) - 4] = '\0';
-
- //create dir will fail if directory already exists but don't care!
-- (void) PHYSFS_mkdir(aFileName);
-+ (void) PHYSFS_mkdir(unix_path(aFileName));
-
- //save the map file
- strcat(aFileName, "/");
diff --git a/games/warzone/Makefile b/games/warzone2100/Makefile
index efad4a62f2c8..cf318404488e 100644
--- a/games/warzone/Makefile
+++ b/games/warzone2100/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
#
-PORTNAME= warzone
-PORTVERSION= 2.0.3
+PORTNAME= warzone2100
+PORTVERSION= 2.0.4
CATEGORIES= games
MASTER_SITES= http://download.gna.org/warzone/releases/2.0/
@@ -29,15 +29,19 @@ USE_SDL= net sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
- LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
LIBS="${PTHREAD_LIBS}"
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
+ `${SDL_CONFIG} --cflags`
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
post-patch:
@${REINPLACE_CMD} -e '/stdint.h/d' ${WRKSRC}/lib/ivis_opengl/screen.c
- @${REINPLACE_CMD} -e 's|-m32||' \
- -e 's|/usr/local|${LOCALBASE}|; s|/usr/X11R6|${X11BASE}|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-m32||; \
+ s|/usr/local|${LOCALBASE}|; \
+ s|/usr/X11R6|${X11BASE}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.for f in configure *.c *.h
@${FIND} ${WRKSRC} -type f -name "${f}" -print0 | \
${XARGS} -0 ${REINPLACE_CMD} -e 's|SDL/||'
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
new file mode 100644
index 000000000000..995003794ad3
--- /dev/null
+++ b/games/warzone2100/distinfo
@@ -0,0 +1,3 @@
+MD5 (warzone2100-2.0.4.tar.bz2) = 84e92061d9a00405994ab7496d03a610
+SHA256 (warzone2100-2.0.4.tar.bz2) = 06ce1d72ec1c3ffceed8f5aae77b96442469abe3096caebc5ce43b1178aee9b5
+SIZE (warzone2100-2.0.4.tar.bz2) = 19883711
diff --git a/games/warzone2100/files/patch-src__loop.c b/games/warzone2100/files/patch-src__loop.c
new file mode 100644
index 000000000000..7deef6c8f62f
--- /dev/null
+++ b/games/warzone2100/files/patch-src__loop.c
@@ -0,0 +1,13 @@
+--- src/loop.c 2006/08/26 15:50:47 289
++++ src/loop.c 2006/08/29 19:57:34 304
+@@ -1085,7 +1085,7 @@
+ paused = FALSE;
+ video = FALSE;
+ gameTimeStart();
+-// pie_SetFogStatus(TRUE);
++ pie_SetFogStatus(TRUE);
+ cdAudio_Resume();
+ ASSERT( videoMode == 0,"loop_ClearVideoPlaybackMode: out of sync." );
+ }
+
+
diff --git a/games/warzone2100/files/patch-src__seqdisp.c b/games/warzone2100/files/patch-src__seqdisp.c
new file mode 100644
index 000000000000..8687b9d2ebbf
--- /dev/null
+++ b/games/warzone2100/files/patch-src__seqdisp.c
@@ -0,0 +1,22 @@
+--- src/seqdisp.c 2006/08/27 19:09:35 298
++++ src/seqdisp.c 2006/08/29 19:57:34 304
+@@ -384,13 +384,14 @@
+ //full screenvideo functions
+ BOOL seq_StartFullScreenVideo(char* videoName, char* audioName)
+ {
+- bHoldSeqForAudio = FALSE;
+-
+ #ifdef DUMMY_VIDEO
+ debug( LOG_VIDEO, "seq_StartFullScreenVideo: Refusing to play video! (Not a bug)" );
+- return FALSE;
++ // FIXME We probably should call something like eventFireCallbackTrigger((TRIGGER_TYPE)CALL_VIDEO_QUIT); here!
++ return TRUE;
+ #endif
+
++ bHoldSeqForAudio = FALSE;
++
+ frameSkip = 1;
+ switch(war_GetSeqMode())
+ {
+
+
diff --git a/games/warzone/pkg-descr b/games/warzone2100/pkg-descr
index c22cf0226aa2..c22cf0226aa2 100644
--- a/games/warzone/pkg-descr
+++ b/games/warzone2100/pkg-descr
diff --git a/games/warzone2100/pkg-message b/games/warzone2100/pkg-message
new file mode 100644
index 000000000000..155d7920e78c
--- /dev/null
+++ b/games/warzone2100/pkg-message
@@ -0,0 +1,22 @@
+==============================================================================
+
+Warzone2100 has been installed.
+
+If the game locks up in heavy fight (e.g. many units firing at each other) try
+to set OPENAL_BUFFER_SIZE to 8192 before running it.
+
+$ env OPENAL_BUFFER_SIZE=8192 warzone
+
+Or set the environment variable in your shell's configuration file (you can
+also run these commands directly from the command-line).
+
+For sh/bash add in your /etc/profile or ~/.profile:
+OPENAL_BUFFER_SIZE=8192
+export OPENAL_BUFFER_SIZE
+
+For csh/tcsh add in your /etc/csh.cshrc or ~/.cshrc:
+setenv OPENAL_BUFFER_SIZE=8192
+
+Enjoy!
+
+==============================================================================
diff --git a/games/warzone/pkg-plist b/games/warzone2100/pkg-plist
index 6006146bbb7b..e26ee908b1c7 100644
--- a/games/warzone/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -1,4 +1,4 @@
-bin/warzone
+bin/warzone2100
%%DATADIR%%/mp.wz
%%DATADIR%%/warzone.wz
%%PORTDOCS%%%%DOCSDIR%%/README