aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Amazon-Signature/Makefile21
-rw-r--r--net/p5-Net-Amazon-Signature/distinfo3
-rw-r--r--net/p5-Net-Amazon-Signature/pkg-descr6
-rw-r--r--net/p5-Net-Amazon-Signature/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 593cb9069721..d209295af837 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -465,6 +465,7 @@
SUBDIR += p5-Net-Amazon-EC2
SUBDIR += p5-Net-Amazon-MechanicalTurk
SUBDIR += p5-Net-Amazon-S3
+ SUBDIR += p5-Net-Amazon-Signature
SUBDIR += p5-Net-Analysis
SUBDIR += p5-Net-BGP
SUBDIR += p5-Net-Blogger
diff --git a/net/p5-Net-Amazon-Signature/Makefile b/net/p5-Net-Amazon-Signature/Makefile
new file mode 100644
index 000000000000..4a8bc6d0c0db
--- /dev/null
+++ b/net/p5-Net-Amazon-Signature/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-Amazon-Signature
+# Date created: 2008-03-20
+# Whom: Greg Larkin <glarkin@sourcehosting.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Amazon-Signature
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= Perl interface to create Amazon AWS signatures
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Amazon::Signature.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-Signature/distinfo b/net/p5-Net-Amazon-Signature/distinfo
new file mode 100644
index 000000000000..99cdf630917d
--- /dev/null
+++ b/net/p5-Net-Amazon-Signature/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Amazon-Signature-0.03.tar.gz) = d8265d25ee0fddfd1cc674750d99d43b
+SHA256 (Net-Amazon-Signature-0.03.tar.gz) = e729d34d706aa5f4db24f1537d094e0487769e7eac6ae24302b8ad5f25083b70
+SIZE (Net-Amazon-Signature-0.03.tar.gz) = 3409
diff --git a/net/p5-Net-Amazon-Signature/pkg-descr b/net/p5-Net-Amazon-Signature/pkg-descr
new file mode 100644
index 000000000000..a9fdc04c2c9f
--- /dev/null
+++ b/net/p5-Net-Amazon-Signature/pkg-descr
@@ -0,0 +1,6 @@
+This module creates the encrypted signature needed to login to
+Amazon's Mechanical Turk and Alexa web services and any other web
+services that Amazon might make in the future that require an
+encrypted signature, assuming they follow the same convention.
+
+WWW: http://search.cpan.org/dist/Net-Amazon-Signature/
diff --git a/net/p5-Net-Amazon-Signature/pkg-plist b/net/p5-Net-Amazon-Signature/pkg-plist
new file mode 100644
index 000000000000..e778a145ee1c
--- /dev/null
+++ b/net/p5-Net-Amazon-Signature/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/Amazon/Signature.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/Signature/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon/Signature
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Amazon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Amazon
+@dirrmtry %%SITE_PERL%%/Net