aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/supercat/Makefile24
-rw-r--r--textproc/supercat/distinfo3
-rw-r--r--textproc/supercat/pkg-descr8
-rw-r--r--textproc/supercat/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 9887e1e085c3..05d43322f26f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -935,6 +935,7 @@
SUBDIR += stardict2-dictd_mova
SUBDIR += stardict2-quick
SUBDIR += stardict2-rptts
+ SUBDIR += supercat
SUBDIR += sv-aspell
SUBDIR += svn2cl
SUBDIR += sw-aspell
diff --git a/textproc/supercat/Makefile b/textproc/supercat/Makefile
new file mode 100644
index 000000000000..3f0e8bf7dda3
--- /dev/null
+++ b/textproc/supercat/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: supercat
+# Date created: 3 September 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supercat
+PORTVERSION= 0.5.1
+CATEGORIES= textproc
+MASTER_SITES= http://supercat.nosredna.net/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Regexp-based text colorizer with ASCII/HTML output
+
+GNU_CONFIGURE= yes
+MAN1= spc.1
+PORT_VERBS= ${PORTNAME} spc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/supercat|${ETCDIR}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|c:C:dDhmnrt:vS|&Rw|' ${WRKSRC}/src/spc.c
+
+.include <bsd.port.mk>
diff --git a/textproc/supercat/distinfo b/textproc/supercat/distinfo
new file mode 100644
index 000000000000..9a100375ac35
--- /dev/null
+++ b/textproc/supercat/distinfo
@@ -0,0 +1,3 @@
+MD5 (supercat-0.5.1.tar.gz) = bad28ef36938adb3c202443d15f9b02a
+SHA256 (supercat-0.5.1.tar.gz) = 2fcb8ea8f25000c2a561b6d7244480d0fbfb1730ce0c805ba9a6e19ca33ccbe7
+SIZE (supercat-0.5.1.tar.gz) = 101602
diff --git a/textproc/supercat/pkg-descr b/textproc/supercat/pkg-descr
new file mode 100644
index 000000000000..38e6d6a53a51
--- /dev/null
+++ b/textproc/supercat/pkg-descr
@@ -0,0 +1,8 @@
+Supercat (spc) is a program that colorizes text based on matching
+regular expressions/strings/characters. Supercat supports html output
+as well as standard ASCII text. Unlike some text-colorizing programs
+that exist, Supercat does not require you to have to be a programmer to
+make colorization rules.
+
+WWW: http://supercat.nosredna.net/
+Author: Thomas G. Anderson <bug-spc@nosredna.net>
diff --git a/textproc/supercat/pkg-plist b/textproc/supercat/pkg-plist
new file mode 100644
index 000000000000..b00a7e45d98c
--- /dev/null
+++ b/textproc/supercat/pkg-plist
@@ -0,0 +1,5 @@
+bin/spc
+%%ETCDIR%%/spcrc-c
+%%ETCDIR%%/spcrc-emerge
+%%ETCDIR%%/spcrc-py
+@dirrmtry %%ETCDIR%%