aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/timidity++/Makefile2
-rw-r--r--audio/timidity/Makefile2
-rw-r--r--editors/wordperfect/Makefile4
-rw-r--r--games/linuxdoom/Makefile2
-rw-r--r--japanese/gawk/Makefile2
-rw-r--r--japanese/gxditview/Makefile2
-rw-r--r--lang/lcc/Makefile6
-rw-r--r--lang/mixal/Makefile2
-rw-r--r--lang/modula-3/Makefile6
-rw-r--r--mail/cyrus-imapd/Makefile2
-rw-r--r--mail/cyrus-imapd2/Makefile2
-rw-r--r--mail/cyrus-imapd22/Makefile2
-rw-r--r--mail/cyrus-imapd23/Makefile2
-rw-r--r--mail/cyrus-imapd24/Makefile2
-rw-r--r--mail/cyrus/Makefile2
-rw-r--r--mail/poppassd/Makefile2
-rw-r--r--mail/smtpd/Makefile4
-rw-r--r--math/snns/Makefile2
-rw-r--r--math/xmgr/Makefile4
-rw-r--r--net/freewais-sf/Makefile4
-rw-r--r--net/rtsp_proxy/Makefile4
-rw-r--r--news/nntpcache/Makefile4
-rw-r--r--print/makeindex/Makefile4
-rw-r--r--print/pbm2ppa/Makefile6
-rw-r--r--print/pnm2ppa/Makefile6
-rw-r--r--print/tex/Makefile4
-rw-r--r--russian/pgp.language/Makefile4
-rw-r--r--security/skip/Makefile4
-rw-r--r--sysutils/lsof/Makefile4
-rw-r--r--sysutils/upsd/Makefile4
-rw-r--r--www/webglimpse/Makefile4
-rw-r--r--x11-fm/x-files/Makefile4
-rw-r--r--x11-wm/afterstep-i18n/Makefile4
-rw-r--r--x11/xloadimage/Makefile4
34 files changed, 58 insertions, 58 deletions
diff --git a/audio/timidity++/Makefile b/audio/timidity++/Makefile
index 95a46f8469f8..0fbe1937e479 100644
--- a/audio/timidity++/Makefile
+++ b/audio/timidity++/Makefile
@@ -26,7 +26,7 @@ post-install:
cd ${PREFIX}/lib/timidity && \
tar zxf ${DISTDIR}/${TIINS} && \
${CP} goemon.cfg goemon.cfg.bak && \
- sed 's=dir goemon=dir ${PREFIX}/lib/timidity/goemon=' \
+ ${SED} 's=dir goemon=dir ${PREFIX}/lib/timidity/goemon=' \
< goemon.cfg.bak > goemon.cfg && \
rm goemon.cfg.bak
diff --git a/audio/timidity/Makefile b/audio/timidity/Makefile
index 95a46f8469f8..0fbe1937e479 100644
--- a/audio/timidity/Makefile
+++ b/audio/timidity/Makefile
@@ -26,7 +26,7 @@ post-install:
cd ${PREFIX}/lib/timidity && \
tar zxf ${DISTDIR}/${TIINS} && \
${CP} goemon.cfg goemon.cfg.bak && \
- sed 's=dir goemon=dir ${PREFIX}/lib/timidity/goemon=' \
+ ${SED} 's=dir goemon=dir ${PREFIX}/lib/timidity/goemon=' \
< goemon.cfg.bak > goemon.cfg && \
rm goemon.cfg.bak
diff --git a/editors/wordperfect/Makefile b/editors/wordperfect/Makefile
index f31fefa14c87..3c12a2db2331 100644
--- a/editors/wordperfect/Makefile
+++ b/editors/wordperfect/Makefile
@@ -40,7 +40,7 @@ post-patch:
< ${WRKDIR}/shared/wpdata.old \
> ${WRKDIR}/shared/wpdata
@${CP} ${WRKDIR}/shared/install.wp ${WRKDIR}/shared/install.wp.old
- @sed 's#REPLACE_ME_WITH_DESTINATION#${PREFIX}/lib/corel#' \
+ @${SED} 's#REPLACE_ME_WITH_DESTINATION#${PREFIX}/lib/corel#' \
< ${WRKDIR}/shared/install.wp.old \
> ${WRKDIR}/shared/install.wp
@@ -60,7 +60,7 @@ pre-install:
do-install:
@${MKDIR} ${WRKDIR}/tmp
@(cd ${WRKDIR} ; ${SCRIPTS_ENV} TMPDIR=${WRKDIR}/tmp ${SH} Runme)
- @sed 's#REPLACE_ME_WITH_DESTINATION#${PREFIX}/lib/corel#' \
+ @${SED} 's#REPLACE_ME_WITH_DESTINATION#${PREFIX}/lib/corel#' \
< ${FILESDIR}/xwp \
> ${WRKDIR}/xwp
@if test -f ${PREFIX}/bin/xwp ; then \
diff --git a/games/linuxdoom/Makefile b/games/linuxdoom/Makefile
index 5dba41f4331d..3aae0f4c2778 100644
--- a/games/linuxdoom/Makefile
+++ b/games/linuxdoom/Makefile
@@ -27,7 +27,7 @@ post-patch:
@(cd ${WRKSRC}/musserver; make clean)
pre-install:
- @sed 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGINSTALL}
+ @${SED} 's,@PREFIX@,${PREFIX},' ${PKGDIR}/INSTALL.in > ${PKGINSTALL}
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/japanese/gawk/Makefile b/japanese/gawk/Makefile
index aa1aa01b2279..59af0bfbce23 100644
--- a/japanese/gawk/Makefile
+++ b/japanese/gawk/Makefile
@@ -39,7 +39,7 @@ pre-fetch:
done; \
done; \
for file in ${DISTPATCHES} ; do zcat $${file}; done | \
- sed -e '1,/-----8</d' -e '/-----8</,/-----8</d' | uudecode; \
+ ${SED} -e '1,/-----8</d' -e '/-----8</,/-----8</d' | uudecode; \
rm -f ${DISTPATCHES};\
fi)
.endif
diff --git a/japanese/gxditview/Makefile b/japanese/gxditview/Makefile
index 96322c28cd3f..f7e81dd70bea 100644
--- a/japanese/gxditview/Makefile
+++ b/japanese/gxditview/Makefile
@@ -34,7 +34,7 @@ pre-fetch:
done; \
done; \
for file in ${DISTPATCHES} ; do zcat $${file}; done | \
- sed '/^END -----/,/^BEGIN ----/d' | uudecode; \
+ ${SED} '/^END -----/,/^BEGIN ----/d' | uudecode; \
rm -f ${DISTPATCHES};\
fi)
diff --git a/lang/lcc/Makefile b/lang/lcc/Makefile
index 6af3e11ac64a..b1d602781579 100644
--- a/lang/lcc/Makefile
+++ b/lang/lcc/Makefile
@@ -25,14 +25,14 @@ LCCDESTDIR= lib/${DISTNAME}/${UNAME_M}-${OPSYS}
pre-configure:
@${MKDIR} ${LCCBUILDDIR}
@${CP} ${FILESDIR}/${OPSYS}.md ${WRKSRC}/src
- @sed -e "s:%%PREFIX%%:${PREFIX}:g" \
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
-e "s:%%LCCDESTDIR%%:${LCCDESTDIR}:g" \
-e "s:%%VERSION%%:${DISTNAME}:g" \
${FILESDIR}/${OPSYS}.c.in > ${WRKSRC}/etc/${OPSYS}.c
@# below can be used to patchup PLIST file for diff os/arch
- @#sed -e "s:%%LCCDESTDIR%%:${LCCDESTDIR}:g" \
+ @#${SED} -e "s:%%LCCDESTDIR%%:${LCCDESTDIR}:g" \
#${PKGDIR}/PLIST.in > ${PKGDIR}/PLIST
- @sed -e "s:%%OPSYS%%:${OPSYS}:g" \
+ @${SED} -e "s:%%OPSYS%%:${OPSYS}:g" \
${WRKSRC}/makefile > ${WRKSRC}/makefile.configured
@/bin/mv -f ${WRKSRC}/makefile.configured ${WRKSRC}/makefile
diff --git a/lang/mixal/Makefile b/lang/mixal/Makefile
index fe6d6c28687e..4757aa7352e0 100644
--- a/lang/mixal/Makefile
+++ b/lang/mixal/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= obrien@FreeBSD.org
EXTRACT_CMD= zcat
EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= |/usr/bin/sed -e '1,/^This ought/d' |sh
+EXTRACT_AFTER_ARGS= | ${SED} -e '1,/^This ought/d' |sh
NO_WRKSUBDIR= yes
ALL_TARGET=
diff --git a/lang/modula-3/Makefile b/lang/modula-3/Makefile
index 0780e8ceb091..6eff50eb8456 100644
--- a/lang/modula-3/Makefile
+++ b/lang/modula-3/Makefile
@@ -52,7 +52,7 @@ do-install:
@${ECHO_MSG} "Installing files in \"${PREFIX}\""
@cd ${temp_prefix}; \
umask 022; \
- sed -e "/^@/d" -e "/m3build-/d" -e "s/\.gz$$//" \
+ ${SED} -e "/^@/d" -e "/m3build-/d" -e "s/\.gz$$//" \
-e "/^share/d" ${PLIST}.real | \
cpio -dump -R ${BINOWN}.${BINGRP} ${PREFIX}
@cd ${temp_prefix}/man/man1; \
@@ -100,9 +100,9 @@ do-install:
${LN} -f m3build m3build-${major}
@${ECHO_MSG} "Fixing file permissions"
@cd ${PREFIX}; \
- sed -e "/^@/d" -e "s/\.gz$$//" ${PLIST}.real |\
+ ${SED} -e "/^@/d" -e "s/\.gz$$//" ${PLIST}.real |\
xargs ${CHOWN} ${BINOWN}.${BINGRP}; \
- sed -e "/^@/d" -e "s/\.gz$$//" ${PLIST}.real |\
+ ${SED} -e "/^@/d" -e "s/\.gz$$//" ${PLIST}.real |\
xargs ${CHMOD} go=u-w; \
find -X lib/m3 -type d | xargs ${CHOWN} ${BINOWN}.${BINGRP}; \
find -X lib/m3 -type d | xargs ${CHMOD} 755
diff --git a/mail/cyrus-imapd/Makefile b/mail/cyrus-imapd/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus-imapd/Makefile
+++ b/mail/cyrus-imapd/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/cyrus-imapd2/Makefile b/mail/cyrus-imapd2/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus-imapd2/Makefile
+++ b/mail/cyrus-imapd2/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/cyrus/Makefile b/mail/cyrus/Makefile
index d2beb9c4c636..444dbc8e338d 100644
--- a/mail/cyrus/Makefile
+++ b/mail/cyrus/Makefile
@@ -76,7 +76,7 @@ post-install:
${INSTALL} -d -m 700 -o cyrus -g cyrus /var/pwcheck
${TOUCH} ${PREFIX}/etc/imap/mailboxes
${CHMOD} 640 ${PREFIX}/etc/imap/mailboxes
- @sed -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/cyrus.sh \
>${PREFIX}/etc/rc.d/cyrus.sh
@${CHMOD} 0755 ${PREFIX}/etc/rc.d/cyrus.sh
@PKG_PREFIX=${PREFIX} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
diff --git a/mail/poppassd/Makefile b/mail/poppassd/Makefile
index 23001c10e7e9..eb37874e2c1d 100644
--- a/mail/poppassd/Makefile
+++ b/mail/poppassd/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= andrew@ugh.net.au
EXTRACT_CMD= /bin/cat
EXTRACT_SUFX=
EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= | /usr/bin/sed -e '1,16d' | ${SH}
+EXTRACT_AFTER_ARGS= | ${SED} -e '1,16d' | ${SH}
WRKSRC= ${WRKDIR}/poppassd
ALL_TARGET= poppassd
MAN8= poppassd.8
diff --git a/mail/smtpd/Makefile b/mail/smtpd/Makefile
index b112f614ba43..c6d42f3a0c34 100644
--- a/mail/smtpd/Makefile
+++ b/mail/smtpd/Makefile
@@ -21,7 +21,7 @@ SPOOLBASE= /var/smtpd
post-patch:
@mv ${WRKSRC}/Makefile ${WRKSRC}/Makefile.tmp
- @sed s+!!SPOOLBASE!!+${SPOOLBASE}+g < ${WRKSRC}/Makefile.tmp \
+ @${SED} s+!!SPOOLBASE!!+${SPOOLBASE}+g < ${WRKSRC}/Makefile.tmp \
> ${WRKSRC}/Makefile
post-install:
@@ -57,7 +57,7 @@ post-install:
${SPOOLBASE}/etc
@${ECHO} "Creating startup file..."
- @sed s+!!PREFIX!!+${PREFIX}+ \
+ @${SED} s+!!PREFIX!!+${PREFIX}+ \
< ${FILESDIR}/smtpd.sh \
> ${PREFIX}/etc/rc.d/smtpd.sh
@${CHMOD} 0700 ${PREFIX}/etc/rc.d/smtpd.sh
diff --git a/math/snns/Makefile b/math/snns/Makefile
index 6441609e725b..f999c9f04ddb 100644
--- a/math/snns/Makefile
+++ b/math/snns/Makefile
@@ -17,7 +17,7 @@ USE_XLIB= yes
post-configure:
@(cd ${WRKSRC} && ./configure < options.FreeBSD)
- @(sed -e "s#%prefix%#${PREFIX}#g" < ${FILESDIR}/snns > ${WRKSRC}/snns)
+ @(${SED} -e "s#%prefix%#${PREFIX}#g" < ${FILESDIR}/snns > ${WRKSRC}/snns)
do-build:
@(cd ${WRKSRC} && ./build all)
diff --git a/math/xmgr/Makefile b/math/xmgr/Makefile
index d892945578fa..438fd9afba3f 100644
--- a/math/xmgr/Makefile
+++ b/math/xmgr/Makefile
@@ -3,7 +3,7 @@
# Date created: So 2 Mär 1997 12:11:43 MET
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.14 1999/05/12 07:46:53 asami Exp $
+# $Id: Makefile,v 1.15 1999/08/22 18:59:08 mharo Exp $
#
DISTNAME= xmgr-4.1.1
@@ -32,7 +32,7 @@ INSTALL_TARGET= install links
post-patch:
mv ${WRKSRC}/configure ${WRKSRC}/configure.input
- sed "s%__MOTIFLIB__%${MOTIFLIB}%" ${WRKSRC}/configure.input > ${WRKSRC}/configure
+ ${SED} "s%__MOTIFLIB__%${MOTIFLIB}%" ${WRKSRC}/configure.input > ${WRKSRC}/configure
rm -f ${WRKSRC}/configure.input
${CHMOD} 755 ${WRKSRC}/configure
diff --git a/net/freewais-sf/Makefile b/net/freewais-sf/Makefile
index a2823b3a9f33..87764c2e1f26 100644
--- a/net/freewais-sf/Makefile
+++ b/net/freewais-sf/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 November 1996
# Whom: Pedro Giffuni
#
-# $Id: Makefile,v 1.9 1999/06/09 00:13:13 steve Exp $
+# $Id: Makefile,v 1.10 1999/08/22 23:33:11 mharo Exp $
#
DISTNAME= freeWAIS-sf-2.2.11
@@ -25,7 +25,7 @@ MAN1= catalog.1 dictionary.1 inverted_file.1 makedb.1 mkfmt.1 waisindex.1 \
MAN3= ftw.3 scandir.3
pre-configure:
- sed "s,PREFIX,${PREFIX},g" \
+ ${SED} "s,PREFIX,${PREFIX},g" \
${FILESDIR}/configure.ans.skel > ${WRKDIR}/configure.ans
${MKDIR} ${PREFIX}
${MKDIR} ${PREFIX}/bin
diff --git a/net/rtsp_proxy/Makefile b/net/rtsp_proxy/Makefile
index 1447d1d6bdca..4ccf3e55ccfd 100644
--- a/net/rtsp_proxy/Makefile
+++ b/net/rtsp_proxy/Makefile
@@ -3,7 +3,7 @@
# Date created: 8 June 1999
# Whom: Richard Kiss <richard@homemail.com>
#
-# $Id: Makefile,v 1.1.1.1 1999/06/16 16:47:36 billf Exp $
+# $Id: Makefile,v 1.2 1999/08/01 02:35:05 steve Exp $
#
DISTNAME= SS1.0.1
@@ -25,6 +25,6 @@ do-install:
@ ${INSTALL_DATA} ${WRKSRC}/../qts_proxy.conf ${PREFIX}/etc/
post-install:
- @ ${CAT} ${PKGMESSAGE} | sed -e 's,@PREFIX@,${PREFIX},g'
+ @ ${CAT} ${PKGMESSAGE} | ${SED} -e 's,@PREFIX@,${PREFIX},g'
.include <bsd.port.mk>
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 46f822f27f42..429cfea3aad1 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -3,7 +3,7 @@
# Date created: 6 January 1997
# Whom: proff@suburbia.net
#
-# $Id: Makefile,v 1.12 1999/08/27 22:30:00 mharo Exp $
+# $Id: Makefile,v 1.13 1999/08/28 01:57:50 mharo Exp $
#
DISTNAME= nntpcache-2.3.2
@@ -42,7 +42,7 @@ post-install:
hardlink-pgp-files:
for i in ${PREFIX}/etc/nntpcache/*asc-dist ${PREFIX}/etc/nntpcache/*pgp-dist ; do \
- j=`${ECHO} $$i | sed -e 's/-dist//'`; \
+ j=`${ECHO} $$i | ${SED} -e 's/-dist//'`; \
if [ \! -f $$j ]; then \
${LN} $$i $$j; \
fi; \
diff --git a/print/makeindex/Makefile b/print/makeindex/Makefile
index ca9e5a594a91..11dcb1425bb2 100644
--- a/print/makeindex/Makefile
+++ b/print/makeindex/Makefile
@@ -3,7 +3,7 @@
# Date created: 12 October 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.10 1996/11/22 11:11:38 asami Exp $
+# $Id: Makefile,v 1.11 1997/02/18 16:57:16 jmz Exp $
#
DISTNAME= makeindex-3.0.8
@@ -25,7 +25,7 @@ do-install:
@(cd ${WRKSRC}/src-3.0/regexp; make)
@(cd ${WRKSRC}/src-3.0; make install)
@(cd ${WRKSRC}/doc; \
- sed -e s:/usr/local/lib/tex/macros/:${PREFIX}/share/texmf/makeindx/: \
+ ${SED} -e s:/usr/local/lib/tex/macros/:${PREFIX}/share/texmf/makeindx/: \
<makeindex.l >makeindex.1; \
${INSTALL_DATA} makeindex.1 ${PREFIX}/man/man1/)
diff --git a/print/pbm2ppa/Makefile b/print/pbm2ppa/Makefile
index 37e47b5a84a4..7a0b54c4dbd5 100644
--- a/print/pbm2ppa/Makefile
+++ b/print/pbm2ppa/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 November 1998
# Whom: smace@freebsd.org
#
-# $Id: Makefile,v 1.4 1999/05/10 02:39:19 smace Exp $
+# $Id: Makefile,v 1.5 1999/08/23 04:23:52 mharo Exp $
#
DISTNAME= ppa-0.8.6
@@ -38,8 +38,8 @@ pre-configure:
.endif
do-install:
- sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
- sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
+ ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
+ ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
cd ${WRKSRC} && \
(${INSTALL_PROGRAM} pbm2ppa pbmtpg \
${PREFIX}/bin; \
diff --git a/print/pnm2ppa/Makefile b/print/pnm2ppa/Makefile
index 37e47b5a84a4..7a0b54c4dbd5 100644
--- a/print/pnm2ppa/Makefile
+++ b/print/pnm2ppa/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 November 1998
# Whom: smace@freebsd.org
#
-# $Id: Makefile,v 1.4 1999/05/10 02:39:19 smace Exp $
+# $Id: Makefile,v 1.5 1999/08/23 04:23:52 mharo Exp $
#
DISTNAME= ppa-0.8.6
@@ -38,8 +38,8 @@ pre-configure:
.endif
do-install:
- sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
- sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
+ ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
+ ${SED} s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
cd ${WRKSRC} && \
(${INSTALL_PROGRAM} pbm2ppa pbmtpg \
${PREFIX}/bin; \
diff --git a/print/tex/Makefile b/print/tex/Makefile
index a585e6a2d5ba..f39c160dbe06 100644
--- a/print/tex/Makefile
+++ b/print/tex/Makefile
@@ -3,7 +3,7 @@
# Date created: 29 September 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.33 1999/01/29 03:09:05 jmz Exp $
+# $Id: Makefile,v 1.34 1999/08/23 04:23:37 mharo Exp $
#
DISTNAME= web2c-7.1
@@ -24,7 +24,7 @@ USE_GMAKE= yes
MAKE_FLAGS= fmts= all_mems=
do-build:
- @(cd ${WRKSRC}; unset `env|${GREP} ^TEX|sed -e s/=.*//`; \
+ @(cd ${WRKSRC}; unset `env|${GREP} ^TEX|${SED} -e s/=.*//`; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${ALL_TARGET})
post-install:
diff --git a/russian/pgp.language/Makefile b/russian/pgp.language/Makefile
index 0e5b7fa4941d..0763eab7fcef 100644
--- a/russian/pgp.language/Makefile
+++ b/russian/pgp.language/Makefile
@@ -3,7 +3,7 @@
# Date created: 4 May 1995
# Whom: ache
#
-# $Id: Makefile,v 1.23 1999/08/22 23:33:21 mharo Exp $
+# $Id: Makefile,v 1.24 1999/08/23 04:23:40 mharo Exp $
#
DISTNAME= pgp26ru
@@ -30,7 +30,7 @@ do-install:
cd ${WRKSRC}; tr -d '\015' < NOTES.ru > ${PGPLIB}/NOTES.ru
cd ${PGPLIB}; ${GREP} -l -q '^Language.*=.*ru' config.txt || { \
${CP} config.txt config.txt.bak; \
- sed 's/^Language.*=.*$$/Language = ru/' < config.txt.bak > config.txt; }
+ ${SED} 's/^Language.*=.*$$/Language = ru/' < config.txt.bak > config.txt; }
-pgp > /dev/null 2>&1 # update .idx file
.include <bsd.port.mk>
diff --git a/security/skip/Makefile b/security/skip/Makefile
index 76755f046a36..b5811a22d930 100644
--- a/security/skip/Makefile
+++ b/security/skip/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 November 1997
# Whom: Archie L. Cobbs <archie@whistle.com>
#
-# $Id: Makefile,v 1.9 1999/07/31 21:48:34 archie Exp $
+# $Id: Makefile,v 1.10 1999/08/23 04:23:42 mharo Exp $
DISTNAME= skip-1.0
CATEGORIES= security
@@ -52,7 +52,7 @@ post-patch:
@cd ${WRKSRC}; \
FILES=`find . -type f -print | xargs ${GREP} -l @@PREFIX@@`; \
for FILE in $$FILES; do \
- sed 's!@@PREFIX@@!${PREFIX}!g' < $$FILE > $$FILE.new ; \
+ ${SED} 's!@@PREFIX@@!${PREFIX}!g' < $$FILE > $$FILE.new ; \
mv $$FILE.new $$FILE; \
done
diff --git a/sysutils/lsof/Makefile b/sysutils/lsof/Makefile
index ec511127585c..dae74cf8fae7 100644
--- a/sysutils/lsof/Makefile
+++ b/sysutils/lsof/Makefile
@@ -4,7 +4,7 @@
# Date created: Sat July 20, 1996
# Whom: David O'Brien (obrien@FreeBSD.org)
#
-# $Id: Makefile,v 1.46 1999/08/23 04:23:43 mharo Exp $
+# $Id: Makefile,v 1.47 1999/08/27 22:30:12 mharo Exp $
#
DISTNAME= lsof_4.45_W
@@ -36,7 +36,7 @@ SRCBALL_NAME= ${DISTNAME:S/_W$//}
post-extract:
@( cd ${WRKDIR} ; \
- EXPMD5=`${GREP} MD5 README.${SRCBALL_NAME} | sed 's/^[ ]*//'` ; \
+ EXPMD5=`${GREP} MD5 README.${SRCBALL_NAME} | ${SED} 's/^[ ]*//'` ; \
CALCMD5=`${MD5} ${SRCBALL_NAME}.tar` ; \
if [ "$${EXPMD5}"X != "$${CALCMD5}"X ]; then \
${ECHO} "Expected and calculated MD5 signatures don't agree." ; \
diff --git a/sysutils/upsd/Makefile b/sysutils/upsd/Makefile
index 335be5333b4a..acc44b822469 100644
--- a/sysutils/upsd/Makefile
+++ b/sysutils/upsd/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 Jul 1996
# Whom: alexis
#
-# $Id: Makefile,v 1.1.1.1 1998/02/25 16:46:22 steve Exp $
+# $Id: Makefile,v 1.2 1998/07/03 23:40:20 steve Exp $
#
DISTNAME= upsd-2.0.1.6
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/upsd-2.0
pre-build:
@${MV} ${WRKSRC}/config.h ${WRKSRC}/conf.h.orig
- @sed -e "s!@prefix@!${PREFIX}!g" ${WRKSRC}/conf.h.orig > ${WRKSRC}/conf.h
+ @${SED} -e "s!@prefix@!${PREFIX}!g" ${WRKSRC}/conf.h.orig > ${WRKSRC}/conf.h
post-install:
if [ ! -f ${PREFIX}/etc/upsd.conf ] ; then \
diff --git a/www/webglimpse/Makefile b/www/webglimpse/Makefile
index 800513d12fee..e58609a79c88 100644
--- a/www/webglimpse/Makefile
+++ b/www/webglimpse/Makefile
@@ -4,7 +4,7 @@
# Date created: 2 Nov 1998
# Whom: ache
#
-# $Id: Makefile,v 1.7 1999/06/05 19:58:45 mharo Exp $
+# $Id: Makefile,v 1.8 1999/08/22 23:33:34 mharo Exp $
#
DISTNAME= webglimpse-1.6.src
@@ -25,7 +25,7 @@ NO_BUILD= YES
pre-configure:
.for i in wginstall wginstall.pl
cd ${WRKSRC}; ${CP} $i $i.tmp; \
- sed s=%PERL%=${PERL}= < $i.tmp > $i
+ ${SED} s=%PERL%=${PERL}= < $i.tmp > $i
.endfor
do-install:
diff --git a/x11-fm/x-files/Makefile b/x11-fm/x-files/Makefile
index 3d26517e3310..30bad05827a9 100644
--- a/x11-fm/x-files/Makefile
+++ b/x11-fm/x-files/Makefile
@@ -3,7 +3,7 @@
# Date created: 14 April 1998
# Whom: Donald J. Maddox <dmaddox@conterra.com>
#
-# $Id: Makefile,v 1.8 1999/03/08 20:55:35 steve Exp $
+# $Id: Makefile,v 1.9 1999/07/02 00:00:26 mph Exp $
#
DISTNAME= X-Files-1.43
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
pre-install:
@tclsh8.0 ${SCRIPTDIR}/mktclIndex ${WRKSRC}
- @sed s#@X11BASE@#${X11BASE}# <${WRKSRC}/X-Files.tcl >${WRKSRC}/tmpfile
+ @${SED} s#@X11BASE@#${X11BASE}# <${WRKSRC}/X-Files.tcl >${WRKSRC}/tmpfile
@mv ${WRKSRC}/tmpfile ${WRKSRC}/X-Files.tcl
do-install:
diff --git a/x11-wm/afterstep-i18n/Makefile b/x11-wm/afterstep-i18n/Makefile
index 41c89b7403a6..16c5468cf8b9 100644
--- a/x11-wm/afterstep-i18n/Makefile
+++ b/x11-wm/afterstep-i18n/Makefile
@@ -3,7 +3,7 @@
# Date created: 23 October 1998
# Whom: issei@jp.FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1999/01/18 06:38:08 asami Exp $
+# $Id: Makefile,v 1.6 1999/02/21 21:51:00 billf Exp $
#
DISTNAME= AfterStep-1.0
@@ -49,7 +49,7 @@ post-patch:
@ for i in ${SRCDIRS}; do \
cd ${WRKSRC}/$$i; \
mv Imakefile Imakefile.orig; \
- sed -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
+ ${SED} -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
done
pre-build:
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 7c764543f627..3e2d2399588d 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 January 1994
# Whom: jmz
#
-# $Id: Makefile,v 1.13 1998/10/15 11:10:02 jseger Exp $
+# $Id: Makefile,v 1.14 1998/10/16 02:12:34 jseger Exp $
#
DISTNAME= xloadimage.4.1
@@ -28,6 +28,6 @@ do-configure:
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} xloadimage uufilter ${X11BASE}/bin
cd ${WRKSRC} && ${INSTALL_DATA} xloadimagerc ${X11BASE}/lib/X11/app-defaults/Xloadimage
- cd ${WRKSRC} && sed -e s:/usr/lib/X11/Xloadimage:${X11BASE}/lib/X11/app-defaults/Xloadimage: < xloadimage.man |${GZIP_CMD} >${X11BASE}/man/man1/xloadimage.1.gz
+ cd ${WRKSRC} && ${SED} -e s:/usr/lib/X11/Xloadimage:${X11BASE}/lib/X11/app-defaults/Xloadimage: < xloadimage.man |${GZIP_CMD} >${X11BASE}/man/man1/xloadimage.1.gz
.include <bsd.port.mk>