aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gnustep-make/Makefile20
-rw-r--r--lang/gnustep-base/Makefile7
-rw-r--r--lang/gnustep-base/files/GNUstep.sh1
3 files changed, 2 insertions, 26 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 40f715912c29..4d25da38d290 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -31,25 +31,7 @@ CONFIGURE_ARGS+= --with-config-file=${PREFIX}/GNUstep.conf
GNUSTEP_WITHOUT_LIBOBJC= yes
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(GNUSTEP_WITH_BASE_GCC)
-pre-configure:
- @if test ! -f "${TARGLIB}/libobjc.so"; then \
- ${ECHO_MSG} "libobjc.so not found, please update your gcc"; \
- ${FALSE}; \
- fi; \
- if test `${LDCONFIG} -r | ${GREP} "${TARGLIB}/libobjc.so" | wc -l` -eq 0; then \
- ${ECHO_MSG} "trying to fix ldconfig.hints"; \
- ${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -m "${TARGLIB}";\
- if test `${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -r | ${GREP} "${TARGLIB}/libobjc.so" | wc -l` -eq 0; then \
- ${ECHO_MSG} "libobjc.so not in path"; \
- ${FALSE}; \
- fi; \
- fi;
-.endif
-
post-install:
${LN} -s Library/Makefiles ${PREFIX}/System/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 0b7630c64e7c..383cd5a17e1a 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -58,11 +58,6 @@ EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
PATH:= ${PREFIX}/System/Tools:${PATH}
-.if !defined(GNUSTEP_WITH_BASE_GCC)
-pre-configure:
- ${LDCONFIG} -m ${TARGLIB}
-.endif
-
post-build:
.for i in ${MAKE_APPS}
(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
@@ -71,7 +66,7 @@ post-build:
post-extract:
@${SED} -e "s=%%PREFIX%%=${LOCALBASE}=" \
- -e "s=%%TARGLIB%%=${TARGLIB}=" ${FILESDIR}/GNUstep.sh \
+ ${FILESDIR}/GNUstep.sh \
> ${WRKSRC}/GNUstep.sh
post-install:
diff --git a/lang/gnustep-base/files/GNUstep.sh b/lang/gnustep-base/files/GNUstep.sh
index 7ecd9905c4fc..6c9eaccb8736 100644
--- a/lang/gnustep-base/files/GNUstep.sh
+++ b/lang/gnustep-base/files/GNUstep.sh
@@ -8,7 +8,6 @@ GNUSTEP_SYSTEM_ROOT="${PREFIX}/GNUstep/System"
case "$1" in
start)
if [ -e ${GNUSTEP_SYSTEM_ROOT}/Library/Makefiles/GNUstep.sh ]; then
- ldconfig -m %%TARGLIB%%
. ${GNUSTEP_SYSTEM_ROOT}/Library/Makefiles/GNUstep.sh
rm -f ${PIDFILE}
opentool gdomap -a ${IFFILE} -I ${PIDFILE}