aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-DateTime/Makefile16
-rw-r--r--devel/p5-DateTime/distinfo6
-rw-r--r--devel/p5-DateTime/pkg-plist1
3 files changed, 17 insertions, 6 deletions
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index 30062a134634..55c8d02bd9af 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DateTime
-PORTVERSION= 0.30
+PORTVERSION= 0.31
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DateTime
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= DateTime.3 DateTime::Duration.3 \
- DateTime::Infinite.3 DateTime::LeapSecond.3
+ DateTime::Helpers.3 DateTime::Infinite.3 DateTime::LeapSecond.3
.if !defined(NOPORTDOCS)
PORTDOCS= CREDITS Changes TODO
@@ -36,4 +36,14 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-DateTime/distinfo b/devel/p5-DateTime/distinfo
index 59c46e44f73d..aa209f92a027 100644
--- a/devel/p5-DateTime/distinfo
+++ b/devel/p5-DateTime/distinfo
@@ -1,3 +1,3 @@
-MD5 (DateTime-0.30.tar.gz) = 18cf4a7cece737e0a153c6585320730f
-SHA256 (DateTime-0.30.tar.gz) = 06cb111609a9d579a4620e9540b34fdac6e3825d28e08e0b0ba43321582cd7a2
-SIZE (DateTime-0.30.tar.gz) = 88484
+MD5 (DateTime-0.31.tar.gz) = f5142045e7e68c02a310405e994f8233
+SHA256 (DateTime-0.31.tar.gz) = ee4752b9c7c55fec026990b09948b3fbca26a22592fff983aedd22058bf9588c
+SIZE (DateTime-0.31.tar.gz) = 89129
diff --git a/devel/p5-DateTime/pkg-plist b/devel/p5-DateTime/pkg-plist
index d41c4cdd2911..5114904836a7 100644
--- a/devel/p5-DateTime/pkg-plist
+++ b/devel/p5-DateTime/pkg-plist
@@ -1,6 +1,7 @@
@comment $FreeBSD$
%%SITE_PERL%%/%%PERL_ARCH%%/DateTime.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Duration.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Helpers.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/Infinite.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DateTime/LeapSecond.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DateTimePP.pm