aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-IO-Socket-Timeout/Makefile22
-rw-r--r--net/p5-IO-Socket-Timeout/distinfo2
-rw-r--r--net/p5-IO-Socket-Timeout/pkg-descr5
-rw-r--r--net/p5-IO-Socket-Timeout/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e2be7bea3afb..34d0daaa424f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -527,6 +527,7 @@
SUBDIR += p5-IO-Socket-IP
SUBDIR += p5-IO-Socket-Multicast
SUBDIR += p5-IO-Socket-Multicast6
+ SUBDIR += p5-IO-Socket-Timeout
SUBDIR += p5-IO-Socket-UNIX-Util
SUBDIR += p5-IP-Anonymous
SUBDIR += p5-IP-Country
diff --git a/net/p5-IO-Socket-Timeout/Makefile b/net/p5-IO-Socket-Timeout/Makefile
new file mode 100644
index 000000000000..45cc491d5ef3
--- /dev/null
+++ b/net/p5-IO-Socket-Timeout/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= IO-Socket-Timeout
+PORTVERSION= 0.32
+CATEGORIES= net ipv6 perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pi@FreeBSD.org
+COMMENT= IO::Socket with read/write timeout
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-PerlIO-via-Timeout>=0.32:${PORTSDIR}/devel/p5-PerlIO-via-Timeout
+
+NO_ARCH= yes
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Socket-Timeout/distinfo b/net/p5-IO-Socket-Timeout/distinfo
new file mode 100644
index 000000000000..04846a68f40d
--- /dev/null
+++ b/net/p5-IO-Socket-Timeout/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IO-Socket-Timeout-0.32.tar.gz) = edf915d6cc66bee43503aa6dc2b373366f38eaff701582183dad10cb8adf2972
+SIZE (IO-Socket-Timeout-0.32.tar.gz) = 16294
diff --git a/net/p5-IO-Socket-Timeout/pkg-descr b/net/p5-IO-Socket-Timeout/pkg-descr
new file mode 100644
index 000000000000..1f75c133d6e2
--- /dev/null
+++ b/net/p5-IO-Socket-Timeout/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a way to set a timeout on read / write operations
+on an IO::Socket instance, or any IO::Socket::* modules, like
+IO::Socket::INET.
+
+WWW: http://search.cpan.org/dist/IO-Socket-Timeout/
diff --git a/net/p5-IO-Socket-Timeout/pkg-plist b/net/p5-IO-Socket-Timeout/pkg-plist
new file mode 100644
index 000000000000..c84b22b8b854
--- /dev/null
+++ b/net/p5-IO-Socket-Timeout/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/IO/Socket/Timeout.pm
+%%PERL5_MAN3%%/IO::Socket::Timeout.3.gz