aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/aunit/Makefile28
-rw-r--r--devel/aunit/distinfo3
-rw-r--r--devel/aunit/files/patch-Makefile11
-rw-r--r--devel/aunit/pkg-descr9
-rw-r--r--devel/aunit/pkg-plist171
6 files changed, 223 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 254cf642ce5f..04286d77dea9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -115,6 +115,7 @@
SUBDIR += atlas
SUBDIR += atlas-devel
SUBDIR += atlassian-plugin-sdk
+ SUBDIR += aunit
SUBDIR += autobook
SUBDIR += autoconf
SUBDIR += autoconf-archive
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
new file mode 100644
index 000000000000..4e8241049d73
--- /dev/null
+++ b/devel/aunit/Makefile
@@ -0,0 +1,28 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aunit
+PORTVERSION= 2016
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+DISTNAME= aunit-gpl-${PORTVERSION}-src
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Ada unit testing framework
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= gprbuild:devel/gprbuild
+
+USES= ada gmake
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|LIBDIR|MYLIBDIR|' \
+ ${WRKSRC}/lib/gnat/aunit_shared.gpr
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install:
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/gnat/manifests
+
+.include <bsd.port.mk>
diff --git a/devel/aunit/distinfo b/devel/aunit/distinfo
new file mode 100644
index 000000000000..774ab8f1e244
--- /dev/null
+++ b/devel/aunit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469184203
+SHA256 (aunit-gpl-2016-src.tar.gz) = ba1b86b853daef98190a7dfc9858aedcd4cc85219b310356c02348f32dcc77cf
+SIZE (aunit-gpl-2016-src.tar.gz) = 393489
diff --git a/devel/aunit/files/patch-Makefile b/devel/aunit/files/patch-Makefile
new file mode 100644
index 000000000000..29bdda09ec7d
--- /dev/null
+++ b/devel/aunit/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2016-01-19 16:18:43 UTC
++++ Makefile
+@@ -4,7 +4,7 @@ GPRBUILD = gprbuild
+ GPRCLEAN = gprclean
+ GPRINSTALL = gprinstall
+
+-INSTALL:=$(shell exec=`which gprbuild`;if [ ! -x "$$exec" ]; then unset exec;fi;echo $$exec | sed -e 's/\/bin\/$(GPRBUILD).*//')
++INSTALL:=$(DESTDIR)$(PREFIX)
+
+ ifeq ($(RTS),)
+ RTS=full
diff --git a/devel/aunit/pkg-descr b/devel/aunit/pkg-descr
new file mode 100644
index 000000000000..ef7c85baf144
--- /dev/null
+++ b/devel/aunit/pkg-descr
@@ -0,0 +1,9 @@
+AUnit is a set of Ada packages based on the xUnit family of unit test
+frameworks. It is intended as a developer's tool to facilitate confident
+writing and evolution of Ada software. It is purposely lightweight, as
+one of its main goals is to make it easy to develop and run unit tests,
+rather than to generate artifacts for process management. The framework
+supports easy composition of sets of unit tests to provide flexibility
+in determining what tests to run for a given purpose.
+
+WWW: http://libre.adacore.com/tools/aunit/
diff --git a/devel/aunit/pkg-plist b/devel/aunit/pkg-plist
new file mode 100644
index 000000000000..2d1525bb1f48
--- /dev/null
+++ b/devel/aunit/pkg-plist
@@ -0,0 +1,171 @@
+include/aunit/ada_containers-aunit_lists.adb
+include/aunit/ada_containers-aunit_lists.ads
+include/aunit/ada_containers.ads
+include/aunit/aunit-assertions-assert_exception.adb
+include/aunit/aunit-assertions.adb
+include/aunit/aunit-assertions.ads
+include/aunit/aunit-memory-utils.adb
+include/aunit/aunit-memory-utils.ads
+include/aunit/aunit-memory.adb
+include/aunit/aunit-memory.ads
+include/aunit/aunit-options.ads
+include/aunit/aunit-reporter-gnattest.adb
+include/aunit/aunit-reporter-gnattest.ads
+include/aunit/aunit-reporter-text.adb
+include/aunit/aunit-reporter-text.ads
+include/aunit/aunit-reporter-xml.adb
+include/aunit/aunit-reporter-xml.ads
+include/aunit/aunit-reporter.ads
+include/aunit/aunit-run.adb
+include/aunit/aunit-run.ads
+include/aunit/aunit-simple_test_cases-run_routine.adb
+include/aunit/aunit-simple_test_cases.adb
+include/aunit/aunit-simple_test_cases.ads
+include/aunit/aunit-test_caller.adb
+include/aunit/aunit-test_caller.ads
+include/aunit/aunit-test_cases-registration.adb
+include/aunit/aunit-test_cases.adb
+include/aunit/aunit-test_cases.ads
+include/aunit/aunit-test_filters.adb
+include/aunit/aunit-test_filters.ads
+include/aunit/aunit-test_fixtures.adb
+include/aunit/aunit-test_fixtures.ads
+include/aunit/aunit-test_results.adb
+include/aunit/aunit-test_results.ads
+include/aunit/aunit-test_suites.adb
+include/aunit/aunit-test_suites.ads
+include/aunit/aunit-tests.ads
+include/aunit/aunit-time_measure.adb
+include/aunit/aunit-time_measure.ads
+include/aunit/aunit.adb
+include/aunit/aunit.ads
+lib/aunit/ada_containers-aunit_lists.ali
+lib/aunit/ada_containers.ali
+lib/aunit/aunit-assertions.ali
+lib/aunit/aunit-memory-utils.ali
+lib/aunit/aunit-memory.ali
+lib/aunit/aunit-options.ali
+lib/aunit/aunit-reporter-gnattest.ali
+lib/aunit/aunit-reporter-text.ali
+lib/aunit/aunit-reporter-xml.ali
+lib/aunit/aunit-reporter.ali
+lib/aunit/aunit-run.ali
+lib/aunit/aunit-simple_test_cases.ali
+lib/aunit/aunit-test_caller.ali
+lib/aunit/aunit-test_cases.ali
+lib/aunit/aunit-test_filters.ali
+lib/aunit/aunit-test_fixtures.ali
+lib/aunit/aunit-test_results.ali
+lib/aunit/aunit-test_suites.ali
+lib/aunit/aunit-tests.ali
+lib/aunit/aunit-time_measure.ali
+lib/aunit/aunit.ali
+lib/aunit/libaunit.a
+lib/gnat/aunit.gpr
+%%PORTDOCS%%%%DOCSDIR%%/aunit.html
+%%PORTDOCS%%%%DOCSDIR%%/aunit.info
+%%PORTDOCS%%%%DOCSDIR%%/aunit.pdf
+%%PORTDOCS%%%%DOCSDIR%%/aunit.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/main_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/main_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operands-ints-test-suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operands-ints-test-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operations-addition-test-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operations-binary-gen_test-gen_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operations-binary-gen_test-gen_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/operations-subtraction-test-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/stack-test-suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/stack-test-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/fixture/test_calculator.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operands-ints.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operands-ints.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operands.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-addition.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-binary.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-binary.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-ints.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-ints.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations-subtraction.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/operations.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/stack.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/src/stack.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operands-ints-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operands-ints-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-addition-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-addition_test_fixture.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-addition_test_fixture.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-binary-gen_test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-binary-gen_test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-subtraction-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-subtraction_test_fixture.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/operations-subtraction_test_fixture.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/stack-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/calculator/tests/stack-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tested_lib/src/math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tested_lib/src/math.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tests/math-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tests/math-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tests/math_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tests/math_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/failures/tests/test_math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/rectangle.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/rectangle.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/shape.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/shape.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/square.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/src/square.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/my_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/my_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/rectangle-tests-suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/rectangle-tests-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/rectangle-tests.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/rectangle-tests.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/shape-tests.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/shape-tests.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests-suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests-suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests-suite_liskov.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests-suite_liskov.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/square-tests.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/liskov/tests/test_liskov.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tested_lib/src/math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tested_lib/src/math.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tests/math-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tests/math-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tests/math_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tests/math_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple_test/tests/test_math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/src/math-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/src/math-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/src/math_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/src/math_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/harness/src/test_math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/tested_lib/src/math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/tested_lib/src/math.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_caller/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/harness.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tested_lib/src/math.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tested_lib/src/math.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tested_lib/testlib.gpr
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tests/math-test.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tests/math-test.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tests/math_suite.adb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tests/math_suite.ads
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_fixture/tests/test_math.adb
+share/gps/plug-ins/aunit.xml