aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk2
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/libxul/Makefile3
-rw-r--r--www/seamonkey/Makefile2
6 files changed, 8 insertions, 3 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 46232fe7276f..c3ce5e3aa0e3 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -250,9 +250,11 @@ BUILD_DEPENDS+= ${-${dep}_BUILD_DEPENDS}
# Standard options
MOZ_CHROME?= omni
MOZ_TOOLKIT?= cairo-gtk2
+MOZ_CHANNEL?= ${PKGNAMESUFFIX:Urelease:S/^-//}
MOZ_OPTIONS+= \
--enable-chrome-format=${MOZ_CHROME} \
--enable-default-toolkit=${MOZ_TOOLKIT} \
+ --enable-update-channel=${MOZ_CHANNEL} \
--enable-pie \
--with-pthreads
# Configure options for install
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 885d4913a1f0..e6b61be40544 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.8.0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 46158e6fb46a..ce444393db9a 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 45.8.0
DISTVERSIONSUFFIX=esr.source
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7aebc07a5d2a..87c2d1b829e4 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,6 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.0.1
DISTVERSIONSUFFIX=.source
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 931d0110fa53..b56bd5bb436e 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.8.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build2/source
@@ -40,6 +40,7 @@ LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
USE_LDCONFIG= ${PREFIX}/lib/${MOZILLA}
MOZ_OPTIONS?= --enable-application=xulrunner
+MOZ_CHANNEL= esr
USE_GECKO= gecko
CPE_PRODUCT= firefox_esr
MOZILLA_EXEC_NAME=xulrunner
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index f66a4beb5ba9..8d7481b88980 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.46
MOZILLA_VER= 49 # above + 3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build9/source