aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/xstroke/Makefile3
-rw-r--r--x11/xstroke/files/patch-Imakefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index b9690bd143b2..53252c5dce60 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -13,8 +13,7 @@ COMMENT= Fullscreen gesture recognition
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= imake
-BUILD_DEPENDS= byacc:devel/byacc
+USES= bison imake
USE_XORG= xft x11 xext xi xtst
PLIST_FILES= bin/xstroke %%ETCDIR%%/alphabet man/man1/xstroke.1.gz
diff --git a/x11/xstroke/files/patch-Imakefile b/x11/xstroke/files/patch-Imakefile
index ed0491b879b4..8c632e41a45f 100644
--- a/x11/xstroke/files/patch-Imakefile
+++ b/x11/xstroke/files/patch-Imakefile
@@ -9,7 +9,7 @@
-LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm -ldl -lpthread
+LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm $(LDFLAGS)
FLEX=flex
-+YACC=byacc
++YACC=bison -y
OBJS=xstroke.o args.o backing.o bresenham.o brush.o control_win.o stroke.o matrix.o \
action.o action_item.o feature.o gesture.o log.o option.o sprintf_alloc.o \
rec.o rec_callback.o rec_history.o rec_lex.o rec_mode.o rec_parse.o \