aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/abyss/Makefile6
-rw-r--r--biology/abyss/distinfo6
-rw-r--r--biology/abyss/files/patch-RResolver_btllib_include_btllib_status.hpp11
3 files changed, 6 insertions, 17 deletions
diff --git a/biology/abyss/Makefile b/biology/abyss/Makefile
index d023c7d5b8b6..8458e069649a 100644
--- a/biology/abyss/Makefile
+++ b/biology/abyss/Makefile
@@ -1,6 +1,5 @@
PORTNAME= abyss
-DISTVERSION= 2.3.5
-PORTREVISION= 2
+DISTVERSION= 2.3.7
CATEGORIES= biology
MAINTAINER= yuri@FreeBSD.org
@@ -15,7 +14,8 @@ BROKEN_i386= result of comparison of constant 18446744073709551615 with expressi
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs \
ghc:lang/ghc \
pandoc:textproc/hs-pandoc # pandoc is required just for one man page: abyss-sealer
-LIB_DEPENDS= libffi.so:devel/libffi \
+LIB_DEPENDS= libbtllib.so:biology/btllib \
+ libffi.so:devel/libffi \
libgmp.so:math/gmp \
libmpich.so:net/mpich # binaries aren't linked with libmpich.so for some reason
RUN_DEPENDS= bash:shells/bash \
diff --git a/biology/abyss/distinfo b/biology/abyss/distinfo
index 82cc32c0fa85..f27d6fc7904a 100644
--- a/biology/abyss/distinfo
+++ b/biology/abyss/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659120367
-SHA256 (bcgsc-abyss-2.3.5_GH0.tar.gz) = 28fb7d75faa2599c3c4d2d2c29d320612ca1539f1772728d1acdfffb4b82dee5
-SIZE (bcgsc-abyss-2.3.5_GH0.tar.gz) = 3511232
+TIMESTAMP = 1689963359
+SHA256 (bcgsc-abyss-2.3.7_GH0.tar.gz) = eb1d814621ad2accaf19ea009453af891b29663de9f96c0da32c83fbfb71b85e
+SIZE (bcgsc-abyss-2.3.7_GH0.tar.gz) = 1323221
diff --git a/biology/abyss/files/patch-RResolver_btllib_include_btllib_status.hpp b/biology/abyss/files/patch-RResolver_btllib_include_btllib_status.hpp
deleted file mode 100644
index 01427a36b2ac..000000000000
--- a/biology/abyss/files/patch-RResolver_btllib_include_btllib_status.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- RResolver/btllib/include/btllib/status.hpp.orig 2022-07-29 18:56:25 UTC
-+++ RResolver/btllib/include/btllib/status.hpp
-@@ -151,7 +151,7 @@ get_strerror()
- char buf[buflen];
- // POSIX and GNU implementation of strerror_r differ, even in function signature
- // and so we need to check which one is used
--#if __APPLE__ || \
-+#if __APPLE__ || defined(__FreeBSD__) || \
- ((_POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && !_GNU_SOURCE)
- strerror_r(errno, buf, buflen);
- return buf;