aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/nethack-qt/Makefile9
-rw-r--r--games/nethack-qt/pkg-plist2
-rw-r--r--games/nethack33-qt/Makefile9
-rw-r--r--games/nethack33-qt/pkg-plist2
-rw-r--r--games/nethack34-qt/Makefile9
-rw-r--r--games/nethack34-qt/pkg-plist2
6 files changed, 18 insertions, 15 deletions
diff --git a/games/nethack-qt/Makefile b/games/nethack-qt/Makefile
index 2f272641eb87..a503ce308799 100644
--- a/games/nethack-qt/Makefile
+++ b/games/nethack-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.7 1997/07/12 16:53:38 max Exp $
+# $Id: Makefile,v 1.8 1997/10/04 14:53:07 andreas Exp $
#
DISTNAME= nethack-3.2.2
@@ -13,12 +13,13 @@ MASTER_SITES= ftp://ftp.uu.net/pub/games/nethack/sources/ \
http://www.uq.edu.au/~cswallis/nhqt/ \
http://student.uq.edu.au/~s002434/ \
${MASTER_SITE_GNU}
-QT_PATCH= nhqt0.9.tar.gz
-QT_SOUND= nhs.tar.gz
-DISTFILES= nethack-3.2.2.tar.gz ${QT_PATCH} ${QT_SOUND}
MAINTAINER= andreas@FreeBSD.ORG
+QT_PATCH= nhqt0.9.tar.gz
+QT_SOUND= nhs.tar.gz
+PATCHFILES= ${QT_PATCH} ${QT_SOUND}
+
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt \
diff --git a/games/nethack-qt/pkg-plist b/games/nethack-qt/pkg-plist
index b9b6c3bae250..269b1fad7324 100644
--- a/games/nethack-qt/pkg-plist
+++ b/games/nethack-qt/pkg-plist
@@ -3,7 +3,7 @@ lib/nethackdir/nethack
@exec mkdir %D/lib/nethackdir/save
@exec chmod 775 %D/lib/nethackdir/save
@exec chown games.games %D/lib/nethackdir/save
-@unexec rmdir %D/lib/nethackdir/save
+@dirrm %D/lib/nethackdir/save
man/man6/dgn_comp.6.gz
man/man6/dlb.6.gz
man/man6/lev_comp.6.gz
diff --git a/games/nethack33-qt/Makefile b/games/nethack33-qt/Makefile
index 2f272641eb87..a503ce308799 100644
--- a/games/nethack33-qt/Makefile
+++ b/games/nethack33-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.7 1997/07/12 16:53:38 max Exp $
+# $Id: Makefile,v 1.8 1997/10/04 14:53:07 andreas Exp $
#
DISTNAME= nethack-3.2.2
@@ -13,12 +13,13 @@ MASTER_SITES= ftp://ftp.uu.net/pub/games/nethack/sources/ \
http://www.uq.edu.au/~cswallis/nhqt/ \
http://student.uq.edu.au/~s002434/ \
${MASTER_SITE_GNU}
-QT_PATCH= nhqt0.9.tar.gz
-QT_SOUND= nhs.tar.gz
-DISTFILES= nethack-3.2.2.tar.gz ${QT_PATCH} ${QT_SOUND}
MAINTAINER= andreas@FreeBSD.ORG
+QT_PATCH= nhqt0.9.tar.gz
+QT_SOUND= nhs.tar.gz
+PATCHFILES= ${QT_PATCH} ${QT_SOUND}
+
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt \
diff --git a/games/nethack33-qt/pkg-plist b/games/nethack33-qt/pkg-plist
index b9b6c3bae250..269b1fad7324 100644
--- a/games/nethack33-qt/pkg-plist
+++ b/games/nethack33-qt/pkg-plist
@@ -3,7 +3,7 @@ lib/nethackdir/nethack
@exec mkdir %D/lib/nethackdir/save
@exec chmod 775 %D/lib/nethackdir/save
@exec chown games.games %D/lib/nethackdir/save
-@unexec rmdir %D/lib/nethackdir/save
+@dirrm %D/lib/nethackdir/save
man/man6/dgn_comp.6.gz
man/man6/dlb.6.gz
man/man6/lev_comp.6.gz
diff --git a/games/nethack34-qt/Makefile b/games/nethack34-qt/Makefile
index 2f272641eb87..a503ce308799 100644
--- a/games/nethack34-qt/Makefile
+++ b/games/nethack34-qt/Makefile
@@ -3,7 +3,7 @@
# Date created: So 6 Apr 1997 04:25:57 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.7 1997/07/12 16:53:38 max Exp $
+# $Id: Makefile,v 1.8 1997/10/04 14:53:07 andreas Exp $
#
DISTNAME= nethack-3.2.2
@@ -13,12 +13,13 @@ MASTER_SITES= ftp://ftp.uu.net/pub/games/nethack/sources/ \
http://www.uq.edu.au/~cswallis/nhqt/ \
http://student.uq.edu.au/~s002434/ \
${MASTER_SITE_GNU}
-QT_PATCH= nhqt0.9.tar.gz
-QT_SOUND= nhs.tar.gz
-DISTFILES= nethack-3.2.2.tar.gz ${QT_PATCH} ${QT_SOUND}
MAINTAINER= andreas@FreeBSD.ORG
+QT_PATCH= nhqt0.9.tar.gz
+QT_SOUND= nhs.tar.gz
+PATCHFILES= ${QT_PATCH} ${QT_SOUND}
+
BUILD_DEPENDS= auplay:${PORTSDIR}/audio/nas \
xpmtoppm:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt \
diff --git a/games/nethack34-qt/pkg-plist b/games/nethack34-qt/pkg-plist
index b9b6c3bae250..269b1fad7324 100644
--- a/games/nethack34-qt/pkg-plist
+++ b/games/nethack34-qt/pkg-plist
@@ -3,7 +3,7 @@ lib/nethackdir/nethack
@exec mkdir %D/lib/nethackdir/save
@exec chmod 775 %D/lib/nethackdir/save
@exec chown games.games %D/lib/nethackdir/save
-@unexec rmdir %D/lib/nethackdir/save
+@dirrm %D/lib/nethackdir/save
man/man6/dgn_comp.6.gz
man/man6/dlb.6.gz
man/man6/lev_comp.6.gz