aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/libdaq/Makefile2
-rw-r--r--net/libdaq/distinfo6
-rw-r--r--net/libdaq/files/patch-api_daq__common.h12
3 files changed, 16 insertions, 4 deletions
diff --git a/net/libdaq/Makefile b/net/libdaq/Makefile
index 889a8f9a19bc..596d9a7eed2a 100644
--- a/net/libdaq/Makefile
+++ b/net/libdaq/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libdaq
DISTVERSIONPREFIX= v
-DISTVERSION= 3.0.0-alpha1
+DISTVERSION= 3.0.0-alpha2
CATEGORIES= net
MAINTAINER= bofh@FreeBSD.org
diff --git a/net/libdaq/distinfo b/net/libdaq/distinfo
index 85537000bcde..aa33102787f2 100644
--- a/net/libdaq/distinfo
+++ b/net/libdaq/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563994415
-SHA256 (snort3-libdaq-v3.0.0-alpha1_GH0.tar.gz) = 0ede444bdda671fc0a08400b5b7607f80cee20a70a3577263faf28fd28dff734
-SIZE (snort3-libdaq-v3.0.0-alpha1_GH0.tar.gz) = 150809
+TIMESTAMP = 1567767906
+SHA256 (snort3-libdaq-v3.0.0-alpha2_GH0.tar.gz) = 9407968d3b1dd4a61356dd42cbd4a5de39f498a5242467e383769559d65d11c8
+SIZE (snort3-libdaq-v3.0.0-alpha2_GH0.tar.gz) = 153323
diff --git a/net/libdaq/files/patch-api_daq__common.h b/net/libdaq/files/patch-api_daq__common.h
new file mode 100644
index 000000000000..4268d0525d20
--- /dev/null
+++ b/net/libdaq/files/patch-api_daq__common.h
@@ -0,0 +1,12 @@
+--- api/daq_common.h.orig 2019-09-06 11:14:19 UTC
++++ api/daq_common.h
+@@ -30,6 +30,9 @@ extern "C" {
+ #include <sys/time.h>
+ #include <stdint.h>
+ #include <unistd.h>
++#if defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__DragonFly__)
++#include <sys/socket.h>
++#endif
+
+ #ifndef DAQ_SO_PUBLIC
+ # ifdef HAVE_VISIBILITY