aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/gcc295/Makefile6
-rw-r--r--mail/mailsync/Makefile8
2 files changed, 7 insertions, 7 deletions
diff --git a/lang/gcc295/Makefile b/lang/gcc295/Makefile
index ac71f565fec2..878eccc21eec 100644
--- a/lang/gcc295/Makefile
+++ b/lang/gcc295/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gcc
PORTVERSION= 2.95.3
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/${PKGNAME}
@@ -58,6 +59,11 @@ MAN1= cccp.1 g++295.1 gcc295.1
pre-patch:
@${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
+ @${MV} ${WRKSRC}/libstdc++/stl/stl_bvector.h \
+ ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig
+ @${SED} -e "s,_WORD_BIT,_WORD_BIT_GCC295,g" \
+ < ${WRKSRC}/libstdc++/stl/stl_bvector.h.orig \
+ > ${WRKSRC}/libstdc++/stl/stl_bvector.h
pre-configure:
@(MAJ=`/sbin/sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
diff --git a/mail/mailsync/Makefile b/mail/mailsync/Makefile
index ce4c8f24715e..f3d94e7d2056 100644
--- a/mail/mailsync/Makefile
+++ b/mail/mailsync/Makefile
@@ -27,12 +27,6 @@ ALL_TARGET= default
MAN1= mailsync.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
${WRKSRC}/examples/mailsync \
@@ -48,4 +42,4 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/mailsync ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>