aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-oembed/Makefile19
-rw-r--r--www/rubygem-oembed/distinfo3
-rw-r--r--www/rubygem-oembed/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 61c8d34cc352..b700178811e9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2041,6 +2041,7 @@
SUBDIR += rubygem-nicovideo
SUBDIR += rubygem-ntlm-http
SUBDIR += rubygem-octopress
+ SUBDIR += rubygem-oembed
SUBDIR += rubygem-ostatus2
SUBDIR += rubygem-pagerduty
SUBDIR += rubygem-passenger
diff --git a/www/rubygem-oembed/Makefile b/www/rubygem-oembed/Makefile
new file mode 100644
index 000000000000..b82278a6dd67
--- /dev/null
+++ b/www/rubygem-oembed/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= oembed
+PORTVERSION= 0.2.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Slim library to work with oEmbed format
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-oembed/distinfo b/www/rubygem-oembed/distinfo
new file mode 100644
index 000000000000..a8e17baa0c22
--- /dev/null
+++ b/www/rubygem-oembed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492174164
+SHA256 (rubygem/oembed-0.2.0.gem) = 8542cbc249bfbe3f292b885ed740026490421b163105302f5eaec74c9ec6dc48
+SIZE (rubygem/oembed-0.2.0.gem) = 11264
diff --git a/www/rubygem-oembed/pkg-descr b/www/rubygem-oembed/pkg-descr
new file mode 100644
index 000000000000..47d4e977c2ed
--- /dev/null
+++ b/www/rubygem-oembed/pkg-descr
@@ -0,0 +1,8 @@
+oEmbed is a format for allowing an embedded representation of a URL on third
+party sites. The simple API allows a website to display embedded content (such
+as photos or videos) when a user posts a link to that resource, without having
+to parse the resource directly. This gem is a simple-to-use and slim library to
+work with oEmbed format. It has no external dependencies at runtime. All you
+need to have is Ruby itself.
+
+WWW: http://soulim.github.com/oembed/