aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-PDF-Reuse/Makefile26
-rw-r--r--textproc/p5-PDF-Reuse/distinfo3
-rw-r--r--textproc/p5-PDF-Reuse/pkg-descr8
-rw-r--r--textproc/p5-PDF-Reuse/pkg-plist69
5 files changed, 107 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 65bcfdabd6dd..9331e988e746 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -685,6 +685,7 @@
SUBDIR += p5-PDF-API3
SUBDIR += p5-PDF-Create
SUBDIR += p5-PDF-FromHTML
+ SUBDIR += p5-PDF-Reuse
SUBDIR += p5-PDF-Table
SUBDIR += p5-PDF-Tiny
SUBDIR += p5-PDF-WebKit
diff --git a/textproc/p5-PDF-Reuse/Makefile b/textproc/p5-PDF-Reuse/Makefile
new file mode 100644
index 000000000000..0def3cc543c9
--- /dev/null
+++ b/textproc/p5-PDF-Reuse/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= PDF-Reuse
+DISTVERSION= 0.39
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gehm@doom-labs.net
+COMMENT= Another perl module to reuse and mass produce PDF documents
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-IO-Compress>=0:archivers/p5-IO-Compress \
+ p5-Exporter>=0:devel/p5-Exporter \
+ p5-AutoLoader>=0:devel/p5-AutoLoader \
+ p5-Carp>=0:devel/p5-Carp \
+ p5-Digest-MD5>=0:security/p5-Digest-MD5 \
+ p5-Font-TTF>=0:x11-fonts/p5-Font-TTF\
+ p5-Text-PDF>=0:print/p5-Text-PDF
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-PDF-Reuse/distinfo b/textproc/p5-PDF-Reuse/distinfo
new file mode 100644
index 000000000000..4dc32bcebc05
--- /dev/null
+++ b/textproc/p5-PDF-Reuse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1485788783
+SHA256 (PDF-Reuse-0.39.tar.gz) = 93e3a21851d9f8a5b5c93e84c1796e6c2f3ef999e0f4c819723840c4dbbc9d07
+SIZE (PDF-Reuse-0.39.tar.gz) = 64884
diff --git a/textproc/p5-PDF-Reuse/pkg-descr b/textproc/p5-PDF-Reuse/pkg-descr
new file mode 100644
index 000000000000..94b1297e90ec
--- /dev/null
+++ b/textproc/p5-PDF-Reuse/pkg-descr
@@ -0,0 +1,8 @@
+PDF::Reuse - Reuse and mass produce PDF documents
+
+This module could be used when you want to mass produce similar (but not
+identical) PDF documents and reuse templates, JavaScripts and some other
+components. It is functional to be fast, and to give your programs capacity to
+produce many pages per second and very big PDF documents if necessary.
+
+WWW: http://search.cpan.org/dist/PDF-Reuse/
diff --git a/textproc/p5-PDF-Reuse/pkg-plist b/textproc/p5-PDF-Reuse/pkg-plist
new file mode 100644
index 000000000000..b5861f466366
--- /dev/null
+++ b/textproc/p5-PDF-Reuse/pkg-plist
@@ -0,0 +1,69 @@
+%%SITE_PERL%%/PDF/Reuse.pm
+%%SITE_PERL%%/PDF/Reuse/Util.pm
+%%SITE_PERL%%/PDF/Util/graphObj_pl
+%%SITE_PERL%%/PDF/Util/reuseComponent_pl
+%%SITE_PERL%%/auto/PDF/Reuse/AcroFormsEtc.al
+%%SITE_PERL%%/auto/PDF/Reuse/analysera.al
+%%SITE_PERL%%/auto/PDF/Reuse/autosplit.ix
+%%SITE_PERL%%/auto/PDF/Reuse/behandlaNames.al
+%%SITE_PERL%%/auto/PDF/Reuse/byggForm.al
+%%SITE_PERL%%/auto/PDF/Reuse/calcMatrix.al
+%%SITE_PERL%%/auto/PDF/Reuse/checkContentStream.al
+%%SITE_PERL%%/auto/PDF/Reuse/checkResources.al
+%%SITE_PERL%%/auto/PDF/Reuse/createCharProcs.al
+%%SITE_PERL%%/auto/PDF/Reuse/crossrefObj.al
+%%SITE_PERL%%/auto/PDF/Reuse/defInit.al
+%%SITE_PERL%%/auto/PDF/Reuse/defLadda.al
+%%SITE_PERL%%/auto/PDF/Reuse/descend.al
+%%SITE_PERL%%/auto/PDF/Reuse/errLog.al
+%%SITE_PERL%%/auto/PDF/Reuse/extractName.al
+%%SITE_PERL%%/auto/PDF/Reuse/extractObject.al
+%%SITE_PERL%%/auto/PDF/Reuse/fillTheForm.al
+%%SITE_PERL%%/auto/PDF/Reuse/findBarFont.al
+%%SITE_PERL%%/auto/PDF/Reuse/findDir.al
+%%SITE_PERL%%/auto/PDF/Reuse/getImage.al
+%%SITE_PERL%%/auto/PDF/Reuse/getKnown.al
+%%SITE_PERL%%/auto/PDF/Reuse/getObject.al
+%%SITE_PERL%%/auto/PDF/Reuse/getPage.al
+%%SITE_PERL%%/auto/PDF/Reuse/inkludera.al
+%%SITE_PERL%%/auto/PDF/Reuse/kolla.al
+%%SITE_PERL%%/auto/PDF/Reuse/mergeLinks.al
+%%SITE_PERL%%/auto/PDF/Reuse/ordnaBookmarks.al
+%%SITE_PERL%%/auto/PDF/Reuse/prAltJpeg.al
+%%SITE_PERL%%/auto/PDF/Reuse/prBar.al
+%%SITE_PERL%%/auto/PDF/Reuse/prBookmark.al
+%%SITE_PERL%%/auto/PDF/Reuse/prCid.al
+%%SITE_PERL%%/auto/PDF/Reuse/prCompress.al
+%%SITE_PERL%%/auto/PDF/Reuse/prDoc.al
+%%SITE_PERL%%/auto/PDF/Reuse/prDocDir.al
+%%SITE_PERL%%/auto/PDF/Reuse/prDocForm.al
+%%SITE_PERL%%/auto/PDF/Reuse/prExtract.al
+%%SITE_PERL%%/auto/PDF/Reuse/prField.al
+%%SITE_PERL%%/auto/PDF/Reuse/prGetLogBuffer.al
+%%SITE_PERL%%/auto/PDF/Reuse/prGraphState.al
+%%SITE_PERL%%/auto/PDF/Reuse/prId.al
+%%SITE_PERL%%/auto/PDF/Reuse/prIdType.al
+%%SITE_PERL%%/auto/PDF/Reuse/prImage.al
+%%SITE_PERL%%/auto/PDF/Reuse/prInit.al
+%%SITE_PERL%%/auto/PDF/Reuse/prInitVars.al
+%%SITE_PERL%%/auto/PDF/Reuse/prJpeg.al
+%%SITE_PERL%%/auto/PDF/Reuse/prJs.al
+%%SITE_PERL%%/auto/PDF/Reuse/prLink.al
+%%SITE_PERL%%/auto/PDF/Reuse/prLog.al
+%%SITE_PERL%%/auto/PDF/Reuse/prLogDir.al
+%%SITE_PERL%%/auto/PDF/Reuse/prMbox.al
+%%SITE_PERL%%/auto/PDF/Reuse/prSinglePage.al
+%%SITE_PERL%%/auto/PDF/Reuse/prTouchUp.al
+%%SITE_PERL%%/auto/PDF/Reuse/prVers.al
+%%SITE_PERL%%/auto/PDF/Reuse/prep.al
+%%SITE_PERL%%/auto/PDF/Reuse/quickxform.al
+%%SITE_PERL%%/auto/PDF/Reuse/sidAnalys.al
+%%SITE_PERL%%/auto/PDF/Reuse/skrivJS.al
+%%SITE_PERL%%/auto/PDF/Reuse/skrivKedja.al
+%%SITE_PERL%%/auto/PDF/Reuse/translate.al
+%%SITE_PERL%%/auto/PDF/Reuse/unZipPrepare.al
+%%SITE_PERL%%/auto/PDF/Reuse/xRefs.al
+%%SITE_PERL%%/auto/PDF/Reuse/xform.al
+%%SITE_PERL%%/auto/PDF/Reuse/xrefSection.al
+%%PERL5_MAN3%%/PDF::Reuse.3.gz
+%%PERL5_MAN3%%/PDF::Reuse::Util.3.gz